aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2013-05-10 15:53:52 -0600
committerNicolas Bock <nicolasbock@gmail.com>2013-05-10 15:53:52 -0600
commit1d40023814ab26ee8e869b34cc020cdb58f31d1e (patch)
treeadd5db940894c182cd6a5e921f19d070fcd2e3ba /sci-physics
parentCleaned up the make command line arguments. (diff)
downloadsci-1d40023814ab26ee8e869b34cc020cdb58f31d1e.tar.gz
sci-1d40023814ab26ee8e869b34cc020cdb58f31d1e.tar.bz2
sci-1d40023814ab26ee8e869b34cc020cdb58f31d1e.zip
Added more use flags to control the build process.
It seems, at least on my system, that the LAMMPS_MEMALIGN option is a guarantee for a segfault. I made the use of this macro optional. Package-Manager: portage-2.2.0_alpha174
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lammps/ChangeLog6
-rw-r--r--sci-physics/lammps/lammps-20130512.ebuild7
-rw-r--r--sci-physics/lammps/metadata.xml5
3 files changed, 16 insertions, 2 deletions
diff --git a/sci-physics/lammps/ChangeLog b/sci-physics/lammps/ChangeLog
index 7beafc68c..b78b53547 100644
--- a/sci-physics/lammps/ChangeLog
+++ b/sci-physics/lammps/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 May 2013; Nicolas Bock <nicolasbock@gmail.com> lammps-20130512.ebuild,
+ metadata.xml:
+ Added more use flags to control the build process. It seems, at least on my
+ system, that the LAMMPS_MEMALIGN option is a guarantee for a segfault. I made
+ the use of this macro optional.
+
10 May 2013; Nicolas Bock <nicolasbock@gmail.com> lammps-20130512.ebuild:
Cleaned up the make command line arguments.
diff --git a/sci-physics/lammps/lammps-20130512.ebuild b/sci-physics/lammps/lammps-20130512.ebuild
index 28d26e4e6..878d095e0 100644
--- a/sci-physics/lammps/lammps-20130512.ebuild
+++ b/sci-physics/lammps/lammps-20130512.ebuild
@@ -15,18 +15,21 @@ SRC_URI="http://lammps.sandia.gov/tars/lammps-${LAMMPSDATE}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="package-meam package-dipole package-rigid"
+IUSE="lammps-gzip lammps-memalign package-meam package-dipole package-rigid"
DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${LAMMPSDATE}"
-LAMMPS_INCLUDEFLAGS="-DLAMMPS_GZIP -DLAMMPS_MEMALIGN"
+LAMMPS_INCLUDEFLAGS=""
src_prepare() {
epatch "${FILESDIR}/Makefile.gentoo-serial.patch"
+ use lammps-gzip && LAMMPS_INCLUDEFLAGS+=" -DLAMMPS_GZIP"
+ use lammps-memalign && LAMMPS_INCLUDEFLAGS+=" -DLAMMPS_MEMALIGN"
+
# Patch up the patch.
sed -i \
-e "s/ARCHIVE\s*=.*$/ARCHIVE = $(tc-getAR)/" \
diff --git a/sci-physics/lammps/metadata.xml b/sci-physics/lammps/metadata.xml
index 58f101120..4b180209a 100644
--- a/sci-physics/lammps/metadata.xml
+++ b/sci-physics/lammps/metadata.xml
@@ -16,6 +16,11 @@
code is designed to be easy to modify or extend with new functionality.
</longdescription>
<use>
+ <flag name="lammps-gzip">The read_data and dump commands will read/write
+ gzipped files</flag>
+ <flag name="lammps-memalign">Enables the use of the posix_memalign()
+ call instead of malloc() when large chunks or memory are allocated
+ by LAMMPS</flag>
<flag name="package-meam">modified EAM potential</flag>
<flag name="package-dipole">point dipole particles</flag>
<flag name="package-rigid">rigid bodies</flag>