aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-09-03 18:03:54 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2014-09-03 18:03:54 +0200
commitc148a2bc2eb5b55abe7f2beba23af4d27c9fe0c3 (patch)
tree88f30506d19374111d6e47de69d7db484bc97550 /sci-physics
parentsci-mathematics/giac: silence repoman, fix metadata.xml (diff)
downloadsci-c148a2bc2eb5b55abe7f2beba23af4d27c9fe0c3.tar.gz
sci-c148a2bc2eb5b55abe7f2beba23af4d27c9fe0c3.tar.bz2
sci-c148a2bc2eb5b55abe7f2beba23af4d27c9fe0c3.zip
sci-physics/tauola: version bump
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/tauola/ChangeLog7
-rw-r--r--sci-physics/tauola/Manifest1
-rw-r--r--sci-physics/tauola/tauola-1.1.5.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/sci-physics/tauola/ChangeLog b/sci-physics/tauola/ChangeLog
index db5d905a4..f94bace3f 100644
--- a/sci-physics/tauola/ChangeLog
+++ b/sci-physics/tauola/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-physics/tauola
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*tauola-1.1.5 (03 Sep 2014)
+
+ 03 Sep 2014; Jauhien Piatlicki <jauhien@gentoo.org> +tauola-1.1.5.ebuild:
+ version bump
+
13 Dec 2013; Justin Lecher <jlec@gentoo.org> tauola-1.1.3.ebuild,
tauola-1.1.4.ebuild, tauola-9999.ebuild, metadata.xml:
Some minor formatting improvments
diff --git a/sci-physics/tauola/Manifest b/sci-physics/tauola/Manifest
index 46c311b09..a797d16ef 100644
--- a/sci-physics/tauola/Manifest
+++ b/sci-physics/tauola/Manifest
@@ -1,2 +1,3 @@
DIST TAUOLA.1.1.3.tar.gz 7152535 SHA256 9b9141a6460477e6cb3c53845f384740539e54540130f69373268b7c2995defc SHA512 ca0c67d61d8476715788ebd7f145bea86ffce2d2a6f5590d66dfd14551fe817d97b1527f6d160b2ea2dc195f1af478f80a5644408e4c1da5ac0ecdbaccc20624 WHIRLPOOL 1ec2b22da2e12ecc400f174ba2fe40bc2bc24e0495f0ae793b2211a5f1dcdc600f31543056a9c9900fe4d049222046604e789ec2eb809a927b26c66ff7d636da
DIST TAUOLA.1.1.4.tar.gz 8643019 SHA256 224c0faa113f91bca62002cb7e405a8eeccfa938e49a62c146441af0ec5f6f30 SHA512 a03873925b35b16a10d8728b42ad0460d2424d879925da6b1d45dd8f88a86ac9729538e2d3a06faa0a7f70b7b0a80fa7b87bed14a82b2aae74663008c1ce5025 WHIRLPOOL 1562e99f364ae614e79c9f52042fedf89fae3edf1e25111de2e7f37ca48fd39a9d22990aae917d7477f203aa090a87930482560a76271935688bfcd5f4ed1c99
+DIST TAUOLA.1.1.5.tar.gz 11986900 SHA256 c6b026ce1b85ac72537882155aa0a5e5be6ee81e37bd469cc176bc55454541cb SHA512 1eb6e4b9b649cdd62b77d65899ae3e74cfdd0e8015d115690c020a06f0ff27c22a745db7c7acb12eeffacb9140b069c57c4135037eaf8feb26f8be32aced182a WHIRLPOOL 6f02400efe92f9730fe9b1b9ea4c519c6f06351588a6ad1266d456314564c410583315f418935c8b2252fa22169c569b5334759732dd2027911dbd9699890311
diff --git a/sci-physics/tauola/tauola-1.1.5.ebuild b/sci-physics/tauola/tauola-1.1.5.ebuild
new file mode 100644
index 000000000..cd7c85474
--- /dev/null
+++ b/sci-physics/tauola/tauola-1.1.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+MYPN=TAUOLA
+
+DESCRIPTION="tau decay Monte Carlo generator"
+HOMEPAGE="http://tauolapp.web.cern.ch/tauolapp/"
+SRC_URI="http://tauolapp.web.cern.ch/tauolapp/resources/${MYPN}.${PV}/${MYPN}.${PV}.tar.gz"
+
+#HepMC interface is licensed under GPL, other code under CPC
+LICENSE="CPC GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples hepmc tau-spinner"
+
+RDEPEND="
+ hepmc? ( sci-physics/hepmc )
+ tau-spinner? ( sci-physics/lhapdf )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ app-text/ghostscript-gpl
+ app-text/texlive )
+"
+
+S="${WORKDIR}/${MYPN}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1.4-makefile.patch \
+ "${FILESDIR}"/${PN}-1.1.3-tau-spinner-makefile.patch
+}
+
+src_configure() {
+ econf \
+ --without-mc-tester \
+ --without-pythia8 \
+ $(use_with hepmc hepmc "${EPREFIX}/usr") \
+ $(use_with tau-spinner) \
+ $(use_with tau-spinner lhapdf "${EPREFIX}/usr")
+}
+
+src_compile() {
+ emake -j1
+ if use doc; then
+ cd "${S}/documentation/doxy_documentation" || die
+ emake
+ cd "${S}/documentation/latex_documentation" || die
+ emake
+ fi
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+
+ if use doc; then
+ dohtml documentation/doxy_documentation/html/*
+ dodoc documentation/latex_documentation/Tauola_interface_design.pdf
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ use tau-spinner && docinto tau-spinner && dodoc -r TauSpinner/examples
+ fi
+}