aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@users.noreply.github.com>2013-12-02 05:11:27 -0800
committerJustin <jlec@users.noreply.github.com>2013-12-02 05:11:27 -0800
commite27f5c86e55b50e3a44e5ac5406520cc14c02364 (patch)
tree0eea6ddddb9a50843baf3099f23fb14b6db49208 /sci-physics
parentMerge pull request #149 from akreal/openfst (diff)
parentsci-physics/mc-tester: ebuild improvements, thanks to jlec (diff)
downloadsci-e27f5c86e55b50e3a44e5ac5406520cc14c02364.tar.gz
sci-e27f5c86e55b50e3a44e5ac5406520cc14c02364.tar.bz2
sci-e27f5c86e55b50e3a44e5ac5406520cc14c02364.zip
Merge pull request #146 from jauhien/mc-tester-1.25.0
sci-physics/mc-tester: ebuild added
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/mc-tester/ChangeLog11
-rw-r--r--sci-physics/mc-tester/Manifest1
-rw-r--r--sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch30
-rw-r--r--sci-physics/mc-tester/mc-tester-1.25.0.ebuild65
-rw-r--r--sci-physics/mc-tester/metadata.xml16
5 files changed, 123 insertions, 0 deletions
diff --git a/sci-physics/mc-tester/ChangeLog b/sci-physics/mc-tester/ChangeLog
new file mode 100644
index 000000000..e93c066f9
--- /dev/null
+++ b/sci-physics/mc-tester/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-physics/mc-tester
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mc-tester-1.25.0 (20 Nov 2013)
+
+ 20 Nov 2013; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
+ +mc-tester-1.25.0.ebuild, +files/mc-tester-1.25.0-compare.sh.patch,
+ +metadata.xml:
+ Ebuild for sci-physics/mc-tester added
+
diff --git a/sci-physics/mc-tester/Manifest b/sci-physics/mc-tester/Manifest
new file mode 100644
index 000000000..baeebc68d
--- /dev/null
+++ b/sci-physics/mc-tester/Manifest
@@ -0,0 +1 @@
+DIST MC-TESTER-1.25.0.tar.gz 4298408 SHA256 21736b8ec317f39caa0fab2d53635a10ddafef4b675839f5d4a46eef4b9ce587 SHA512 0cd529e05ae18f7f2fe62251b11fbdc62ce7c0cbb59218b56d682f854c731713ce72b8baf5a08ca0b359dc4600e6b411f165827b2d9829b98e1d3dbace78fbb0 WHIRLPOOL 233d0e5b25cbf1527d58e95c0ed32d2fa71fcc519027f526d179e8b323d567836287574f08786836f9f1440dce70bc9a5086da8335e497687b6d685804700656
diff --git a/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
new file mode 100644
index 000000000..180dcb029
--- /dev/null
+++ b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
@@ -0,0 +1,30 @@
+--- analyze/compare.sh
++++ analyze/compare.sh
+@@ -6,13 +6,14 @@
+ #----------------------------------
+ # Change these variables
+ #----------------------------------
+-FILE1=mc-tester.root #first generation step file
+-FILE2=mc-tester2.root #second generation step file
+-MCTESTER_DIR= #location of MC-TESTER
++FILE1="${1}" #first generation step file
++FILE2="${2}" #second generation step file
++MCTESTER_DIR=/usr #location of MC-TESTER
+
+ #----------------------------------
+
+-MCTESTER_ANALYZE_DIR=${MCTESTER_DIR}/analyze
++MCTESTER_ANALYZE_DIR=${MCTESTER_DIR}/libexec/mc-tester/analyze
++MCTESTER_DATA_DIR=${MCTESTER_DIR}/share/mc-tester
+ export MC_TESTER_LIBS_DIR=${MCTESTER_DIR}/lib
+
+ WORKING_DIR=`pwd`
+@@ -24,7 +25,7 @@
+ cd $WORKING_DIR
+
+ #copy base .tex file needed for booklet and create
+-cp ${MCTESTER_ANALYZE_DIR}/tester.tex ./
++cp ${MCTESTER_DATA_DIR}/tester.tex ./
+ latex tester.tex
+ latex tester.tex
+ latex tester.tex
diff --git a/sci-physics/mc-tester/mc-tester-1.25.0.ebuild b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
new file mode 100644
index 000000000..43f835d4d
--- /dev/null
+++ b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+MYPN=MC-TESTER
+
+DESCRIPTION="A universal tool for comparisons of Monte Carlo predictions in High Energy Physics"
+HOMEPAGE="http://mc-tester.web.cern.ch/MC-TESTER/"
+SRC_URI="http://mc-tester.web.cern.ch/MC-TESTER/${MYPN}-${PV}.tar.gz"
+LICENSE="CPC GPL-2+"
+#HepMC interface is licensed under GPL, other code under CPC
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples hepmc"
+
+RDEPEND="sci-physics/root
+ hepmc? ( sci-physics/hepmc )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MYPN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-compare.sh.patch"
+}
+
+src_configure() {
+ econf \
+ --with-root="${EPREFIX}/usr" \
+ --without-Pythia8 \
+ $(use_with hepmc HepMC "${EPREFIX}/usr")
+}
+
+src_compile() {
+ emake
+ use doc && cd doc && emake
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ newbin analyze/compare.sh mc-tester-compare
+
+ insinto /usr/libexec/${PN}/analyze
+ doins analyze/*.C
+ insinto /usr/share/${PN}
+ doins analyze/*.tex
+
+ if use doc; then
+ dohtml doc/doxygenDocs/html/*
+ dodoc doc/{README*,USER-TESTS,tester.ps.gz}
+ fi
+
+ use examples && dodoc -r examples-*
+}
+
+pkg_postinst() {
+ elog "A script to perform an analysis step is installed as /usr/bin/mc-tester-compare"
+ elog "it takes two root files with generation results as command line arguments"
+}
diff --git a/sci-physics/mc-tester/metadata.xml b/sci-physics/mc-tester/metadata.xml
new file mode 100644
index 000000000..2edb7b2ba
--- /dev/null
+++ b/sci-physics/mc-tester/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+
+<herd>sci-physics</herd>
+<maintainer>
+ <email>piatlicki@gmail.com</email>
+</maintainer>
+
+<longdescription>
+ A universal tool for comparisons of Monte Carlo predictions in High Energy Physics
+</longdescription>
+<use>
+ <flag name="hepmc">Compile <pkg>sci-physics/hepmc</pkg> interface</flag>
+</use>
+</pkgmetadata>