aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-11 21:10:51 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-11 21:16:53 +0200
commitd41d662b5ba3cc219d6e743f2938afa0f65f426c (patch)
treeeb40a37422d0d1e48edbfb08a28e3ba2d1e7aff6 /sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild
parentsci-visualization/fsleyes-widgets: add 0.12.3 (diff)
downloadsci-d41d662b5ba3cc219d6e743f2938afa0f65f426c.tar.gz
sci-d41d662b5ba3cc219d6e743f2938afa0f65f426c.tar.bz2
sci-d41d662b5ba3cc219d6e743f2938afa0f65f426c.zip
sci-visualization/fsleyes-props: add 1.8.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild')
-rw-r--r--sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild b/sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild
new file mode 100644
index 000000000..eff42e1bb
--- /dev/null
+++ b/sci-visualization/fsleyes-props/fsleyes-props-1.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+MY_PN="props"
+
+DESCRIPTION="Object attribute management for the FSLeyes viewer"
+HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
+SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/${MY_PN}/-/archive/${PV}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-3.0.2.0[${PYTHON_USEDEP}]
+ >=sci-visualization/fsleyes-widgets-0.6[${PYTHON_USEDEP}]
+ >=dev-python/fslpy-1.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # do not depend on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest || die "Tests failed with ${EPYTHON}"
+}