aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-24 16:07:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-24 16:07:37 +0100
commit43df0040d2daeed6edd9ea6a4f4e4038483d87b6 (patch)
tree871715d41790a92a681f79a387950e41c67e3d0b /sci-visualization/fsleyes-widgets
parentdev-perl/Bio-EnsEMBL: remove fundamentally broken package (diff)
downloadsci-43df0040d2daeed6edd9ea6a4f4e4038483d87b6.tar.gz
sci-43df0040d2daeed6edd9ea6a4f4e4038483d87b6.tar.bz2
sci-43df0040d2daeed6edd9ea6a4f4e4038483d87b6.zip
sci-visualization/fsleyes-widgets: bump to 0.12.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization/fsleyes-widgets')
-rw-r--r--sci-visualization/fsleyes-widgets/Manifest3
-rw-r--r--sci-visualization/fsleyes-widgets/fsleyes-widgets-0.12.2.ebuild (renamed from sci-visualization/fsleyes-widgets/fsleyes-widgets-0.9.0.ebuild)20
-rw-r--r--sci-visualization/fsleyes-widgets/fsleyes-widgets-0.8.4.ebuild47
3 files changed, 10 insertions, 60 deletions
diff --git a/sci-visualization/fsleyes-widgets/Manifest b/sci-visualization/fsleyes-widgets/Manifest
index bcfa8ba9a..f81be256c 100644
--- a/sci-visualization/fsleyes-widgets/Manifest
+++ b/sci-visualization/fsleyes-widgets/Manifest
@@ -1,2 +1 @@
-DIST fsleyes-widgets-0.8.4.tar.gz 1063873 BLAKE2B 75aca3b5a3b3726cee821016df5d5da4adcb3db0bbe3ad24c371e63215584bc6e47d1fc941344c44db8c6d32f21332be2541b74aca31c0efbcb34b46a7f872d8 SHA512 b3b3a5f1a963022f82456c2d6978e02e6f0eb459a76d3aa9f924dbb484ad8359fe9344e9d914c859bd213406707b1b3456de8543b1400728b84fb503ae1fddc8
-DIST fsleyes-widgets-0.9.0.tar.gz 1064093 BLAKE2B 2bdf0d60d1f04e0473dbbaead4d8d8285c7779eac00fb28851dea25dec55be20ffd7ea95a1c556b5b7be817e147ef0957312ffbd3ade5e0bf6bb791b2d41fec9 SHA512 b514b1d7652654da9aba3de5974ca6e3eb1d4b5dd5e321d7343a56fb9c1af2cce1d1c3672e30c4d48262d2f2cdb3993e890dee35cfe7dc98de340fe0463de100
+DIST fsleyes-widgets-0.12.2.tar.gz 1068565 BLAKE2B db322e7cadfef8d7ba5a63ed089a6979337837418afeb8e0cd10418a119f7e359a360b16dc2dc3756d1f353033d60b4387bff69b9dc864b515fab16daa939e6f SHA512 6c6da4bb2d61a1fe4cff8a7db887595de2df9b3e76984a0ab7492f859f8a47d14b4999e2a3e31c6f6e13f31b7557e55e6b04378dd970d227aa02920c250de088
diff --git a/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.9.0.ebuild b/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.12.2.ebuild
index 4e00e2e47..82a1e587c 100644
--- a/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.9.0.ebuild
+++ b/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.12.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1 virtualx
@@ -12,22 +12,20 @@ MY_P="widgets-${PV}"
DESCRIPTION="GUI widgets and utilities for the FSLeyes viewer"
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/-/archive/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-python/deprecation[${PYTHON_USEDEP}]
=dev-python/numpy-1*[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- =dev-python/six-1*[${PYTHON_USEDEP}]
- dev-python/wxpython[${PYTHON_USEDEP}]
- "
-
-S="${WORKDIR}/${MY_P}"
+ >=dev-python/matplotlib-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-3.0.2.0[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
python_prepare_all() {
# do not depend on pytest-cov
@@ -55,5 +53,5 @@ python_test() {
# If this could be set for the eclass, it might fix some of the tests:
# https://github.com/pauldmccarthy/fsleyes-widgets/issues/1#issuecomment-575387724
#xvfbargs="-screen 0 1920x1200x24 +extension RANDR"
- virtx pytest --verbose || die
+ virtx epytest
}
diff --git a/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.8.4.ebuild b/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.8.4.ebuild
deleted file mode 100644
index cbae95701..000000000
--- a/sci-visualization/fsleyes-widgets/fsleyes-widgets-0.8.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1 virtualx
-
-MY_P="widgets-${PV}"
-
-DESCRIPTION="GUI widgets and utilities for the FSLeyes viewer"
-HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
-SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/-/archive/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-RDEPEND="
- dev-python/deprecation[${PYTHON_USEDEP}]
- =dev-python/numpy-1*[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- =dev-python/six-1*[${PYTHON_USEDEP}]
- dev-python/wxpython[${PYTHON_USEDEP}]
- "
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/fsleyes-widgets-0.8.4-coverage.patch"
- "${FILESDIR}/fsleyes-widgets-0.8.4-tests.patch"
-)
-
-python_test() {
- # If this could be set for the eclass, it might fix some of the tests:
- # https://github.com/pauldmccarthy/fsleyes-widgets/issues/1#issuecomment-575387724
- #xvfbargs="-screen 0 1920x1200x24 +extension RANDR"
- virtx pytest --verbose || die
-}