aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-03-13 19:59:13 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-03-13 19:59:13 -0600
commit287070533eedbc60be4ed24f0174c3fd1197b5eb (patch)
treef69d12a799199ab54ebaac42242fa3f3521bf5cb /sci-visualization/gnuplot
parentsci-libs/mumps: Fixed for sequential (non mpi) libraries (diff)
downloadsci-287070533eedbc60be4ed24f0174c3fd1197b5eb.tar.gz
sci-287070533eedbc60be4ed24f0174c3fd1197b5eb.tar.bz2
sci-287070533eedbc60be4ed24f0174c3fd1197b5eb.zip
sci-visualization/gnuplot: clean up
(Portage version: 2.2.0_alpha90/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/ChangeLog4
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.4.9999.ebuild255
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild19
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild19
-rw-r--r--sci-visualization/gnuplot/metadata.xml2
5 files changed, 25 insertions, 274 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index b149287ea..fe614ead5 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Mar 2012; Christoph Junghans <ottxor@gentoo.org> -gnuplot-4.4.9999.ebuild,
+ gnuplot-4.6.9999.ebuild, gnuplot-4.7.9999.ebuild, metadata.xml:
+ sci-visualization/gnuplot: clean up
+
28 Jan 2012; Christoph Junghans <ottxor@gentoo.org> gnuplot-4.6.9999.ebuild,
gnuplot-4.7.9999.ebuild:
sync with tree and bug #400999#c7
diff --git a/sci-visualization/gnuplot/gnuplot-4.4.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.4.9999.ebuild
deleted file mode 100644
index 0445bf34e..000000000
--- a/sci-visualization/gnuplot/gnuplot-4.4.9999.ebuild
+++ /dev/null
@@ -1,255 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-inherit elisp-common multilib wxwidgets
-
-DESCRIPTION="Command-line driven interactive plotting program"
-HOMEPAGE="http://www.gnuplot.info/"
-
-if [[ -z ${PV%%*9999} ]]; then
- inherit autotools cvs
- ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot"
- ECVS_MODULE="gnuplot"
- ECVS_BRANCH="branch-4-4-stable"
- ECVS_USER="anonymous"
- ECVS_CVS_OPTIONS="-dP"
- MY_P="${PN}"
- SRC_URI=""
-else
- MY_P="${P/_/-}"
- SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
-fi
-
-LICENSE="gnuplot GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cairo doc emacs examples +gd ggi latex lua plotutils readline svga thin-splines wxwidgets X xemacs"
-
-RDEPEND="
- cairo? (
- x11-libs/cairo
- x11-libs/pango )
- emacs? ( virtual/emacs )
- gd? ( media-libs/gd[png] )
- ggi? ( media-libs/libggi )
- latex? (
- virtual/latex-base
- lua? (
- dev-tex/pgf
- >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
- lua? ( dev-lang/lua )
- plotutils? ( media-libs/plotutils )
- readline? ( sys-libs/readline )
- svga? ( media-libs/svgalib )
- wxwidgets? (
- x11-libs/wxGTK:2.8[X]
- x11-libs/cairo
- x11-libs/pango
- x11-libs/gtk+:2 )
- X? ( x11-libs/libXaw )
- xemacs? (
- app-editors/xemacs
- app-xemacs/xemacs-base )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? (
- virtual/latex-base
- app-text/ghostscript-gpl )
- !emacs? ( xemacs? ( app-xemacs/texinfo ) )
- !emacs? ( !xemacs? ( || ( virtual/emacs app-xemacs/texinfo ) ) )"
-
-RESTRICT="wxwidgets? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
-GP_VERSION="${PV%.*}"
-E_SITEFILE="50${PN}-gentoo.el"
-TEXMF="${EPREFIX}/usr/share/texmf-site"
-
-src_prepare() {
- if [[ -z ${PV%%*9999} ]]; then
- local dir
- for dir in config demo m4 term tutorial; do
- emake -C "$dir" -f Makefile.am.in Makefile.am || \
- die "make -f Makefile.am.in Makefile.am in $dir failed"
- done
- eautoreconf
- fi
-
- # Add special version identification as required by provision 2
- # of the gnuplot license
- sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
-}
-
-src_configure() {
- if ! use latex; then
- sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
- fi
-
- if use wxwidgets; then
- WX_GTK_VER="2.8"
- need-wxwidgets unicode
- fi
-
- local myconf
- myconf="${myconf} --without-lisp-files"
- myconf="${myconf} --without-pdf"
- myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
- myconf="${myconf} $(use_with cairo)"
- myconf="${myconf} $(use_with doc tutorial)"
- myconf="${myconf} $(use_with gd)"
- myconf="${myconf} $(use_with ggi ggi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with ggi xmi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with lua)"
- myconf="${myconf} $(use_with plotutils plot "${EPREFIX}"/usr/$(get_libdir))"
- myconf="${myconf} $(use_with svga linux-vga)"
- myconf="${myconf} $(use_enable thin-splines)"
- myconf="${myconf} $(use_enable wxwidgets)"
- myconf="${myconf} $(use_with X x)"
- use readline \
- && myconf="${myconf} --with-readline=gnu" \
- || myconf="${myconf} --with-readline=builtin"
-
- if has_version virtual/emacs; then
- emacs="emacs"
- elif has_version app-xemacs/texinfo; then
- emacs="xemacs"
- fi
-
- econf ${myconf} \
- DIST_CONTACT="http://bugs.gentoo.org/" \
- EMACS="${emacs}"
-
- if use xemacs; then
- einfo "Configuring gnuplot-mode for XEmacs ..."
- use emacs && cp -Rp lisp lisp-xemacs || ln -s lisp lisp-xemacs
- cd "${S}/lisp-xemacs"
- econf --with-lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/${PN}" EMACS=xemacs
- fi
-
- if use emacs; then
- einfo "Configuring gnuplot-mode for GNU Emacs ..."
- cd "${S}/lisp"
- econf --with-lispdir="${EPREFIX}${SITELISP}/${PN}" EMACS=emacs
- fi
-}
-
-src_compile() {
- # Prevent access violations, see bug 201871
- VARTEXFONTS="${T}/fonts"
-
- # This is a hack to avoid sandbox violations when using the Linux console.
- # Creating the DVI and PDF tutorials require /dev/svga to build the
- # example plots.
- addwrite /dev/svga:/dev/mouse:/dev/tts/0
-
- emake all info || die
-
- if use xemacs; then
- cd "${S}/lisp-xemacs"
- emake || die
- fi
-
- if use emacs; then
- cd "${S}/lisp"
- emake || die
- fi
-
- if use doc; then
- # Avoid sandbox violation in epstopdf/ghostscript
- addpredict /var/cache/fontconfig
- cd "${S}/docs"
- emake pdf || die
- cd "${S}/tutorial"
- emake pdf || die
-
- if use emacs || use xemacs; then
- cd "${S}/lisp"
- emake pdf || die
- fi
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die
-
- if use xemacs; then
- cd "${S}/lisp-xemacs"
- emake DESTDIR="${D}" install || die
- fi
-
- if use emacs; then
- cd "${S}/lisp"
- emake DESTDIR="${D}" install || die
- # info-look* is included with >=emacs-21
- rm -f "${ED}${SITELISP}/${PN}"/info-look*
-
- # Gentoo emacs site-lisp configuration
- echo "(add-to-list 'load-path \"@SITELISP@\")" > ${E_SITEFILE}
- sed '/^;; move/,+3 d' dotemacs >> ${E_SITEFILE} || die
- elisp-site-file-install ${E_SITEFILE} || die
- fi
-
- cd "${S}"
- dodoc BUGS ChangeLog NEWS PGPKEYS PORTING README* TODO
- newdoc term/PostScript/README README-ps
- newdoc term/js/README README-js
- use lua && newdoc term/lua/README README-lua
-
- if use examples; then
- # Demo files
- insinto /usr/share/${PN}/${GP_VERSION}
- doins -r demo || die
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
- fi
- if use doc; then
- # Manual
- dodoc docs/gnuplot.pdf
- # Tutorial
- dodoc tutorial/{tutorial.dvi,tutorial.pdf}
- # FAQ
- dodoc FAQ.pdf
- # Documentation for making PostScript files
- docinto psdoc
- dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
- fi
-
- if use emacs || use xemacs; then
- docinto emacs
- dodoc lisp/ChangeLog lisp/README
- use doc && dodoc lisp/gpelcard.pdf
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- use latex && texmf-update
-
- einfo "Gnuplot no longer links against pdflib, see the ChangeLog for"
- einfo "details. You can use the \"pdfcairo\" terminal for PDF output."
- use cairo || einfo "It is available with USE=\"cairo\"."
-
- if use svga; then
- echo
- einfo "In order to enable ordinary users to use SVGA console graphics"
- einfo "gnuplot needs to be set up as setuid root. Please note that"
- einfo "this is usually considered to be a security hazard."
- einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
- fi
- if use gd; then
- echo
- einfo "For font support in png/jpeg/gif output, you may have to"
- einfo "set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT environment"
- einfo "variables. See the FAQ file in /usr/share/doc/${PF}/"
- einfo "for more information."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use latex && texmf-update
-}
diff --git a/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
index 89556a7f4..d0ec7f615 100644
--- a/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.3 2012/01/27 16:05:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.7 2012/03/07 00:33:49 ulm Exp $
EAPI=4
@@ -23,10 +23,10 @@ else
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
fi
-LICENSE="gnuplot GPL-2"
+LICENSE="gnuplot GPL-2 bitmap? ( free-noncomm )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
+IUSE="bitmap cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
RESTRICT="wxwidgets? ( test )"
RDEPEND="
@@ -106,6 +106,7 @@ src_configure() {
myconf="${myconf} --without-pdf"
myconf="${myconf} --enable-stats" #extra command save to be enabled
myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
+ myconf="${myconf} $(use_with bitmap bitmap-terminals)"
myconf="${myconf} $(use_with cairo)"
myconf="${myconf} $(use_with doc tutorial)"
myconf="${myconf} $(use_with gd)"
@@ -124,8 +125,9 @@ src_configure() {
local emacs=$(usev emacs || usev xemacs || echo no)
if [[ -z ${PV%%*9999} && ${emacs} = no ]]; then
- #live ebuild needs an emacs to build texi
- has_version virtual/emacs && emacs="emacs" || emacs="xemacs"
+ # Live ebuild needs an Emacs to build gnuplot.texi
+ if has_version virtual/emacs; then emacs=emacs
+ elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
fi
econf ${myconf} \
@@ -150,10 +152,9 @@ src_compile() {
# Prevent access violations, see bug 201871
VARTEXFONTS="${T}/fonts"
- # This is a hack to avoid sandbox violations when using the Linux console.
- # Creating the DVI and PDF tutorials require /dev/svga to build the
- # example plots.
- addwrite /dev/svga:/dev/mouse:/dev/tts/0
+ # We believe that the following line is no longer needed.
+ # In case of problems file a bug report at bugs.gentoo.org.
+ #addwrite /dev/svga:/dev/mouse:/dev/tts/0
emake all info
diff --git a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
index 3cb5c178c..5a5541edc 100644
--- a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.3 2012/01/27 16:05:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.7 2012/03/07 00:33:49 ulm Exp $
EAPI=4
@@ -23,10 +23,10 @@ else
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
fi
-LICENSE="gnuplot GPL-2"
+LICENSE="gnuplot GPL-2 bitmap? ( free-noncomm )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
+IUSE="bitmap cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
RESTRICT="wxwidgets? ( test )"
RDEPEND="
@@ -106,6 +106,7 @@ src_configure() {
myconf="${myconf} --without-pdf"
myconf="${myconf} --enable-stats" #extra command save to be enabled
myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
+ myconf="${myconf} $(use_with bitmap bitmap-terminals)"
myconf="${myconf} $(use_with cairo)"
myconf="${myconf} $(use_with doc tutorial)"
myconf="${myconf} $(use_with gd)"
@@ -124,8 +125,9 @@ src_configure() {
local emacs=$(usev emacs || usev xemacs || echo no)
if [[ -z ${PV%%*9999} && ${emacs} = no ]]; then
- #live ebuild needs an emacs to build texi
- has_version virtual/emacs && emacs="emacs" || emacs="xemacs"
+ # Live ebuild needs an Emacs to build gnuplot.texi
+ if has_version virtual/emacs; then emacs=emacs
+ elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
fi
econf ${myconf} \
@@ -150,10 +152,9 @@ src_compile() {
# Prevent access violations, see bug 201871
VARTEXFONTS="${T}/fonts"
- # This is a hack to avoid sandbox violations when using the Linux console.
- # Creating the DVI and PDF tutorials require /dev/svga to build the
- # example plots.
- addwrite /dev/svga:/dev/mouse:/dev/tts/0
+ # We believe that the following line is no longer needed.
+ # In case of problems file a bug report at bugs.gentoo.org.
+ #addwrite /dev/svga:/dev/mouse:/dev/tts/0
emake all info
diff --git a/sci-visualization/gnuplot/metadata.xml b/sci-visualization/gnuplot/metadata.xml
index b66be8a3b..9f5fba32b 100644
--- a/sci-visualization/gnuplot/metadata.xml
+++ b/sci-visualization/gnuplot/metadata.xml
@@ -13,6 +13,6 @@
<flag name="gd">Add support for <pkg>media-libs/gd</pkg>.
Needed for GIF, JPEG, and PNG image output.</flag>
<flag name="thin-splines">Enable thin plate splines</flag>
- <flag name="qt4">Build Qt4 terminal</flag>
+ <flag name="bitmap">Enable dot-matrix printers and pbm terminal</flag>
</use>
</pkgmetadata>