aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <debdepba@dasganma.tk>2015-01-27 20:04:04 +0000
committerChris Kerr <debdepba@dasganma.tk>2015-01-27 20:04:04 +0000
commit20c442d83ee5b393544614e7148de4d222c2be2d (patch)
tree5edeb5483bbcb8b2f859130f57c49039f4327831 /sci-visualization/mantid
parentSome changes to dependencies on inspection of the website (diff)
downloadsci-20c442d83ee5b393544614e7148de4d222c2be2d.tar.gz
sci-20c442d83ee5b393544614e7148de4d222c2be2d.tar.bz2
sci-20c442d83ee5b393544614e7148de4d222c2be2d.zip
src_test requires `make AllTests`
Diffstat (limited to 'sci-visualization/mantid')
-rw-r--r--sci-visualization/mantid/mantid-3.3.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-visualization/mantid/mantid-3.3.0.ebuild b/sci-visualization/mantid/mantid-3.3.0.ebuild
index 58f2eb060..56b8eda93 100644
--- a/sci-visualization/mantid/mantid-3.3.0.ebuild
+++ b/sci-visualization/mantid/mantid-3.3.0.ebuild
@@ -74,4 +74,10 @@ src_configure() {
$(cmake-utils_use_build test TESTING)
)
cmake-utils_src_configure
-} \ No newline at end of file
+}
+
+src_test() {
+ # Tests are not built by default
+ emake AllTests
+ cmake-utils_src_test
+}