aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-18 16:28:54 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-18 16:28:54 +0000
commit5e2019f74083ff85b519c8cf0e71f5cbae2a79bf (patch)
tree79727f67f8a1ca0cff860987ca7f2c3a816d3563 /sci-visualization/qtiplot
parentInitial import of xtide. A tidal prediction program that has graphical inter... (diff)
downloadsci-5e2019f74083ff85b519c8cf0e71f5cbae2a79bf.tar.gz
sci-5e2019f74083ff85b519c8cf0e71f5cbae2a79bf.tar.bz2
sci-5e2019f74083ff85b519c8cf0e71f5cbae2a79bf.zip
qtiplot-0.9.6 is now in the main tree
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1070 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-visualization/qtiplot')
-rw-r--r--sci-visualization/qtiplot/ChangeLog190
-rw-r--r--sci-visualization/qtiplot/Manifest7
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch32
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch72
-rw-r--r--sci-visualization/qtiplot/metadata.xml15
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.6.ebuild103
6 files changed, 0 insertions, 419 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
deleted file mode 100644
index 7b3199b42..000000000
--- a/sci-visualization/qtiplot/ChangeLog
+++ /dev/null
@@ -1,190 +0,0 @@
-# ChangeLog for sci-visualization/qtiplot
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
-*qtiplot-0.9.6 (14 May 2008)
-
- 14 May 2008; Andrey Grozin <grozin@gentoo.org>
- +qtiplot-0.9.6.ebuild, +files/qtiplot-0.9.6-profile.patch,
- +files/qtiplot-0.9.6-fitplugins.patch:
- Version bump.
-
-*qtiplot-0.9.5-r1 (30 Apr 2008)
-
- 30 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
- files/qtiplot-0.9.5-profile.patch, +qtiplot-0.9.5-r1.ebuild:
- Fixed installation for binary and translations, closing bug #219845
-
-*qtiplot-0.9.5 (29 Apr 2008)
-
- 29 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
- -files/qtiplot-0.9.3-homepage.patch,
- -files/qtiplot-0.9.3-systemlibs.patch,
- +files/qtiplot-0.9.5-fitplugins.patch, +files/qtiplot-0.9.5-profile.patch,
- qtiplot-0.7.7.ebuild, -qtiplot-0.9.3.ebuild, qtiplot-0.9.4.ebuild,
- +qtiplot-0.9.5.ebuild:
- Version bump. Separated patches for fit plugins and qtiplot.pro for better
- re-usability
-
-*qtiplot-0.9.4 (28 Mar 2008)
-
- 28 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
- +files/qtiplot-0.9.4-systemlibs.patch, -qtiplot-0.9.2.ebuild,
- -qtiplot-0.9.2-r1.ebuild, +qtiplot-0.9.4.ebuild:
- Version bump. Thanks Dieter Ries for the update (closing bug #215192).
- Removed older versions.
-
- 15 Mar 2008; Markus Rothe <corsair@gentoo.org> qtiplot-0.9.3.ebuild:
- Added ~ppc64
-
- 10 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> Manifest:
- Fixed doc file on mirror, bug #212599
-
-*qtiplot-0.9.3 (07 Mar 2008)
-
- 07 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
- +files/qtiplot-0.9.3-homepage.patch,
- +files/qtiplot-0.9.3-systemlibs.patch, qtiplot-0.9.2.ebuild,
- +qtiplot-0.9.3.ebuild:
- Version bump
-
- 13 Feb 2008; Markus Dittrich <markusle@gentoo.org> qtiplot-0.7.7.ebuild,
- qtiplot-0.8.5.ebuild, qtiplot-0.9.2.ebuild, qtiplot-0.9.2-r1.ebuild:
- Fixed QA issues and added bindist for >=gsl-1.10 (see bug #199451).
-
-*qtiplot-0.9.2-r1 (12 Feb 2008)
-
- 12 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
- files/qtiplot-0.9.2-systemlibs.patch, +qtiplot-0.9.2-r1.ebuild:
- Fixed installation of plugins, fixed non-installation of python scripts,
- translations, some cleanup
-
- 14 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
- files/qtiplot-0.9.2-systemlibs.patch, qtiplot-0.9.2.ebuild:
- Removed spanish manual (incomplete), added english one on mirror (closing
- bug #205366), fixed patch to use pkg-config for gsl, therefore possibly using
- external cblas library.
-
-*qtiplot-0.9.2 (03 Dec 2007)
-
- 03 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
- -files/qtiplot-0.9.1-systemlibs.patch,
- +files/qtiplot-0.9.2-systemlibs.patch, -qtiplot-0.9.1.ebuild,
- +qtiplot-0.9.2.ebuild:
- Version bump. Removed 0.9.1 because many issues and missing doc upstream.
- python-2.5 now only needed if python flag set.
-
-*qtiplot-0.9.1 (28 Nov 2007)
-
- 28 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org>
- -files/qtiplot-0.8.2-qmake.patch, +files/qtiplot-0.9.1-systemlibs.patch,
- qtiplot-0.7.7.ebuild, -qtiplot-0.8.2.ebuild, qtiplot-0.8.5.ebuild,
- +qtiplot-0.9.1.ebuild:
- Version bump. Now uses qt4. Closing bug #144286, thanks everyone and
- especially Andrey Grozin for maintaining in the science overlay.
- Dropped ppc and ppc64, untested for now.
-
- 22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
- Redigest for Manifest2
-
-*qtiplot-0.8.5 (26 May 2006)
-
- 26 May 2006; Marcus D. Hanwell <cryos@gentoo.org>
- -files/qtiplot-0.8.4-qmake.patch, +files/qtiplot-0.8.5-qmake.patch,
- -qtiplot-0.8.4.ebuild, +qtiplot-0.8.5.ebuild:
- Version bump, thanks to Andrey Grozin <A.G.Grozin@inp.nsk.su> for ebuild
- imrpovements first implemented in the sci overlay.
-
-*qtiplot-0.8.4 (18 May 2006)
-
- 18 May 2006; Marcus D. Hanwell <cryos@gentoo.org>
- +files/qtiplot-0.8.4-qmake.patch, +qtiplot-0.8.4.ebuild:
- Version bump.
-
- 07 May 2006; Markus Rothe <corsair@gentoo.org> qtiplot-0.8.2.ebuild:
- Added ~ppc64
-
- 05 May 2006; Caleb Tennis <caleb@gentoo.org> qtiplot-0.8.2.ebuild:
- Change qwt dep to 4.2 so that it doesn't try and build against 5
-
-*qtiplot-0.8.2 (09 Apr 2006)
-
- 09 Apr 2006; Marcus D. Hanwell <cryos@gentoo.org>
- -files/qtiplot-0.8.1-qmake.patch, +files/qtiplot-0.8.2-qmake.patch,
- -qtiplot-0.8.1.ebuild, +qtiplot-0.8.2.ebuild:
- Version bump, pruned old version.
-
- 08 Apr 2006; <nixnut@gentoo.org> qtiplot-0.8.1.ebuild:
- Added ~ppc. bug #129071
-
-*qtiplot-0.8.1 (27 Mar 2006)
-
- 27 Mar 2006; Marcus D. Hanwell <cryos@gentoo.org>
- -files/qtiplot-0.7.4-qmake.patch, -files/qtiplot-0.7.6-qmake.patch,
- +files/qtiplot-0.8.1-qmake.patch, -qtiplot-0.7.4.ebuild,
- -qtiplot-0.7.6.ebuild, qtiplot-0.7.7.ebuild, +qtiplot-0.8.1.ebuild:
- Version bump, closes bug 124109. Also cleaned up old versions and marked
- newer version stable on amd64.
-
-*qtiplot-0.7.7 (30 Jan 2006)
-
- 30 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
- +files/qtiplot-0.7.7-qmake.patch, +qtiplot-0.7.7.ebuild:
- Version bump.
-
- 29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
- +files/qtiplot-0.7.4-qmake.patch, +files/qtiplot-0.7.6-qmake.patch,
- +metadata.xml, +qtiplot-0.7.4.ebuild, +qtiplot-0.7.6.ebuild:
- Moved from sci-mathematics/qtiplot to sci-visualization/qtiplot.
-
- 18 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> qtiplot-0.7.4.ebuild,
- qtiplot-0.7.6.ebuild:
- Stable on amd64, addition of app-arch/unzip to the deps.
-
-*qtiplot-0.7.6 (16 Jan 2006)
-
- 16 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
- -files/qtiplot-0.7.5-qmake.patch, +files/qtiplot-0.7.6-qmake.patch,
- -qtiplot-0.7.5.ebuild, +qtiplot-0.7.6.ebuild:
- Version bump.
-
-*qtiplot-0.7.5 (12 Jan 2006)
-
- 12 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
- -files/qtiplot-0.7.3-qmake.patch, +files/qtiplot-0.7.5-qmake.patch,
- -qtiplot-0.7.3.ebuild, +qtiplot-0.7.5.ebuild:
- Version bump.
-
- 09 Jan 2006; Caleb Tennis <caleb@gentoo.org> qtiplot-0.7.3.ebuild,
- qtiplot-0.7.4.ebuild:
- Fix qmake call
-
-*qtiplot-0.7.4 (17 Dec 2005)
-
- 17 Dec 2005; Marcus D. Hanwell <cryos@gentoo.org>
- +files/qtiplot-0.7.4-qmake.patch, +qtiplot-0.7.4.ebuild:
- Version bump, bug 115497.
-
- 09 Dec 2005; Marcus D. Hanwell <cryos@gentoo.org> qtiplot-0.7.3.ebuild:
- Small cleanup for the Qt path.
-
-*qtiplot-0.7.3 (29 Nov 2005)
-
- 29 Nov 2005; Marcus D. Hanwell <cryos@gentoo.org>
- +files/qtiplot-0.7.3-qmake.patch, -qtiplot-0.7.ebuild,
- +qtiplot-0.7.3.ebuild:
- Version bump, closes bug 112952.
-
-*qtiplot-0.7 (23 Oct 2005)
-
- 23 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> -qtiplot-0.6.9.ebuild,
- +qtiplot-0.7.ebuild:
- Version bump, bug 109968.
-
-*qtiplot-0.6.9 (14 Oct 2005)
-
- 14 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
- +qtiplot-0.6.9.ebuild:
- Initial import, thanks to Martin Corley <Martin.Corley@ed.ac.uk> for the
- ebuild, closes bug 83293.
-
diff --git a/sci-visualization/qtiplot/Manifest b/sci-visualization/qtiplot/Manifest
deleted file mode 100644
index 7c381beff..000000000
--- a/sci-visualization/qtiplot/Manifest
+++ /dev/null
@@ -1,7 +0,0 @@
-AUX qtiplot-0.9.6-fitplugins.patch 1568 RMD160 af8b05f8f49dd567fa3619b9efe799f1d74632e6 SHA1 b5c53f8a33de778366e5f1072fe283bb357d2311 SHA256 63df38507723ce3ef8ce897d9db7f0c0e86424790b8f855f529de0a48fdf1a48
-AUX qtiplot-0.9.6-profile.patch 2939 RMD160 5d524efec78f111bee196eb1d74d70d8d365aab4 SHA1 7470ffbf2e25342ab922e4a03688b0c83666c3e0 SHA256 0f79ce7316b723156193c6383f27fb321998bc0009e63d40c05b034cbd6678f5
-DIST qtiplot-0.9.6-manual-en.tar.bz2 11094755 RMD160 1b75339cb787a47beff0f39e260277b523c0b3e7 SHA1 7156100e1eae6a466f0a573be9c44bec8adc1fc6 SHA256 10867d1cc4af68c29c3da1f0fd8046d953f4851f7e32acdfb2e2d508deee8254
-DIST qtiplot-0.9.6.tar.bz2 6431763 RMD160 7d0a28b9ab3132dc72abf42f6c89283b7d9c82b0 SHA1 ae32fc3cad883c71f7cbf2d3a285a56ed7388796 SHA256 9892f48eaf08f7e9f9932156c755a37a3570f5028e1777263706cd1fb688c7c1
-EBUILD qtiplot-0.9.6.ebuild 2499 RMD160 f48784dff4517708bccfe6e0551d70dbb1647d41 SHA1 65bfe52e170b8b6657fe695bd5f3298fed0f1fb9 SHA256 c83438394cddb0b4c76ef688c6d7a631136d9f9792a73f687467e8c28641d240
-MISC ChangeLog 6731 RMD160 dc63e0b1c1c0f583af9da499e1a5959d853f5f0e SHA1 d1ed0f424b95b0ff25c82d4d8440195967ec69fa SHA256 9a2268d76134e6ac808816e1d25f5c2e65d1cf2d9fa950d747f2d3053396ee8a
-MISC metadata.xml 604 RMD160 1e0ed48d48668781cafc44ef8a14c3fb1e41eb28 SHA1 0f1b65755c3b923539a54b7e05dfda9679c4d758 SHA256 094795782ea49d41a8c4106510bb80d360f1bdaae3ab89c23c369def31bab56c
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch
deleted file mode 100644
index 64e54655d..000000000
--- a/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -U2 -r qtiplot-0.9.6.orig/fitPlugins/fitRational0/fitRational0.pro qtiplot-0.9.6/fitPlugins/fitRational0/fitRational0.pro
---- qtiplot-0.9.6.orig/fitPlugins/fitRational0/fitRational0.pro 2007-10-29 05:44:06.000000000 +0600
-+++ qtiplot-0.9.6/fitPlugins/fitRational0/fitRational0.pro 2008-05-15 10:42:10.000000000 +0700
-@@ -13,10 +13,8 @@
-
- # statically link against GSL in 3rdparty
--INCLUDEPATH += ../../3rdparty/gsl/include/
--LIBS += ../../3rdparty/gsl/lib/libgsl.a
--LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
-+INCLUDEPATH += /usr/include/gsl
-
- #dynamically link against GSL installed system-wide
--#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
-+unix:LIBS += $$system(pkg-config --libs gsl)
-
- target.path=/usr/lib$${libsuff}/qtiplot/plugins
-diff -U2 -r qtiplot-0.9.6.orig/fitPlugins/fitRational1/fitRational1.pro qtiplot-0.9.6/fitPlugins/fitRational1/fitRational1.pro
---- qtiplot-0.9.6.orig/fitPlugins/fitRational1/fitRational1.pro 2007-10-29 05:44:06.000000000 +0600
-+++ qtiplot-0.9.6/fitPlugins/fitRational1/fitRational1.pro 2008-05-15 10:43:01.000000000 +0700
-@@ -13,10 +13,8 @@
-
- # statically link against GSL in 3rdparty
--INCLUDEPATH += ../../3rdparty/gsl/include/
--LIBS += ../../3rdparty/gsl/lib/libgsl.a
--LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
-+INCLUDEPATH += /usr/include/gsl
-
- #dynamically link against GSL installed system-wide
--#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
-+unix:LIBS += $$system(pkg-config --libs gsl)
-
- target.path=/usr/lib$${libsuff}/qtiplot/plugins
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch
deleted file mode 100644
index bce1a5e91..000000000
--- a/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -U2 -r qtiplot-0.9.6.orig/qtiplot/qtiplot.pro qtiplot-0.9.6/qtiplot/qtiplot.pro
---- qtiplot-0.9.6.orig/qtiplot/qtiplot.pro 2008-05-13 17:22:46.000000000 +0700
-+++ qtiplot-0.9.6/qtiplot/qtiplot.pro 2008-05-15 12:47:15.000000000 +0700
-@@ -18,8 +18,8 @@
- # the *.path variables defined bellow.
- ######################################################################################
--#CONFIG += CustomInstall
-+CONFIG += CustomInstall
-
--#CONFIG += release
--CONFIG += debug
-+CONFIG += release
-+#CONFIG += debug
- win32: CONFIG += console
-
-@@ -28,10 +28,9 @@
- #############################################################################
-
--INCLUDEPATH += ../3rdparty/muparser/include
--INCLUDEPATH += ../3rdparty/qwtplot3d/include
--INCLUDEPATH += ../3rdparty/qwt/src
-+INCLUDEPATH += /usr/include/muparser
-+INCLUDEPATH += /usr/include/qwtplot3d
-+INCLUDEPATH += /usr/include/qwt5
- INCLUDEPATH += ../3rdparty/liborigin
--INCLUDEPATH += ../3rdparty/gsl/include
--INCLUDEPATH += ../3rdparty/zlib123/include
-+INCLUDEPATH += /usr/include/gsl
-
- ##################### 3rd PARTY LIBRARIES SECTION ###########################
-@@ -42,15 +41,16 @@
-
- # statically link against libraries in 3rdparty
--unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
--unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
--unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
--unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
--unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
-+#unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
-+#unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
-+#unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
-+#unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
-+#unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
-
- # dynamically link against dependencies if they are installed system-wide
--#unix:LIBS += -lmuparser
--#unix:LIBS += -lqwtplot3d
--#unix:LIBS += -lqwt
--#unix:LIBS += -lgsl -lgslcblas
-+unix:LIBS += -lmuparser
-+unix:LIBS += -lqwtplot3d
-+unix:LIBS += -lqwt
-+unix:LIBS += $$system(pkg-config --libs gsl)
-+unix:LIBS += -lz
-
- ##################### Windows ###############################################
-@@ -141,6 +141,5 @@
- ../manual/qtiplot-manual-en.pdf
-
--documentation.files += ../README.html \
-- ../gpl_licence.txt
-+documentation.files += ../README.html
-
- unix: man.files += ../qtiplot.1
-@@ -474,5 +473,5 @@
- qti_wordlist.txt \
-
-- unix: pythonconfig.path = /usr/local/qtiplot
-+ unix: pythonconfig.path = /usr/share/qtiplot
- win32: pythonconfig.path = $$INSTALLBASE
- DEFINES += PYTHON_CONFIG_PATH="\\\"$$replace(pythonconfig.path," ","\ ")\\\"
- qtiplot-0.9.6/qtiplot: qtiplot.pro~
diff --git a/sci-visualization/qtiplot/metadata.xml b/sci-visualization/qtiplot/metadata.xml
deleted file mode 100644
index 118c096c5..000000000
--- a/sci-visualization/qtiplot/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>cryos@gentoo.org</email>
- </maintainer>
- <longdescription>
- Data analysis and scientific plotting package. This is a clone of the
- popular Origin software available on another well known platform implemented
- in Qt with powerful 2D and 3D data plotting, ASCII import and powerful
- spreadsheet data manipulation using column logic. Curve fitting and other
- statistical tools are also available.
- </longdescription>
-</pkgmetadata>
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild
deleted file mode 100644
index 5c4834f6d..000000000
--- a/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="1"
-inherit eutils multilib qt4
-
-DESCRIPTION="Qt based clone of the Origin plotting package"
-HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
-SRC_URI="http://soft.proindependent.com/src/${P}.tar.bz2
- doc? ( mirror://gentoo/${P}-manual-en.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="python doc bindist"
-
-LANGS="de es fr ja ru sv"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-CDEPEND=">=x11-libs/qwt-5.1
- >=x11-libs/qwtplot3d-0.2.7
- >=dev-cpp/muParser-1.28
- !bindist? ( sci-libs/gsl )
- bindist? ( <sci-libs/gsl-1.10 )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- python? ( >=dev-python/sip-4.5.2 )"
-
-RDEPEND="${CDEPEND}
- python? ( >=dev-lang/python-2.5
- dev-python/PyQt4
- dev-python/pygsl
- sci-libs/scipy )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-profile.patch
- epatch "${FILESDIR}"/${P}-fitplugins.patch
-
- sed -i \
- -e '/manual/d'\
- -e '/3rd/d' \
- qtiplot.pro || die "sed qtiplot.pro failed"
- sed -i \
- -e '/manual/d' \
- -e "s:doc/${PN}:doc/${PF}:" \
- qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
-
- if ! use python; then
- sed -i \
- -e '/^SCRIPTING_LANGS += Python/d' \
- -e '/sipcmd/d' \
- qtiplot/qtiplot.pro || die "sed for python option failed"
- fi
-
- # the lib$$suff did not work in the fitRational*.pro files
- sed -i \
- -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
- fitPlugins/fit*/fitRational*.pro \
- || die "sed fitRational* failed"
-
- for l in ${LANGS}; do
- if ! use linguas_${l}; then
- sed -i \
- -e "s:translations/qtiplot_${l}.ts::" \
- qtiplot/qtiplot.pro || die
- fi
- done
-}
-
-src_compile() {
- eqmake4 || die "eqmake4 failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die 'emake install failed'
-
- newicon qtiplot_logo.png qtiplot.png
- make_desktop_entry qtiplot QtiPlot qtiplot
-
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins -r "${WORKDIR}"/qtiplot-manual-en/* \
- || die "install manual failed"
- rm -rf "${D}"/usr/share/doc/${PF}/html/*/.svn
- fi
-}
-
-pkg_postinst() {
- if use doc; then
- elog "On the first start, do Help -> Choose Help Folder"
- elog "and select /usr/share/doc/${PF}/html"
- elog "Also do View -> Preferences, in the tab File Locations"
- elog "set Python Configuration Files to /usr/share/${PN}"
- elog "and Translations to /usr/share/${PN}/translations"
- fi
-}