aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-11-20 22:33:14 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-11-21 22:14:58 +0100
commita7ee361dbbe3881376442622ccf5ae5b4ad0dc07 (patch)
tree89dd038af0c50c6aaa5a71e28c559d680d597e57 /sci-visualization
parentrefetching qgis samples (diff)
downloadsci-a7ee361dbbe3881376442622ccf5ae5b4ad0dc07.tar.gz
sci-a7ee361dbbe3881376442622ccf5ae5b4ad0dc07.tar.bz2
sci-a7ee361dbbe3881376442622ccf5ae5b4ad0dc07.zip
qtiplot imported
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog316
-rw-r--r--sci-visualization/qtiplot/Manifest21
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.10-docbuild.patch38
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.10-gcc44.patch18
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.10-sip.patch55
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.10-syslibs.patch183
-rw-r--r--sci-visualization/qtiplot/metadata.xml15
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.10.ebuild120
8 files changed, 766 insertions, 0 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
new file mode 100644
index 000000000..df1af57b6
--- /dev/null
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -0,0 +1,316 @@
+# ChangeLog for sci-visualization/qtiplot
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.46 2009/09/18 18:40:01 bicatali Exp $
+
+*qtiplot-0.9.7.7-r1 (18 Sep 2009)
+
+ 18 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -qtiplot-0.9.7.7.ebuild, +qtiplot-0.9.7.7-r1.ebuild,
+ +files/qtiplot-0.9.7.7-sip.patch, files/qtiplot-0.9.7.7-syslibs.patch:
+ Fixed for more recent versions of sip, and re-introduced minigzip since it
+ is not distributed by zlib. Closing bug #274633
+
+ 29 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> qtiplot-0.9.7.7.ebuild,
+ +files/qtiplot-0.9.7.7-gcc44.patch:
+ Fix building w/ GCC 4.4. (bug #272375)
+
+ 05 Jun 2009; Andrey Grozin <grozin@gentoo.org> qtiplot-0.9.7.7.ebuild:
+ USE-deps on PyQt4 fixed (bug #272182)
+
+ 18 May 2009; Andrey Grozin <grozin@gentoo.org> qtiplot-0.9.7.7.ebuild:
+ Fixed missing dependency on qt-opengl (bug #270339)
+
+*qtiplot-0.9.7.7 (14 Apr 2009)
+
+ 14 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/qtiplot-0.9.7.4-gcc4.3.patch,
+ -files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch,
+ -files/qtiplot-0.9.7.4-no-python.patch, -files/qtiplot-0.9.7.4-pro.patch,
+ -files/qtiplot-0.9.7.4-sip.patch, +files/qtiplot-0.9.7.7-docbuild.patch,
+ +files/qtiplot-0.9.7.7-syslibs.patch, -qtiplot-0.9.7.4.ebuild,
+ +qtiplot-0.9.7.7.ebuild:
+ Version bump, fixing bug #256543, bug #262939, bug #263675, bug #265623.
+ Removed old version.
+
+ 08 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -qtiplot-0.8.5.ebuild, -qtiplot-0.9.7.2.ebuild, -qtiplot-0.9.7.3.ebuild:
+ Removed old versions
+
+ 06 Apr 2009; Brent Baude <ranger@gentoo.org> qtiplot-0.9.7.4.ebuild:
+ Marking qtiplot-0.9.7.4 ~ppc for bug 215830
+
+*qtiplot-0.9.7.4 (20 Dec 2008)
+
+ 20 Dec 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/qtiplot-0.9.7.4-gcc4.3.patch,
+ +files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch,
+ +files/qtiplot-0.9.7.4-no-python.patch, +files/qtiplot-0.9.7.4-pro.patch,
+ +files/qtiplot-0.9.7.4-sip.patch, +qtiplot-0.9.7.4.ebuild:
+ Version bump
+
+ 18 Dec 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qtiplot-0.9.7.3-sip.patch, qtiplot-0.9.7.3.ebuild:
+ Added patch to fix problem with sip-4.7.9 and qtiplot's sip files
+ (see bug #250014).
+
+ 13 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qtiplot-0.9.7.3-no-python.patch, qtiplot-0.9.7.3.ebuild:
+ Added patch to fix compile problems with python disabled (#246473).
+
+*qtiplot-0.9.7.3 (24 Oct 2008)
+
+ 24 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qtiplot-0.9.7.3-pro.patch, +files/qtiplot-0.9.7.3-qwt3d.patch,
+ +qtiplot-0.9.7.3.ebuild:
+ Version bump (fixes bug #243430).
+
+ 13 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ qtiplot-0.9.7.2.ebuild:
+ Fixed SRC_URI for mirrors, bug #218657.
+
+ 28 Sep 2008; Markus Dittrich <markusle@gentoo.org> qtiplot-0.9.7.2.ebuild:
+ Changed boost dependency to >=1.35.0 since compile fails otherwise
+ (see bug 238632).
+
+*qtiplot-0.9.7.2 (25 Sep 2008)
+
+ 25 Sep 2008; Markus Dittrich <markusle@gentoo.org>
+ -qtiplot-0.9.6.2.ebuild,
+ +files/qtiplot-0.9.7.2-liborigin-gcc4.3.patch,
+ +files/qtiplot-0.9.7.2-pro.patch, +qtiplot-0.9.7.2.ebuild:
+ Version bump. Fixes bug #238632.
+ NOTE: This version uses an improved liborigin file parser
+ and is not compatible any more with sci-libs/liborigin. Hence,
+ we use the included liborigin sources for now until upstream
+ hopefully updates liborigin as well.
+
+*qtiplot-0.9.7 (26 Aug 2008)
+
+ 26 Aug 2008; Markus Dittrich <markusle@gentoo.org>
+ -files/qtiplot-0.9.2-systemlibs.patch,
+ -files/qtiplot-0.9.4-systemlibs.patch,
+ -files/qtiplot-0.9.5-fitplugins.patch, -files/qtiplot-0.9.5-profile.patch,
+ -files/qtiplot-0.9.6-fitplugins.patch, -files/qtiplot-0.9.6-profile.patch,
+ +files/qtiplot-0.9.7-gcc4.3.patch, -qtiplot-0.9.4.ebuild,
+ -qtiplot-0.9.5-r1.ebuild, -qtiplot-0.9.6.ebuild, +qtiplot-0.9.7.ebuild:
+ Version bump (fixes #233610) and removed old ebuilds. Thanks much to
+ Alexey Shvetsov <alexxyum@gmail.com> for his patches.
+
+ 25 Aug 2008; Markus Dittrich <markusle@gentoo.org> qtiplot-0.9.6.2.ebuild:
+ Added missing dependency on x11-libs/qt-assistant:4 (fixes bug #235618).
+
+ 11 Aug 2008; Markus Dittrich <markusle@gentoo.org> qtiplot-0.9.6.2.ebuild:
+ Added dependencies/check for qt3support (fixes bug #234316).
+
+ 27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qtiplot-0.7.7.ebuild,
+ qtiplot-0.8.5.ebuild:
+ QA: Get rid of deprecated qt_min_version().
+
+ 29 May 2008; Ali Polatel <hawking@gentoo.org> qtiplot-0.9.6.2.ebuild:
+ python_mod_compile is ROOT aware and can take multiple files as argument.
+
+ 28 May 2008; Andrey Grozin <grozin@gentoo.org>
+ files/qtiplot-0.9.6.2-pro.patch, qtiplot-0.9.6.2.ebuild:
+ Python files are now installed to the proper place and compiled (bugs
+ #223671, #223673)
+
+ 25 May 2008; Andrey Grozin <grozin@gentoo.org>
+ files/qtiplot-0.9.6.2-pro.patch:
+ Python files are now installed to /usr/share/qtiplot (bug #223313)
+
+ 24 May 2008; Andrey Grozin <grozin@gentoo.org> qtiplot-0.9.6.2.ebuild:
+ A minor ebuild fix
+
+*qtiplot-0.9.6.2 (21 May 2008)
+
+ 21 May 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/qtiplot-0.9.6.2-fitplugins.patch, +files/qtiplot-0.9.6.2-pro.patch,
+ +qtiplot-0.9.6.2.ebuild:
+ Version bump. fdo-mime_desktop_database_update added
+
+*qtiplot-0.9.6 (19 May 2008)
+
+ 19 May 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/qtiplot-0.9.6-fitplugins.patch, +files/qtiplot-0.9.6-profile.patch,
+ +qtiplot-0.9.6.ebuild:
+ Version bump. Translations are now handled correctly.
+
+*qtiplot-0.9.5-r1 (30 Apr 2008)
+
+ 30 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/qtiplot-0.9.5-profile.patch, +qtiplot-0.9.5-r1.ebuild:
+ Fixed installation for binary and translations, closing bug #219845
+
+*qtiplot-0.9.5 (29 Apr 2008)
+
+ 29 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/qtiplot-0.9.3-homepage.patch,
+ -files/qtiplot-0.9.3-systemlibs.patch,
+ +files/qtiplot-0.9.5-fitplugins.patch, +files/qtiplot-0.9.5-profile.patch,
+ qtiplot-0.7.7.ebuild, -qtiplot-0.9.3.ebuild, qtiplot-0.9.4.ebuild,
+ +qtiplot-0.9.5.ebuild:
+ Version bump. Separated patches for fit plugins and qtiplot.pro for better
+ re-usability
+
+*qtiplot-0.9.4 (28 Mar 2008)
+
+ 28 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/qtiplot-0.9.4-systemlibs.patch, -qtiplot-0.9.2.ebuild,
+ -qtiplot-0.9.2-r1.ebuild, +qtiplot-0.9.4.ebuild:
+ Version bump. Thanks Dieter Ries for the update (closing bug #215192).
+ Removed older versions.
+
+ 15 Mar 2008; Markus Rothe <corsair@gentoo.org> qtiplot-0.9.3.ebuild:
+ Added ~ppc64
+
+ 10 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> Manifest:
+ Fixed doc file on mirror, bug #212599
+
+*qtiplot-0.9.3 (07 Mar 2008)
+
+ 07 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/qtiplot-0.9.3-homepage.patch,
+ +files/qtiplot-0.9.3-systemlibs.patch, qtiplot-0.9.2.ebuild,
+ +qtiplot-0.9.3.ebuild:
+ Version bump
+
+ 13 Feb 2008; Markus Dittrich <markusle@gentoo.org> qtiplot-0.7.7.ebuild,
+ qtiplot-0.8.5.ebuild, qtiplot-0.9.2.ebuild, qtiplot-0.9.2-r1.ebuild:
+ Fixed QA issues and added bindist for >=gsl-1.10 (see bug #199451).
+
+*qtiplot-0.9.2-r1 (12 Feb 2008)
+
+ 12 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/qtiplot-0.9.2-systemlibs.patch, +qtiplot-0.9.2-r1.ebuild:
+ Fixed installation of plugins, fixed non-installation of python scripts,
+ translations, some cleanup
+
+ 14 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/qtiplot-0.9.2-systemlibs.patch, qtiplot-0.9.2.ebuild:
+ Removed spanish manual (incomplete), added english one on mirror (closing
+ bug #205366), fixed patch to use pkg-config for gsl, therefore possibly using
+ external cblas library.
+
+*qtiplot-0.9.2 (03 Dec 2007)
+
+ 03 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/qtiplot-0.9.1-systemlibs.patch,
+ +files/qtiplot-0.9.2-systemlibs.patch, -qtiplot-0.9.1.ebuild,
+ +qtiplot-0.9.2.ebuild:
+ Version bump. Removed 0.9.1 because many issues and missing doc upstream.
+ python-2.5 now only needed if python flag set.
+
+*qtiplot-0.9.1 (28 Nov 2007)
+
+ 28 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/qtiplot-0.8.2-qmake.patch, +files/qtiplot-0.9.1-systemlibs.patch,
+ qtiplot-0.7.7.ebuild, -qtiplot-0.8.2.ebuild, qtiplot-0.8.5.ebuild,
+ +qtiplot-0.9.1.ebuild:
+ Version bump. Now uses qt4. Closing bug #144286, thanks everyone and
+ especially Andrey Grozin for maintaining in the science overlay.
+ Dropped ppc and ppc64, untested for now.
+
+ 22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
+ Redigest for Manifest2
+
+*qtiplot-0.8.5 (26 May 2006)
+
+ 26 May 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/qtiplot-0.8.4-qmake.patch, +files/qtiplot-0.8.5-qmake.patch,
+ -qtiplot-0.8.4.ebuild, +qtiplot-0.8.5.ebuild:
+ Version bump, thanks to Andrey Grozin <A.G.Grozin@inp.nsk.su> for ebuild
+ imrpovements first implemented in the sci overlay.
+
+*qtiplot-0.8.4 (18 May 2006)
+
+ 18 May 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/qtiplot-0.8.4-qmake.patch, +qtiplot-0.8.4.ebuild:
+ Version bump.
+
+ 07 May 2006; Markus Rothe <corsair@gentoo.org> qtiplot-0.8.2.ebuild:
+ Added ~ppc64
+
+ 05 May 2006; Caleb Tennis <caleb@gentoo.org> qtiplot-0.8.2.ebuild:
+ Change qwt dep to 4.2 so that it doesn't try and build against 5
+
+*qtiplot-0.8.2 (09 Apr 2006)
+
+ 09 Apr 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/qtiplot-0.8.1-qmake.patch, +files/qtiplot-0.8.2-qmake.patch,
+ -qtiplot-0.8.1.ebuild, +qtiplot-0.8.2.ebuild:
+ Version bump, pruned old version.
+
+ 08 Apr 2006; <nixnut@gentoo.org> qtiplot-0.8.1.ebuild:
+ Added ~ppc. bug #129071
+
+*qtiplot-0.8.1 (27 Mar 2006)
+
+ 27 Mar 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/qtiplot-0.7.4-qmake.patch, -files/qtiplot-0.7.6-qmake.patch,
+ +files/qtiplot-0.8.1-qmake.patch, -qtiplot-0.7.4.ebuild,
+ -qtiplot-0.7.6.ebuild, qtiplot-0.7.7.ebuild, +qtiplot-0.8.1.ebuild:
+ Version bump, closes bug 124109. Also cleaned up old versions and marked
+ newer version stable on amd64.
+
+*qtiplot-0.7.7 (30 Jan 2006)
+
+ 30 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/qtiplot-0.7.7-qmake.patch, +qtiplot-0.7.7.ebuild:
+ Version bump.
+
+ 29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/qtiplot-0.7.4-qmake.patch, +files/qtiplot-0.7.6-qmake.patch,
+ +metadata.xml, +qtiplot-0.7.4.ebuild, +qtiplot-0.7.6.ebuild:
+ Moved from sci-mathematics/qtiplot to sci-visualization/qtiplot.
+
+ 18 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> qtiplot-0.7.4.ebuild,
+ qtiplot-0.7.6.ebuild:
+ Stable on amd64, addition of app-arch/unzip to the deps.
+
+*qtiplot-0.7.6 (16 Jan 2006)
+
+ 16 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/qtiplot-0.7.5-qmake.patch, +files/qtiplot-0.7.6-qmake.patch,
+ -qtiplot-0.7.5.ebuild, +qtiplot-0.7.6.ebuild:
+ Version bump.
+
+*qtiplot-0.7.5 (12 Jan 2006)
+
+ 12 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/qtiplot-0.7.3-qmake.patch, +files/qtiplot-0.7.5-qmake.patch,
+ -qtiplot-0.7.3.ebuild, +qtiplot-0.7.5.ebuild:
+ Version bump.
+
+ 09 Jan 2006; Caleb Tennis <caleb@gentoo.org> qtiplot-0.7.3.ebuild,
+ qtiplot-0.7.4.ebuild:
+ Fix qmake call
+
+*qtiplot-0.7.4 (17 Dec 2005)
+
+ 17 Dec 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/qtiplot-0.7.4-qmake.patch, +qtiplot-0.7.4.ebuild:
+ Version bump, bug 115497.
+
+ 09 Dec 2005; Marcus D. Hanwell <cryos@gentoo.org> qtiplot-0.7.3.ebuild:
+ Small cleanup for the Qt path.
+
+*qtiplot-0.7.3 (29 Nov 2005)
+
+ 29 Nov 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/qtiplot-0.7.3-qmake.patch, -qtiplot-0.7.ebuild,
+ +qtiplot-0.7.3.ebuild:
+ Version bump, closes bug 112952.
+
+*qtiplot-0.7 (23 Oct 2005)
+
+ 23 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> -qtiplot-0.6.9.ebuild,
+ +qtiplot-0.7.ebuild:
+ Version bump, bug 109968.
+
+*qtiplot-0.6.9 (14 Oct 2005)
+
+ 14 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+ +qtiplot-0.6.9.ebuild:
+ Initial import, thanks to Martin Corley <Martin.Corley@ed.ac.uk> for the
+ ebuild, closes bug 83293.
+
diff --git a/sci-visualization/qtiplot/Manifest b/sci-visualization/qtiplot/Manifest
new file mode 100644
index 000000000..b89eefbfb
--- /dev/null
+++ b/sci-visualization/qtiplot/Manifest
@@ -0,0 +1,21 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX qtiplot-0.7.7-qmake.patch 11384 RMD160 fa0491bd504d3445645817871fa831d0b70b4602 SHA1 5cd18e99d39664ef48e0d18069d89cb4b417a175 SHA256 2d89427ab1304b1ec8165d6ceaedf474a48ba59d55dafbb4977b5ddaab8509ca
+AUX qtiplot-0.9.7.7-docbuild.patch 2179 RMD160 011a6f3c71f0c5993ddea8a0b679867f40fe6753 SHA1 aed721371c106d041eeabcac55b627eceaa84ae0 SHA256 f3b043e16d099edd45ad4f41af602627883859f91731efcac077e123189073b0
+AUX qtiplot-0.9.7.7-gcc44.patch 663 RMD160 6ba315028c09767d9bb5f7f31ae8c6a17d4a8a3b SHA1 47cad99fe3fcace29c0b11fd005ce2e75542fc00 SHA256 f282fc735a546eed42ab30c38215ff1d32d413c415a6575a7702f8445f392292
+AUX qtiplot-0.9.7.7-sip.patch 2575 RMD160 68e5dff2be6f15a5518db7a26dfcda4e7e20b6b0 SHA1 cbc797c2b9b033c496bcd1e702862a5f9ce0c829 SHA256 6d1005beb7067d76525191198e19bb18d629bcd894fee6c0912e0a2a75fb16c0
+AUX qtiplot-0.9.7.7-syslibs.patch 8389 RMD160 f8a8535892bca48862353edd72ec6001683bf10e SHA1 168b2af1336a0c81878614b1d9ba0d1f8d5a6877 SHA256 5094f599056f5516dd30e61f7de7807fe4778d49fbf3c63bb8b2df8e265182b6
+DIST qtiplot-0.7.7.zip 812738 RMD160 6f62b32059eec57bf931b5bae9f524672d436ee9 SHA1 b201e600ec057ff0f7b4b4572850b0b072a0e0fb SHA256 937849c42cc3047df3975d1cb7a26a2503a499d548066937589340f55bd1ab01
+DIST qtiplot-0.9.7.7.tar.bz2 6908502 RMD160 2843c6a614d62613bc383f9d7b678f6fb5df0e01 SHA1 52d93c01013925b43d1f8dc2b372b83c7b84f848 SHA256 6c1cf9425de5609eec98b0e29bd0b7a316ca8d513ea44a462cffacf8695f43b1
+EBUILD qtiplot-0.7.7.ebuild 1095 RMD160 a5ccfad6cdadadf0f11600f9b8114f9c7fb8ae2b SHA1 e6008083cbd394f979d675035c6c11fb6771fc26 SHA256 b4019c8262709376fc6d2d6fc34150da0d1079db79718d3c50adc06ed3f95c03
+EBUILD qtiplot-0.9.7.7-r1.ebuild 3051 RMD160 1e26e9d0d2722b388f1e1b1fea1dd9f058b8f34d SHA1 cd6337ded02ba4fbf1c6317d4b9649d358bbba51 SHA256 74c24604e35e4444c964239e00d797a304c7db0099add48ac491094cb8dea4cc
+MISC ChangeLog 11972 RMD160 a63e508d2111a6f0054019ad446bb7eae240feb9 SHA1 c90579ecf861488ef6e15ea076910b93253bed55 SHA256 58f2ea40e8ee97e2c6878dd8ca3ebc020933a43e0b1fdc434527ee22138d7195
+MISC metadata.xml 604 RMD160 1e0ed48d48668781cafc44ef8a14c3fb1e41eb28 SHA1 0f1b65755c3b923539a54b7e05dfda9679c4d758 SHA256 094795782ea49d41a8c4106510bb80d360f1bdaae3ab89c23c369def31bab56c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqz1AsACgkQ1ycZbhPLE2D2hQCaAuioSnTNHzDcCeCtnqdcrBJz
+Jg8An2bMFxdKRdVXsX4O9WBObXTB3C1I
+=pSBf
+-----END PGP SIGNATURE-----
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-docbuild.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-docbuild.patch
new file mode 100644
index 000000000..58779fd3f
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-docbuild.patch
@@ -0,0 +1,38 @@
+--- manual/docbook-en/index.docbook.orig 2009-04-14 11:03:31.000000000 +0100
++++ manual/docbook-en/index.docbook 2009-04-14 10:58:41.000000000 +0100
+@@ -1,5 +1,5 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.4//EN" "/usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd" [
++<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "/usr/share/sgml/docbook/xml-dtd-4.2/docbookx.dtd" [
+
+ <!ENTITY appname "QtiPlot">
+ <!ENTITY kappname "&appname;">
+--- manual/Makefile.orig 2009-04-14 11:03:31.000000000 +0100
++++ manual/Makefile 2009-04-14 10:44:59.000000000 +0100
+@@ -1,3 +1,2 @@
+-html-pdf:
+- docbook2html -d qtiplot.dsl docbook-en/index.docbook -e no-valid
+- dblatex -o qtiplot-manual-en.pdf -c dblatex.conf -p dblatex-param.xsl docbook-en/index.docbook
++all:
++ docbook2html -d qtiplot.dsl docbook-en/index.docbook -e no-valid -l /usr/share/sgml/xml.dcl
+--- manual/qtiplot.dsl.orig 2009-04-14 11:03:31.000000000 +0100
++++ manual/qtiplot.dsl 2009-04-14 10:50:29.000000000 +0100
+@@ -6,7 +6,7 @@
+ <!DOCTYPE style-sheet PUBLIC "-//James Clark//DTD DSSSL Style Sheet//EN" [
+
+ <!-- Path to main Docbook->html stylesheet. You have to adapt this to your installation. -->
+-<!ENTITY docbook-html-stylesheet SYSTEM "/usr/share/sgml/docbook/stylesheet/dsssl/modular/html/docbook.dsl" CDATA DSSSL>
++<!ENTITY docbook-html-stylesheet SYSTEM "/usr/share/sgml/stylesheets/dsssl/docbook/html/docbook.dsl" CDATA DSSSL>
+
+ <!-- Stylesheet function library for creating Windows HTML help and Qt Assistant profiles. -->
+ <!ENTITY docbook-help-stylesheet SYSTEM "./help.dsl" CDATA DSSSL>
+diff -Nur manual.orig/qtiplot_html.xsl manual/qtiplot_html.xsl
+--- manual/qtiplot_html.xsl.orig 2009-04-14 11:03:31.000000000 +0100
++++ manual/qtiplot_html.xsl 2009-04-14 10:51:53.000000000 +0100
+@@ -1,5 +1,5 @@
+ <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version='1.0'>
+-<xsl:import href="file:////usr/share/xml/docbook/stylesheet/nwalsh/html/chunk.xsl"/>
++<xsl:import href="file:////usr/share/sgml/docbook/xsl-stylesheets/html/chunk.xsl"/>
+
+ <!-- html.stylesheet
+ The html.stylesheet parameter is either empty, indicating that no
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-gcc44.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-gcc44.patch
new file mode 100644
index 000000000..1dc993434
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-gcc44.patch
@@ -0,0 +1,18 @@
+--- qtiplot-0.9.7.7-orig/3rdparty/qwtplot3d/src/qwt3d_function.cpp
++++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/src/qwt3d_function.cpp
+@@ -1,3 +1,4 @@
++#include <cstdio>
+ #include "qwt3d_surfaceplot.h"
+ #include "qwt3d_function.h"
+
+--- qtiplot-0.9.7.7-orig/qtiplot/src/scripting/ScriptEdit.cpp
++++ qtiplot-0.9.7.7/qtiplot/src/scripting/ScriptEdit.cpp
+@@ -291,7 +291,7 @@ void ScriptEdit::insertErrorMsg(const QS
+ console->setPlainText(err);
+ if (!console->isVisible())
+ ((QDockWidget *)console->parent())->show();
+-#elif
++#else
+ int start = printCursor.position();
+ printCursor.insertText(err);
+ printCursor.setPosition(start, QTextCursor::KeepAnchor);
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-sip.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-sip.patch
new file mode 100644
index 000000000..bef796697
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-sip.patch
@@ -0,0 +1,55 @@
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/matrix/Matrix.h qtiplot-0.9.7.7/qtiplot/src/matrix/Matrix.h
+--- qtiplot-0.9.7.7.orig/qtiplot/src/matrix/Matrix.h 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/src/matrix/Matrix.h 2009-09-18 18:39:50.000000000 +0100
+@@ -137,6 +137,7 @@
+ void setColorMapType(ColorMapType mapType);
+
+ QwtLinearColorMap colorMap(){return d_color_map;};
++ QwtLinearColorMap *colorMapPointer(){return &d_color_map;};
+ void setColorMap(const QwtLinearColorMap& map);
+ //! Used when restoring from project files
+ void setColorMap(const QStringList& lst);
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/plot2D/Spectrogram.h qtiplot-0.9.7.7/qtiplot/src/plot2D/Spectrogram.h
+--- qtiplot-0.9.7.7.orig/qtiplot/src/plot2D/Spectrogram.h 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/src/plot2D/Spectrogram.h 2009-09-18 18:40:14.000000000 +0100
+@@ -62,6 +62,7 @@
+ void setDefaultColorMap();
+
+ QwtLinearColorMap colorMap(){return color_map;};
++ QwtLinearColorMap *colorMapPointer(){return &color_map;};
+ void setCustomColorMap(const QwtLinearColorMap& map);
+ void updateData(Matrix *m);
+
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/plot3D/Graph3D.h qtiplot-0.9.7.7/qtiplot/src/plot3D/Graph3D.h
+--- qtiplot-0.9.7.7.orig/qtiplot/src/plot3D/Graph3D.h 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/src/plot3D/Graph3D.h 2009-09-18 18:40:37.000000000 +0100
+@@ -274,6 +274,8 @@
+
+ QString colorMapFile(){return d_color_map_file;};
+ QwtLinearColorMap colorMap(){return d_color_map;};
++ QwtLinearColorMap *colorMapPointer(){return &d_color_map;};
++
+
+ static bool openColorMapFile(ColorVector& cv, QString fname);
+
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/scripting/qti.sip qtiplot-0.9.7.7/qtiplot/src/scripting/qti.sip
+--- qtiplot-0.9.7.7.orig/qtiplot/src/scripting/qti.sip 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/src/scripting/qti.sip 2009-09-18 18:19:15.000000000 +0100
+@@ -505,7 +505,7 @@
+ void setDefaultColorMap();
+ void setGrayScale();
+ void setRainbowColorMap();
+- QwtLinearColorMap colorMap();
++ QwtLinearColorMap *colorMapPointer()/PyName=colorMap/;
+ void setColorMap(const QwtLinearColorMap&);
+
+ void resetView();
+@@ -993,7 +993,7 @@
+ void setDataColors(const QColor&, const QColor&);
+ QString colorMapFile();
+ void setDataColorMap(const QString& fileName);
+- QwtLinearColorMap colorMap();
++ QwtLinearColorMap *colorMapPointer()/PyName=colorMap/;
+ void setDataColorMap(const QwtLinearColorMap&);
+
+ void changeTransparency(double) /PyName=setOpacity/;
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-syslibs.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-syslibs.patch
new file mode 100644
index 000000000..e6162192e
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.10-syslibs.patch
@@ -0,0 +1,183 @@
+diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pri
+--- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pri 2009-09-18 19:29:12.000000000 +0100
+@@ -57,11 +57,11 @@
+ ../3rdparty/qwtplot3d/include/qwt3d_multiplot.h
+
+ # gl2ps support
+-HEADERS += ../3rdparty/qwtplot3d/3rdparty/gl2ps/gl2ps.h \
+- ../3rdparty/qwtplot3d/include/qwt3d_io_gl2ps.h
++HEADERS += ../3rdparty/qwtplot3d/include/qwt3d_io_gl2ps.h
+
+-SOURCES += ../3rdparty/qwtplot3d/src/qwt3d_io_gl2ps.cpp \
+- ../3rdparty/qwtplot3d/3rdparty/gl2ps/gl2ps.c
++SOURCES += ../3rdparty/qwtplot3d/src/qwt3d_io_gl2ps.cpp
++
++unix:LIBS+=-lgl2ps
+
+ # zlib support for gl2ps
+ zlib {
+diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pro
+--- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -82,11 +82,10 @@
+ include/qwt3d_multiplot.h
+
+ # gl2ps support
+-HEADERS+=3rdparty/gl2ps/gl2ps.h \
+- include/qwt3d_io_gl2ps.h
++HEADERS+=include/qwt3d_io_gl2ps.h
+
+-SOURCES+=src/qwt3d_io_gl2ps.cpp \
+- 3rdparty/gl2ps/gl2ps.c
++SOURCES+=src/qwt3d_io_gl2ps.cpp
++unix:LIBS+=-lgl2ps
+
+ # zlib support for gl2ps
+ zlib {
+diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro qtiplot-0.9.7.7/fitPlugins/explin/explin.pro
+--- qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/fitPlugins/explin/explin.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -12,9 +12,8 @@
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += $$system(pkg-config --cflags gsl)
++LIBS += $$system(pkg-config --libs gsl)
+
+ #dynamically link against GSL installed system-wide
+ #unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
+diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro qtiplot-0.9.7.7/fitPlugins/exp_saturation/exp_saturation.pro
+--- qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/fitPlugins/exp_saturation/exp_saturation.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -12,9 +12,9 @@
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += $$system(pkg-config --cflags gsl)
++LIBS += $$system(pkg-config --libs gsl)
++
+
+ #dynamically link against GSL installed system-wide
+ #unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
+diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitPlugins.pro qtiplot-0.9.7.7/fitPlugins/fitPlugins.pro
+--- qtiplot-0.9.7.7.orig/fitPlugins/fitPlugins.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/fitPlugins/fitPlugins.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -4,3 +4,4 @@
+ exp_saturation \
+ fitRational0 \
+ fitRational1
++
+diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro qtiplot-0.9.7.7/fitPlugins/fitRational0/fitRational0.pro
+--- qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/fitPlugins/fitRational0/fitRational0.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -12,9 +12,9 @@
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += $$system(pkg-config --cflags gsl)
++LIBS += $$system(pkg-config --libs gsl)
++
+
+ #dynamically link against GSL installed system-wide
+ #unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
+diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro qtiplot-0.9.7.7/fitPlugins/fitRational1/fitRational1.pro
+--- qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/fitPlugins/fitRational1/fitRational1.pro 2009-09-18 19:29:12.000000000 +0100
+@@ -12,9 +12,8 @@
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += $$system(pkg-config --cflags gsl)
++LIBS += $$system(pkg-config --libs gsl)
+
+ #dynamically link against GSL installed system-wide
+ #unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtiplot.pro
+--- qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/qtiplot.pro 2009-09-18 19:31:47.000000000 +0100
+@@ -21,7 +21,7 @@
+ #CONFIG += HAVE_EMF
+
+ # Uncomment the following line if you want to perform a custom installation using the *.path variables defined bellow.
+-#CONFIG += CustomInstall
++CONFIG += CustomInstall
+
+ CONFIG += release
+ #CONFIG += debug
+@@ -31,13 +31,13 @@
+ #!!! Warning: You must modify these paths according to your computer settings
+ #############################################################################
+
+-INCLUDEPATH += ../3rdparty/muparser/include
++INCLUDEPATH += $$system(pkg-config --cflags muparser)
+ INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-INCLUDEPATH += ../3rdparty/qwt/src
+-INCLUDEPATH += ../3rdparty/liborigin
+-INCLUDEPATH += ../3rdparty/gsl/include
+ INCLUDEPATH += ../3rdparty/zlib
+-INCLUDEPATH += ../3rdparty/boost_1_36_0
++INCLUDEPATH += /usr/include/qwt5
++INCLUDEPATH += /usr/include/liborigin2
++INCLUDEPATH += $$system(pkg-config --cflags gsl)
++INCLUDEPATH += /usr/include/boost
+
+ ##################### 3rd PARTY LIBRARIES SECTION ###########################
+ #!!! Warning: You must modify these paths according to your computer settings
+@@ -46,12 +46,10 @@
+ ##################### Linux (Mac OS X) ######################################
+
+ # statically link against libraries in 3rdparty
+-unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
+-unix:LIBS += ../3rdparty/boost_1_36_0/lib/libboost_date_time-gcc43-mt-1_36.a
+-unix:LIBS += ../3rdparty/boost_1_36_0/lib/libboost_thread-gcc43-mt-1_36.a
++unix:LIBS += $$system(pkg-config --libs muparser)
++unix:LIBS += $$system(pkg-config --libs gsl)
++unix:LIBS += -lqwt -lz -lorigin2
++unix:LIBS += -lboost_date_time -lboost_thread
+
+ # dynamically link against dependencies if they are installed system-wide
+ #unix:LIBS += -lmuparser
+@@ -213,8 +211,6 @@
+
+ contains(CONFIG, HAVE_LIBPNG){
+ DEFINES += GL2PS_HAVE_LIBPNG
+- INCLUDEPATH += ../3rdparty/libpng/
+- LIBS += ../3rdparty/libpng/libpng.a
+ }
+
+ ###############################################################
+diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/origin/origin.pri qtiplot-0.9.7.7/qtiplot/src/origin/origin.pri
+--- qtiplot-0.9.7.7.orig/qtiplot/src/origin/origin.pri 2009-09-18 18:16:33.000000000 +0100
++++ qtiplot-0.9.7.7/qtiplot/src/origin/origin.pri 2009-09-18 19:29:12.000000000 +0100
+@@ -4,14 +4,6 @@
+ INCLUDEPATH += src/origin/
+
+ HEADERS += src/origin/importOPJ.h
+-HEADERS += ../3rdparty/liborigin/OriginObj.h
+-HEADERS += ../3rdparty/liborigin/OriginFile.h
+-HEADERS += ../3rdparty/liborigin/OriginParser.h
+-HEADERS += ../3rdparty/liborigin/OriginDefaultParser.h
+-HEADERS += ../3rdparty/liborigin/Origin750Parser.h
+
+ SOURCES += src/origin/importOPJ.cpp
+-SOURCES += ../3rdparty/liborigin/OriginFile.cpp
+-SOURCES += ../3rdparty/liborigin/OriginParser.cpp
+-SOURCES += ../3rdparty/liborigin/OriginDefaultParser.cpp
+-SOURCES += ../3rdparty/liborigin/Origin750Parser.cpp
++
diff --git a/sci-visualization/qtiplot/metadata.xml b/sci-visualization/qtiplot/metadata.xml
new file mode 100644
index 000000000..118c096c5
--- /dev/null
+++ b/sci-visualization/qtiplot/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Data analysis and scientific plotting package. This is a clone of the
+ popular Origin software available on another well known platform implemented
+ in Qt with powerful 2D and 3D data plotting, ASCII import and powerful
+ spreadsheet data manipulation using column logic. Curve fitting and other
+ statistical tools are also available.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.10.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.10.ebuild
new file mode 100644
index 000000000..ef02e7d1f
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.9.7.10.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.7-r1.ebuild,v 1.1 2009/09/18 18:40:01 bicatali Exp $
+
+EAPI=2
+inherit eutils qt4 fdo-mime python
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python doc bindist"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+# qwtplot3d much modified from original upstream
+CDEPEND=">=x11-libs/qwt-5.2
+ x11-libs/qt-opengl:4
+ x11-libs/qt-qt3support:4
+ x11-libs/qt-assistant:4
+ x11-libs/qt-svg:4
+ x11-libs/gl2ps
+ >=dev-cpp/muParser-1.30
+ >=dev-libs/boost-1.35.0
+ >=sci-libs/liborigin-20090406:2
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( dev-python/sip )
+ doc? ( app-text/docbook-sgml-utils
+ app-text/docbook-xml-dtd:4.2 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-lang/python-2.5
+ dev-python/PyQt4[X]
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-syslibs.patch
+ epatch "${FILESDIR}"/${P}-docbuild.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ has_version ">=dev-python/sip-4.8" && epatch "${FILESDIR}"/${P}-sip.patch
+
+ python_version
+ sed -i \
+ -e "s:doc/${PN}/manual:doc/${PF}/html:" \
+ -e "s:local/${PN}:$(get_libdir)/python${PYVER}/site-packages:" \
+ qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
+
+ if ! use python; then
+ sed -i \
+ -e '/^SCRIPTING_LANGS += Python/d' \
+ -e '/sipcmd/d' \
+ qtiplot/qtiplot.pro || die "sed for python option failed"
+ fi
+ sed -i \
+ -e '/INSTALLS.*.*documentation/d' \
+ -e '/manual/d' \
+ qtiplot.pro qtiplot/qtiplot.pro || die "sed for doc failed"
+
+ # the lib$$suff did not work in the fitRational*.pro files
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ fitPlugins/*/*.pro \
+ || die "sed fitRational* failed"
+
+ for l in ${LANGS}; do
+ if ! use linguas_${l}; then
+ sed -i \
+ -e "s:translations/qtiplot_${l}.ts::" \
+ -e "s:translations/qtiplot_${l}.qm::" \
+ qtiplot/qtiplot.pro || die
+ fi
+ done
+ chmod -x qtiplot/qti_wordlist.txt
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ #doxygen Doxyfile || die "api building failed"
+ cd manual
+ emake || die "html docbook building failed"
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ newicon qtiplot_logo.png qtiplot.png
+ make_desktop_entry qtiplot "QtiPlot Scientific Plotting" qtiplot
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r manual/html/* || die "install manual failed"
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ if use doc; then
+ elog "On the first start, do Help -> Choose Help Folder"
+ elog "and select /usr/share/doc/${PF}/html"
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}