aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-18 15:18:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-02-18 15:18:08 +0100
commitf4ee1c44273f78f7078a793d052273615c26dbb5 (patch)
tree0893d5b1ed9b1dceb206649ae1edc84d0e22fb0f /sys-cluster/htcondor
parentsys-cluster/lustre: fix SLOT operators (diff)
downloadsci-f4ee1c44273f78f7078a793d052273615c26dbb5.tar.gz
sci-f4ee1c44273f78f7078a793d052273615c26dbb5.tar.bz2
sci-f4ee1c44273f78f7078a793d052273615c26dbb5.zip
sys-cluster/htcondor: fix SLOT operators
Package-Manager: portage-2.2.17
Diffstat (limited to 'sys-cluster/htcondor')
-rw-r--r--sys-cluster/htcondor/ChangeLog4
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild22
-rw-r--r--sys-cluster/htcondor/htcondor-8.3.2.ebuild19
3 files changed, 28 insertions, 17 deletions
diff --git a/sys-cluster/htcondor/ChangeLog b/sys-cluster/htcondor/ChangeLog
index 1dafb4820..7215000f4 100644
--- a/sys-cluster/htcondor/ChangeLog
+++ b/sys-cluster/htcondor/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Feb 2015; Justin Lecher <jlec@gentoo.org> htcondor-8.0.0.ebuild,
+ htcondor-8.3.2.ebuild:
+ sys-cluster/htcondor: fix SLOT operators
+
*htcondor-8.3.2 (06 Jan 2015)
06 Jan 2015; Christoph Junghans <ottxor@gentoo.org> +htcondor-8.3.2.ebuild:
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index c62179383..54c4d5a47 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -3,8 +3,10 @@
# $Header: $
EAPI=5
+
CMAKE_MIN_VERSION=2.8
-PYTHON_COMPAT=( python{2_6,2_7} )
+
+PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1 user
@@ -19,7 +21,8 @@ IUSE="boinc cgroup contrib curl dmtcp doc kerberos libvirt management minimal po
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-CDEPEND="sys-libs/zlib
+CDEPEND="
+ sys-libs/zlib
>=dev-libs/libpcre-7.6
>=dev-libs/boost-1.49.0[${PYTHON_USEDEP}]
net-nds/openldap
@@ -31,10 +34,10 @@ CDEPEND="sys-libs/zlib
kerberos? ( virtual/krb5 )
X? ( x11-libs/libX11 )
management? ( net-libs/qmf )
- postgres? ( >=dev-db/postgresql-8.2.4 )
+ postgres? ( >=dev-db/postgresql-8.2.4:= )
python? ( ${PYTHON_DEPS} )
soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
- ssl? ( >=dev-libs/openssl-0.9.8i )
+ ssl? ( >=dev-libs/openssl-0.9.8i:0 )
xml? ( >=dev-libs/libxml2-2.7.3 )"
DEPEND="${CDEPEND}
@@ -53,11 +56,12 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/condor_shadow_dlopen-${PV}.patch" \
- "${FILESDIR}/condor_config.generic.patch" \
- "${FILESDIR}/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch" \
- "${FILESDIR}/packaging_directories-${PV}.patch" \
- "${FILESDIR}/fix_sandbox_violations-${PV}.patch"
+ epatch \
+ "${FILESDIR}"/condor_shadow_dlopen-${PV}.patch \
+ "${FILESDIR}"/condor_config.generic.patch \
+ "${FILESDIR}"/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch \
+ "${FILESDIR}"/packaging_directories-${PV}.patch \
+ "${FILESDIR}"/fix_sandbox_violations-${PV}.patch
cmake-utils_src_prepare
}
diff --git a/sys-cluster/htcondor/htcondor-8.3.2.ebuild b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
index cc8017645..fa11f6d8a 100644
--- a/sys-cluster/htcondor/htcondor-8.3.2.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
@@ -3,8 +3,10 @@
# $Header: $
EAPI=5
+
CMAKE_MIN_VERSION=2.8
-PYTHON_COMPAT=( python{2_6,2_7} )
+
+PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1 user vcs-snapshot
@@ -31,10 +33,10 @@ CDEPEND="sys-libs/zlib
kerberos? ( virtual/krb5 )
X? ( x11-libs/libX11 )
management? ( net-libs/qmf )
- postgres? ( >=dev-db/postgresql-8.2.4 )
+ postgres? ( >=dev-db/postgresql-8.2.4:= )
python? ( ${PYTHON_DEPS} )
soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
- ssl? ( >=dev-libs/openssl-0.9.8i )
+ ssl? ( >=dev-libs/openssl-0.9.8i:0 )
xml? ( >=dev-libs/libxml2-2.7.3 )"
DEPEND="${CDEPEND}
@@ -49,11 +51,12 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}-shadow_dlopen.patch"
- epatch "${FILESDIR}/${P}-condor_config.generic.patch"
- epatch "${FILESDIR}/${P}-Apply-the-users-condor_config-last-rather-than-first.patch"
- epatch "${FILESDIR}/${P}-packaging_directories.patch"
- epatch "${FILESDIR}/fix_sandbox_violations-8.0.0.patch"
+ epatch \
+ "${FILESDIR}"/${P}-shadow_dlopen.patch \
+ "${FILESDIR}"/${P}-condor_config.generic.patch \
+ "${FILESDIR}"/${P}-Apply-the-users-condor_config-last-rather-than-first.patch \
+ "${FILESDIR}"/${P}-packaging_directories.patch \
+ "${FILESDIR}"/fix_sandbox_violations-8.0.0.patch
cmake-utils_src_prepare
}