aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-04-17 10:05:06 -0400
committerRichard Yao <ryao@cs.stonybrook.edu>2013-04-17 10:05:06 -0400
commit98e36ab78572b7f4ae926cb1f6f5737b5f6a5efe (patch)
treefcff382896a016cc23f08311d439ef9386cbc8b8 /sys-cluster/lustre
parentFix client build (diff)
downloadsci-98e36ab78572b7f4ae926cb1f6f5737b5f6a5efe.tar.gz
sci-98e36ab78572b7f4ae926cb1f6f5737b5f6a5efe.tar.bz2
sci-98e36ab78572b7f4ae926cb1f6f5737b5f6a5efe.zip
Pass correct SPL and ZFS kernel header directories
This change enables lustre to find the kernel headers installed by >=sys-kernel/spl-0.6.1 and >=sys-fs/zfs-kmod-0.6.1. It also eliminates the need for those ebuilds to install symlinks as a hint to lustre. Signed-off-by: Richard Yao <ryao@gentoo.org>
Diffstat (limited to 'sys-cluster/lustre')
-rw-r--r--sys-cluster/lustre/lustre-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-cluster/lustre/lustre-9999.ebuild b/sys-cluster/lustre/lustre-9999.ebuild
index a40cd653f..617141315 100644
--- a/sys-cluster/lustre/lustre-9999.ebuild
+++ b/sys-cluster/lustre/lustre-9999.ebuild
@@ -25,8 +25,8 @@ DEPEND="
readline? ( sys-libs/readline )
tcpd? ( sys-apps/tcp-wrappers )
server? (
- sys-kernel/spl
- sys-fs/zfs-kmod
+ >=sys-kernel/spl-0.6.1
+ >=sys-fs/zfs-kmod-0.6.1
sys-fs/zfs
)
"
@@ -100,8 +100,10 @@ src_prepare() {
src_configure() {
local myconf
if use server; then
- myconf+="${myconf} --with-zfs=\"${EPREFIX}/usr/src/zfs\""
- myconf+="${myconf} --with-spl=\"${EPREFIX}/usr/src/spl\""
+ SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
+ myconf+="${myconf} --with-spl=\"${EROOT}usr/src/${SPL_PATH}\""
+ ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
+ myconf+="${myconf} --with-zfs=\"${EROOT}usr/src/${ZFS_PATH}\""
fi
econf \
${myconf} \