aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-08-29 14:03:41 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-08-29 14:11:29 -0600
commit8aa5f237c622b4305b33fdba0c3fab964f1cf945 (patch)
tree48ee8168586c194a5e2d7fb04feaaeaec1d450db /sys-cluster/mpich
parentsys-cluster/openmpi: re-add keywords for multilib ebuild (diff)
downloadsci-8aa5f237c622b4305b33fdba0c3fab964f1cf945.tar.gz
sci-8aa5f237c622b4305b33fdba0c3fab964f1cf945.tar.bz2
sci-8aa5f237c622b4305b33fdba0c3fab964f1cf945.zip
sys-cluster/mpich: bring back sysconfdir logic
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/mpich-3.2-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-cluster/mpich/mpich-3.2-r2.ebuild b/sys-cluster/mpich/mpich-3.2-r2.ebuild
index 33fe4430a..64ebfc060 100644
--- a/sys-cluster/mpich/mpich-3.2-r2.ebuild
+++ b/sys-cluster/mpich/mpich-3.2-r2.ebuild
@@ -69,6 +69,13 @@ multilib_src_configure() {
c="${c} --enable-threads=single"
fi
+ if ! mpi_classed; then
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ else
+ c="${c} --docdir=$(mpi_root)/usr/share/doc/${PF}"
+ fi
+
export MPICHLIB_CFLAGS="${CFLAGS}"
export MPICHLIB_CPPFLAGS="${CPPFLAGS}"
export MPICHLIB_CXXFLAGS="${CXXFLAGS}"
@@ -77,16 +84,14 @@ multilib_src_configure() {
export MPICHLIB_LDFLAGS="${LDFLAGS}"
unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
- ECONF_SOURCE=${S} $(mpi_econf_args) econf \
+ ECONF_SOURCE=${S} econf $(mpi_econf_args) \
--enable-shared \
- --sysconfdir="${EPREFIX}/etc/${PN}" \
--with-hwloc-prefix="${EPREFIX}/usr" \
${c} \
--with-pm=hydra \
--disable-fast \
--enable-versioning \
--with-hwloc-prefix=/usr \
- $(mpi_classed && echo "--docdir=$(mpi_root)/usr/share/doc/${PF}") \
$(use_enable romio) \
$(use_enable cxx) \
$(multilib_native_use_enable fortran fortran all)