aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-21 17:17:14 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-21 17:17:14 +0000
commit3be46fc5c23221b810050f718f1bcb97fbf40f2d (patch)
treead714f1de843b7a0deb75fa5f609fce2704975f6 /sys-cluster/torque
parentopenmpi-1.0.1.ebuild: removed warning if not pic (diff)
downloadsci-3be46fc5c23221b810050f718f1bcb97fbf40f2d.tar.gz
sci-3be46fc5c23221b810050f718f1bcb97fbf40f2d.tar.bz2
sci-3be46fc5c23221b810050f718f1bcb97fbf40f2d.zip
torque-2.0.0_p8.ebuild: forced fPIC and added PBS_SERVER_NAME
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@139 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/Manifest2
-rw-r--r--sys-cluster/torque/torque-2.0.0_p8.ebuild32
2 files changed, 20 insertions, 14 deletions
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index ee422bd1e..02eb9a700 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -6,4 +6,4 @@ MD5 b551147a374f034bf251490ce985be6b files/torque-2.0.0_p8-respect-destdir.patch
MD5 3ea9d3a2e1cff3ccd224f0e0b33da6d5 files/torque-2.0.0_p8-respect-ldflags.patch 2710
MD5 f362dc4addcab08a5d537913b99c9484 files/torque-2.0.0_p8-setuid-safety.patch 997
MD5 873d7e3e93527942f580edbddb57061b metadata.xml 647
-MD5 cdacdd95aac9717577e1a837cc55e457 torque-2.0.0_p8.ebuild 4414
+MD5 a0ca5498617cc42f9c51cca663cf7e70 torque-2.0.0_p8.ebuild 4516
diff --git a/sys-cluster/torque/torque-2.0.0_p8.ebuild b/sys-cluster/torque/torque-2.0.0_p8.ebuild
index 9c38ec4d8..8a9fd9fd0 100644
--- a/sys-cluster/torque/torque-2.0.0_p8.ebuild
+++ b/sys-cluster/torque/torque-2.0.0_p8.ebuild
@@ -8,17 +8,19 @@ inherit flag-o-matic eutils
MY_P="${P/_}"
DESCRIPTION="Resource manager and queuing system based on OpenPBS"
HOMEPAGE="http://www.clusterresources.com/products/torque/"
-SRC_URI="http://www.clusterresources.com/downloads/torque/${MY_P}.tar.gz"
+SRC_URI="http://www.clusterresources.com/downloads/${PN}/${MY_P}.tar.gz"
LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="tcltk scp server pic"
+IUSE="tcltk scp server"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
DEPEND_COMMON="virtual/libc
+ sys-libs/ncurses
+ sys-libs/readline
tcltk? ( dev-tcltk/tclx )
!virtual/pbs"
@@ -39,6 +41,7 @@ PBS_SERVER_HOME="${SPOOL_LOCATION}/PBS/"
src_unpack() {
unpack ${MY_P}.tar.gz
export EPATCH_OPTS="-p1 -d ${S}"
+
epatch ${FILESDIR}/${P}-respect-ldflags.patch \
|| die "epatch for ldflags failed"
epatch ${FILESDIR}/${P}-respect-destdir.patch \
@@ -58,18 +61,25 @@ src_unpack() {
src_compile() {
append-flags -DJOB_DELETE_NANNY
- # needed for openmpi on amd64 with shared libs
- use pic && append-flags -fPIC
+ append-flags -fPIC
+
+ local myconf=""
+ if use server; then
+ myconf="--enable-server --set-default-server=$(hostname)"
+ elif [ -z "${PBS_SERVER_NAME}" ]; then
+ myconf="--disable-server --set-default-server=${PBS_SERVER_NAME}"
+ else
+ myconf="--disable-server --set-default-server=$(hostname)"
+ fi
./configure ${myconf} \
- $(use_enable server) \
$(use_enable tcltk gui) \
$(use_enable tcltk tcl-qstat) \
$(use_with tcltk tclx) \
$(use_with tcltk tcl) \
$(use_with scp) \
- --prefix=/usr \
- --mandir=/usr/share/man \
+ --prefix="/usr" \
+ --mandir="/usr/share/man" \
--libdir="\${exec_prefix}/$(get_libdir)/pbs" \
--enable-mom \
--enable-clients \
@@ -77,7 +87,7 @@ src_compile() {
--enable-shared \
--enable-depend-cache \
--set-server-home=${PBS_SERVER_HOME} \
- --set-environ=/etc/pbs_environment || die "./configure failed"
+ --set-environ=/etc/pbs_environment || die "econf failed"
emake || die "emake failed"
}
@@ -117,14 +127,10 @@ src_install() {
# Make directories first
pbs_createspool "${D}"
- einfo "Running make install"
make DESTDIR=${D} install || die "make install failed"
-
- einfo "Doing docs & lib symlinks"
- dodoc INSTALL PBS_License.txt README.torque Release_Notes
dosym /usr/$(get_libdir)/pbs/libpbs.a /usr/$(get_libdir)/libpbs.a
+ dodoc CHANGELOG DEVELOPMENT README.* Release_Notes doc/admin_guide.ps
- einfo "Handling /etc/pbs_environment and /var/spool/PBS/server_name"
# this file MUST exist for PBS/Torque to work
# but try to preserve any customatizations that the user has made
dodir /etc