aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-16 00:09:11 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-16 00:09:11 +0000
commit8273477a6fe322e40f867e6f24d61b18fcf5e790 (patch)
tree894038b0065d2f9eb36a99aebc78edda4ecdc973 /sys-cluster/torque
parentadded openpbs-common-1.1.1 (diff)
downloadsci-8273477a6fe322e40f867e6f24d61b18fcf5e790.tar.gz
sci-8273477a6fe322e40f867e6f24d61b18fcf5e790.tar.bz2
sci-8273477a6fe322e40f867e6f24d61b18fcf5e790.zip
fixed pic behaviour for openmpi and torque
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@128 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/Manifest2
-rw-r--r--sys-cluster/torque/torque-2.0.0_p8.ebuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index 6ffc5c435..f194f5c3a 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -6,4 +6,4 @@ MD5 b551147a374f034bf251490ce985be6b files/torque-2.0.0_p8-respect-destdir.patch
MD5 3ea9d3a2e1cff3ccd224f0e0b33da6d5 files/torque-2.0.0_p8-respect-ldflags.patch 2710
MD5 f362dc4addcab08a5d537913b99c9484 files/torque-2.0.0_p8-setuid-safety.patch 997
MD5 873d7e3e93527942f580edbddb57061b metadata.xml 647
-MD5 34a6e35844280e6b4d0afeb940f07210 torque-2.0.0_p8.ebuild 4428
+MD5 9c6db47f242e4c35d08b2237c2192ff1 torque-2.0.0_p8.ebuild 4478
diff --git a/sys-cluster/torque/torque-2.0.0_p8.ebuild b/sys-cluster/torque/torque-2.0.0_p8.ebuild
index 5cd472284..471ff8f41 100644
--- a/sys-cluster/torque/torque-2.0.0_p8.ebuild
+++ b/sys-cluster/torque/torque-2.0.0_p8.ebuild
@@ -14,7 +14,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="tcltk scp server doc"
+IUSE="tcltk scp server doc pic"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -58,7 +58,8 @@ src_compile() {
# use tcltk && myconf="${myconf} --with-tcl"
use doc && myconf="${myconf} --enable-docs"
append-flags -DJOB_DELETE_NANNY
- use amd64 && append-flags -fPIC
+ # needed for openmpi on amd64 with shared libs
+ use pic && append-flags -fPIC
./configure ${myconf} \
$(use_enable X gui) \