aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-16 00:09:11 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-16 00:09:11 +0000
commit8273477a6fe322e40f867e6f24d61b18fcf5e790 (patch)
tree894038b0065d2f9eb36a99aebc78edda4ecdc973 /sys-cluster
parentadded openpbs-common-1.1.1 (diff)
downloadsci-8273477a6fe322e40f867e6f24d61b18fcf5e790.tar.gz
sci-8273477a6fe322e40f867e6f24d61b18fcf5e790.tar.bz2
sci-8273477a6fe322e40f867e6f24d61b18fcf5e790.zip
fixed pic behaviour for openmpi and torque
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@128 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/Manifest2
-rw-r--r--sys-cluster/openmpi/openmpi-1.0.1.ebuild8
-rw-r--r--sys-cluster/torque/Manifest2
-rw-r--r--sys-cluster/torque/torque-2.0.0_p8.ebuild5
4 files changed, 12 insertions, 5 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 78cbaf339..56aa7fe3d 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,4 +1,4 @@
MD5 5857c1a5ccb8ec1a1b24454e7f74a2d9 ChangeLog 342
MD5 914db9dc84c9ae3fdc732b8fb13fe21c files/digest-openmpi-1.0.1 67
MD5 c92d111706d0769823a1ff19c0abaacf metadata.xml 541
-MD5 73821d9ad6fa3f1e740db8dc78e084d6 openmpi-1.0.1.ebuild 1825
+MD5 a7fcaac73d1c9a9799cde943b90bb8a7 openmpi-1.0.1.ebuild 1960
diff --git a/sys-cluster/openmpi/openmpi-1.0.1.ebuild b/sys-cluster/openmpi/openmpi-1.0.1.ebuild
index d86d76807..b69bde5cc 100644
--- a/sys-cluster/openmpi/openmpi-1.0.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.0.1.ebuild
@@ -43,9 +43,15 @@ src_compile() {
use crypt && RSH=ssh || RSH=rsh; myconf="${myconf} --with-rsh=${RSH}"
use threads && myconf="${myconf} --with-threads=posix --enable-mpi-threads"
use pbs && append-ldflags "-L/usr/$(get_libdir)/pbs"
- use static && myconf="${myconf} --enable-static --disable-shared"
use fortran || myconf="${myconf} --disable-mpi-f77 --disable-mpi-f90"
+ if use static; then
+ myconf="${myconf} --enable-static --disable-shared"
+ elif use amd64; then
+ build_with_use virtual/pbs pic || \
+ die "your pbs implementation must be compiled with USE=pic"
+ fi
+
econf \
--prefix=/usr/$(get_libdir)/${PN}/${PV}-${COMPILER} \
--datadir=/usr/share/${PN}/${PV}-${COMPILER} \
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index 6ffc5c435..f194f5c3a 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -6,4 +6,4 @@ MD5 b551147a374f034bf251490ce985be6b files/torque-2.0.0_p8-respect-destdir.patch
MD5 3ea9d3a2e1cff3ccd224f0e0b33da6d5 files/torque-2.0.0_p8-respect-ldflags.patch 2710
MD5 f362dc4addcab08a5d537913b99c9484 files/torque-2.0.0_p8-setuid-safety.patch 997
MD5 873d7e3e93527942f580edbddb57061b metadata.xml 647
-MD5 34a6e35844280e6b4d0afeb940f07210 torque-2.0.0_p8.ebuild 4428
+MD5 9c6db47f242e4c35d08b2237c2192ff1 torque-2.0.0_p8.ebuild 4478
diff --git a/sys-cluster/torque/torque-2.0.0_p8.ebuild b/sys-cluster/torque/torque-2.0.0_p8.ebuild
index 5cd472284..471ff8f41 100644
--- a/sys-cluster/torque/torque-2.0.0_p8.ebuild
+++ b/sys-cluster/torque/torque-2.0.0_p8.ebuild
@@ -14,7 +14,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="tcltk scp server doc"
+IUSE="tcltk scp server doc pic"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -58,7 +58,8 @@ src_compile() {
# use tcltk && myconf="${myconf} --with-tcl"
use doc && myconf="${myconf} --enable-docs"
append-flags -DJOB_DELETE_NANNY
- use amd64 && append-flags -fPIC
+ # needed for openmpi on amd64 with shared libs
+ use pic && append-flags -fPIC
./configure ${myconf} \
$(use_enable X gui) \