aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2014-01-28 08:55:19 +0100
committerAndreas Schäfer <gentryx@gmx.de>2014-01-28 08:55:19 +0100
commitb703b6c5fa241da104c511f0dced46893b84c6d2 (patch)
tree76089398a2dfdbb224e361f30920006c444008ba /sys-cluster
parentadded ebuild for visit 2.7.1 (diff)
downloadsci-b703b6c5fa241da104c511f0dced46893b84c6d2.tar.gz
sci-b703b6c5fa241da104c511f0dced46893b84c6d2.tar.bz2
sci-b703b6c5fa241da104c511f0dced46893b84c6d2.zip
added ebuilds for HPX 0.9.7 and upstream
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-0.9.7.ebuild38
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild38
3 files changed, 77 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 30bd49207..cecd9ea58 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1,2 +1,3 @@
DIST hpx_0.9.5.tar.gz 3801863 SHA256 4e9f71b70d005104142157969f5ab3a980e2594279a2fb5f79a48bf77a8bc6aa SHA512 b156935061130bd87ababc4693b936687a4098eae305b55fce3c1fa7e0aef13b24f396045b8b392131c9eb973e67a1c1e665ae192a4b6350b5d3802dae9231a7 WHIRLPOOL 41a3e28be66578f0f665470847b38e2c6e5c573cb2ada7fbb49fe07c51b9bb15b761e811299560b2f4ed2e386bff5d42c6748c1c58fe430f4d8bed1376588c2a
DIST hpx_0.9.6.tar.gz 4506305 SHA256 937f753d5e6287bfa121d45ffe282b5f72c1c7a9bdc7cd6ca90e92169e13dba9 SHA512 37253aca00df825528dc79700cbb68de5cc9c652fdc7ebb4986f9f8fc603c789290f033d46b35b766a2a2a87c0dc9a2120d12ed300ef4fa3d4e267462906f01c WHIRLPOOL 317e9f229e10dec59e0c95ee008b33689b0728612954205eb6edc2b0014e40510fb5f026579d4f4becf9b39f4e419da0d1f7c95c1f8bc137c7da4edb8e5fe2fd
+DIST hpx_0.9.7.7z 2416122 SHA256 95fa108a6ba6cd3a3afc117d508936d1c070cc7e83a592f62815a6a11378882a SHA512 eb258e94facaaba29729ebca63640ab5feda156ee860153848ca1143266b8365bc9cc772eb6d6f56f884af43531efb1b77fa84ca4c6e185882cbf031ac794a7b WHIRLPOOL c5432a608a90a732ed7ec08f980d3d2f7f99a3bd5b83867db26190877120b76f0b46f6fd3e9bbc97bfb9637e6c951c9dd449c0f6c767bb11eca1e0212f488d88
diff --git a/sys-cluster/hpx/hpx-0.9.7.ebuild b/sys-cluster/hpx/hpx-0.9.7.ebuild
new file mode 100644
index 000000000..0c2f2b9f8
--- /dev/null
+++ b/sys-cluster/hpx/hpx-0.9.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2014-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+ CMAKE_USE_DIR="${S}"
+else
+ SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${PN}_${PV}"
+fi
+
+inherit cmake-utils
+
+DESCRIPTION="A general C++ runtime system for parallel and distributed applications of any scale"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.48"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/hpx-0.9.5-install-path.patch" )
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
new file mode 100644
index 000000000..0c2f2b9f8
--- /dev/null
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2014-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+ CMAKE_USE_DIR="${S}"
+else
+ SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${PN}_${PV}"
+fi
+
+inherit cmake-utils
+
+DESCRIPTION="A general C++ runtime system for parallel and distributed applications of any scale"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.48"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/hpx-0.9.5-install-path.patch" )
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ cmake-utils_src_configure
+}