aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-11-10 11:42:46 +0000
committerJustin Lecher <jlec@gentoo.org>2018-11-10 11:42:53 +0000
commitf7385f2513b4f2b47adb09adc7073390e7c81172 (patch)
tree229943bdd90437cb2dabbc7e36d5945ddcce8bce /sys-cluster
parentdev-python/trimesh: new package (diff)
downloadsci-f7385f2513b4f2b47adb09adc7073390e7c81172.tar.gz
sci-f7385f2513b4f2b47adb09adc7073390e7c81172.tar.bz2
sci-f7385f2513b4f2b47adb09adc7073390e7c81172.zip
sys-cluster/mpich: Version Bump
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich/Manifest1
-rw-r--r--sys-cluster/mpich/files/mpich-3.2.1-hwloc2.patch42
-rw-r--r--sys-cluster/mpich/mpich-3.2.1.ebuild140
3 files changed, 183 insertions, 0 deletions
diff --git a/sys-cluster/mpich/Manifest b/sys-cluster/mpich/Manifest
index c6215e613..d96bcb053 100644
--- a/sys-cluster/mpich/Manifest
+++ b/sys-cluster/mpich/Manifest
@@ -1,4 +1,5 @@
DIST mpich-3.0.4.tar.gz 10921075 BLAKE2B 341aaac23277aed05a4448ea03d9caf1ee14cfe327a770c95d620fc1ee1ea7bfa6df36860aa44aad162eb6d630d35fdfb30ae9a866d67680ab71c7b4326c109c SHA512 f9d8b2cf561fe5f85c12512ef4dd7b0cf5ec8b53ddb07bfa0d1db2e3c8ae0382c77e0661f46b82ec96b05d18ea2d25328bb84e9528ac06e5925f30ec8ef030d0
DIST mpich-3.1.3.tar.gz 11487313 BLAKE2B 15d39d8617e7b503bd1cb7d05ef098898736c2d634da2e50f33d7d3a92f2c0aeeb72ec152ee1907ab0658e5c485bd7ed8c2639b8d2abf1839981c542cfe2fc29 SHA512 3071d75e925808c13ea528aaff81a2ee44a4eb9732c74005a0cedd5a710aeafc691d30c7a035ae0aba14bd2b837c1c788202a7612599d3ffac8e5a9299467c09
DIST mpich-3.1.4.tar.gz 11325036 BLAKE2B 606003f4a9120930841a261698ff9c572f289a88d1db40bf02c8ed89f67a7ba1081652ce39acbf995b7c42e7becb9336fbb262c04873f25a939e5f963eec7de3 SHA512 55bd4d12a42b9ebc116016bd777eb2b8ed8c51e69f5ea5faf823eba0aeb7eadfe2848c4cca3032aa38841a25a4902c07cec2409811149a057c4aa99a25c6b6da
+DIST mpich-3.2.1.tar.gz 11908154 BLAKE2B 86437d9fefae06e32b5d1ba983e6d70f61e6e7a99b92527b966f5dcd1c7fb44fbfe155226c369fb5dede15a554d89ff674eaeeedfb47753b7e73e93ecdca91ce SHA512 659a11cf02302f27eb1db77667dd4c7a4f8008b1d73f5f0f0f28ee6b5d9cca2130bac3d010a132136ba15a25a738ec9cbda67255133aeb42f0d82a2ded23d23d
DIST mpich-3.2.tar.gz 11862150 BLAKE2B 2e0414b2e11b08a59497fa255d464a2130c754ba8798b99a8b84f7232179906bb27906abbe58b9546833541c238f42ae06df90bfe1133d3ff2d85921d9736452 SHA512 083c51655b4355827bd7fa4fe528046e2bc77b7747d869ff87b79fa324c3cc2a9b5640ccb7271490ccc0dd627e354a33a449bbab448501bbfddcfe5f999ee717
diff --git a/sys-cluster/mpich/files/mpich-3.2.1-hwloc2.patch b/sys-cluster/mpich/files/mpich-3.2.1-hwloc2.patch
new file mode 100644
index 000000000..415a40932
--- /dev/null
+++ b/sys-cluster/mpich/files/mpich-3.2.1-hwloc2.patch
@@ -0,0 +1,42 @@
+From ab59467c51206ac72546e4b734a1b41bf3d0345d Mon Sep 17 00:00:00 2001
+From: Kavitha Tiptur Madhu <kmadhu@anl.gov>
+Date: Fri, 19 Jan 2018 10:44:56 -0600
+Subject: [PATCH] hydra: remove replicate membind option
+
+The "replicate" option of membind is not well supported on a number of
+operating systems, and has been removed from hwloc (in v2.0) as well.
+This patch gets rid of that option in Hydra, in preparation for an
+upgrade to hwloc-2.0.
+
+Signed-off-by: Pavan Balaji <balaji@anl.gov>
+---
+ src/pm/hydra/tools/topo/hwloc/topo_hwloc.c | 3 ---
+ src/pm/hydra/ui/mpich/utils.c | 1 -
+ 2 files changed, 4 deletions(-)
+
+diff --git a/src/pm/hydra/tools/topo/hwloc/topo_hwloc.c b/src/pm/hydra/tools/topo/hwloc/topo_hwloc.c
+index ce15fe7702..74029fad61 100644
+--- a/src/pm/hydra/tools/topo/hwloc/topo_hwloc.c
++++ b/src/pm/hydra/tools/topo/hwloc/topo_hwloc.c
+@@ -424,9 +424,6 @@ HYD_status HYDT_topo_hwloc_init(const char *binding, const char *mapping, const
+ else if (!strncmp(membind, "interleave:", strlen("interleave:"))) {
+ HYDT_topo_hwloc_info.membind = HWLOC_MEMBIND_INTERLEAVE;
+ }
+- else if (!strncmp(membind, "replicate:", strlen("replicate:"))) {
+- HYDT_topo_hwloc_info.membind = HWLOC_MEMBIND_REPLICATE;
+- }
+ else {
+ HYDU_ERR_SETANDJUMP(status, HYD_INTERNAL_ERROR,
+ "unrecognized membind policy \"%s\"\n", membind);
+diff --git a/src/pm/hydra/ui/mpich/utils.c b/src/pm/hydra/ui/mpich/utils.c
+index 9e18a754b5..a9c9dde015 100644
+--- a/src/pm/hydra/ui/mpich/utils.c
++++ b/src/pm/hydra/ui/mpich/utils.c
+@@ -940,7 +940,6 @@ static void bind_to_help_fn(void)
+ printf(" nexttouch -- closest to process that next touches memory\n");
+ printf(" bind:<list> -- bind to memory node list\n");
+ printf(" interleave:<list> -- interleave among memory node list\n");
+- printf(" replicate:<list> -- replicate among memory node list\n");
+ }
+
+ static HYD_status bind_to_fn(char *arg, char ***argv)
diff --git a/sys-cluster/mpich/mpich-3.2.1.ebuild b/sys-cluster/mpich/mpich-3.2.1.ebuild
new file mode 100644
index 000000000..ae3166474
--- /dev/null
+++ b/sys-cluster/mpich/mpich-3.2.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="77 90"
+
+inherit fortran-2 multilib-minimal mpi
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mpich.org/"
+SRC_URI="http://www.mpich.org/static/downloads/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="mpich"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cxx doc fortran mpi-threads romio threads"
+
+COMMON_DEPEND="
+ >=dev-libs/libaio-0.3.109-r5[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-1.10.0-r2[${MULTILIB_USEDEP}]
+ romio? ( net-fs/nfs-utils )
+ $(mpi_imp_deplist)"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-hwloc2.patch"
+)
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpicxx.h
+ /usr/include/mpi.h
+ /usr/include/opa_config.h
+)
+
+src_prepare() {
+ default
+
+ # Using MPICHLIB_LDFLAGS doesn't seem to fully work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich.pc.in \
+ src/env/*.in \
+ || die
+}
+
+multilib_src_configure() {
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories. Hence the separate
+ # local vars.
+
+ local c=
+ if use mpi-threads; then
+ # MPI-THREAD requries threading.
+ c="${c} --with-thread-package=pthreads"
+ c="${c} --enable-threads=runtime"
+ else
+ if use threads ; then
+ c="${c} --with-thread-package=pthreads"
+ else
+ c="${c} --with-thread-package=none"
+ fi
+ c="${c} --enable-threads=single"
+ fi
+
+ if ! mpi_classed; then
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ else
+ c="${c} --docdir=$(mpi_root)/usr/share/doc/${PF}"
+ fi
+
+ export MPICHLIB_CFLAGS="${CFLAGS}"
+ export MPICHLIB_CPPFLAGS="${CPPFLAGS}"
+ export MPICHLIB_CXXFLAGS="${CXXFLAGS}"
+ export MPICHLIB_FFLAGS="${FFLAGS}"
+ export MPICHLIB_FCFLAGS="${FCFLAGS}"
+ export MPICHLIB_LDFLAGS="${LDFLAGS}"
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ ECONF_SOURCE=${S} econf $(mpi_econf_args) \
+ --enable-shared \
+ --with-hwloc-prefix="${EPREFIX}/usr" \
+ ${c} \
+ --with-pm=hydra \
+ --disable-fast \
+ --enable-versioning \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(multilib_native_use_enable fortran fortran all)
+}
+
+multilib_src_test() {
+ emake -j1 check
+}
+
+multilib_src_install() {
+ default
+
+ # fortran header cannot be wrapped (bug #540508), workaround part 1
+ if multilib_is_native_abi && use fortran; then
+ mkdir "${T}"/fortran || die
+ mv "${ED}"/$(mpi_root)/usr/include/mpif* "${T}"/fortran || die
+ mv "${ED}"/$(mpi_root)/usr/include/*.mod "${T}"/fortran || die
+ else
+ # some fortran files get installed unconditionally
+ rm "${ED}"/$(mpi_root)/usr/include/mpif* "${ED}"usr/include/*.mod || die
+ fi
+}
+
+multilib_src_install_all() {
+ # fortran header cannot be wrapped (bug #540508), workaround part 2
+ if use fortran; then
+ mv "${T}"/fortran/* "${ED}"/$(mpi_root)/usr/include || die
+ fi
+
+ mpi_dodir /usr/share/doc/${PF}
+ mpi_dodoc COPYRIGHT README{,.envvar} CHANGES RELEASE_NOTES
+ mpi_newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ mpi_newdoc src/mpi/romio/README README.romio
+ fi
+
+ local d=$(echo ${ED}/$(mpi_root)/ | sed 's,///*,/,g')
+ if ! use doc; then
+ rm -rf "${d}"usr/share/doc/${PF}/www* || die
+ fi
+
+ MPI_ESELECT_FILE="eselect.mpi.mpich"
+ mpi_imp_add_eselect
+}