aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-28 09:13:38 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-28 09:13:38 +0100
commit3a5e4ddcf7f1369051ebe8344c9fa15e3a392220 (patch)
tree92aee2f056b835510404ad248faa40693f63c825 /virtual
parentvirtual/blas: Update deps, Drop unsupported ABIs (diff)
downloadsci-3a5e4ddcf7f1369051ebe8344c9fa15e3a392220.tar.gz
sci-3a5e4ddcf7f1369051ebe8344c9fa15e3a392220.tar.bz2
sci-3a5e4ddcf7f1369051ebe8344c9fa15e3a392220.zip
virtual/lapacke: Version Bump, add ABI_X86 and int64 support
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/lapacke/lapacke-3.6.ebuild27
-rw-r--r--virtual/lapacke/metadata.xml4
2 files changed, 31 insertions, 0 deletions
diff --git a/virtual/lapacke/lapacke-3.6.ebuild b/virtual/lapacke/lapacke-3.6.ebuild
new file mode 100644
index 000000000..c469912b3
--- /dev/null
+++ b/virtual/lapacke/lapacke-3.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for LAPACK C implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="int64"
+
+RDEPEND="
+ || (
+ abi_x86_64? ( !abi_x86_32? ( >=sci-libs/lapacke-reference-3.5 ) )
+ sci-libs/mkl[int64?,${MULTILIB_USEDEP}]
+ )
+ int64? ( sci-libs/mkl[int64,${MULTILIB_USEDEP}] )
+ "
+DEPEND=""
diff --git a/virtual/lapacke/metadata.xml b/virtual/lapacke/metadata.xml
index 43a75c8ae..a21ef90cb 100644
--- a/virtual/lapacke/metadata.xml
+++ b/virtual/lapacke/metadata.xml
@@ -6,4 +6,8 @@
Gentoo virtual package for the Linear Algebra PACKAge
C implementation.
</longdescription>
+ <use>
+ <flag name="int64">Add eselect module for blas libraries built with 64 bits
+ integer ABI</flag>
+ </use>
</pkgmetadata>