aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-22 12:35:17 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-22 12:35:17 +0100
commitfd80af8af63aa6ac64a35867c3731776e3e22355 (patch)
tree6a4e7eaf4f3f9f8115db74c4f627cd2643980d8d /x11-libs/agg/agg-2.5-r3.ebuild
parentdev-cpp/growler-thread: Bump to EAPI=6 (diff)
downloadsci-fd80af8af63aa6ac64a35867c3731776e3e22355.tar.gz
sci-fd80af8af63aa6ac64a35867c3731776e3e22355.tar.bz2
sci-fd80af8af63aa6ac64a35867c3731776e3e22355.zip
x11-libs/agg: Bump to EAPI=6
* Amend patches for -p1 * Drop usage of autotools-utils.eclass Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'x11-libs/agg/agg-2.5-r3.ebuild')
-rw-r--r--x11-libs/agg/agg-2.5-r3.ebuild43
1 files changed, 16 insertions, 27 deletions
diff --git a/x11-libs/agg/agg-2.5-r3.ebuild b/x11-libs/agg/agg-2.5-r3.ebuild
index bc6eda331..d9d07db57 100644
--- a/x11-libs/agg/agg-2.5-r3.ebuild
+++ b/x11-libs/agg/agg-2.5-r3.ebuild
@@ -1,13 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=1
-AT_M4DIR="."
-
-inherit eutils autotools-utils
+inherit autotools
DESCRIPTION="High quality rendering engine library for C++"
HOMEPAGE="http://antigrain.com/"
@@ -32,28 +29,20 @@ DOCS=( readme authors ChangeLog news )
# patches taken from fedora
PATCHES=(
- "${FILESDIR}"/${PV}/agg-2.4-depends.patch
- "${FILESDIR}"/${PV}/agg-2.5-pkgconfig.patch
- "${FILESDIR}"/${PV}/agg-2.5-autotools.patch
- "${FILESDIR}"/${PV}/agg-2.5-sdl-m4.patch
- "${FILESDIR}"/${PV}/agg-2.5-sdl-automagic.patch
- "${FILESDIR}"/${PV}/0001-Fix-non-terminating-loop-conditions-when-len-1.patch
- "${FILESDIR}"/${PV}/0002-Cure-recursion-by-aborting-if-the-co-ordinates-are-t.patch
- "${FILESDIR}"/${PV}/0003-Get-coordinates-from-previous-vertex-if-last-command.patch
- "${FILESDIR}"/${PV}/0004-Make-rasterizer_outline_aa-ignore-close_polygon-when.patch
- "${FILESDIR}"/${PV}/0005-Remove-VC-6-workaround.patch
- "${FILESDIR}"/${PV}/0006-Implement-grain-merge-blending-mode-GIMP.patch
- "${FILESDIR}"/${PV}/0007-Implement-grain-extract-blending-mode-GIMP.patch
- "${FILESDIR}"/${PV}/0008-Declare-multiplication-and-division-operators-as-con.patch
- "${FILESDIR}"/${PV}/0009-Add-a-static-identity-transformation.patch
- "${FILESDIR}"/${PV}/0010-Add-renderer_scanline_aa_alpha.patch
- "${FILESDIR}"/${PV}/0011-Avoid-division-by-zero-in-color-burn-mode.patch
- "${FILESDIR}"/${PV}/0012-Avoid-pixel-artifacts-when-compositing.patch
- "${FILESDIR}"/${PV}/0013-Modify-agg-conv-classes-to-allow-access-to-the-origi.patch
- "${FILESDIR}"/${PV}/0014-Avoid-potential-zero-division-resulting-in-nan-in-ag.patch
- "${FILESDIR}"/${PV}/0015-Ensure-first-value-in-the-gamma-table-is-always-zero.patch
+ "${FILESDIR}"/agg-2.4-depends.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-sdl-m4.patch
+ "${FILESDIR}"/${P}-sdl-automagic.patch
+ "${FILESDIR}"/${PV}
)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ AT_M4DIR="." eautoreconf
+}
+
src_configure() {
local myeconfargs=(
--disable-ctrl
@@ -64,5 +53,5 @@ src_configure() {
$(use_enable truetype freetype)
$(use_with X x)
)
- autotools-utils_src_configure
+ econf ${myeconfargs[@]}
}