aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-12 16:46:51 +0100
committerJustin Lecher <jlec@gentoo.org>2012-11-12 16:46:51 +0100
commit9e5b747dc222c412aa93d48db148da37112fa97d (patch)
treec9f64da86833ed47bdf2207b161479e8c91f853c /x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild
parentopenbabel-python: Enter BUILD_DIR in src_install (diff)
downloadsci-9e5b747dc222c412aa93d48db148da37112fa97d.tar.gz
sci-9e5b747dc222c412aa93d48db148da37112fa97d.tar.bz2
sci-9e5b747dc222c412aa93d48db148da37112fa97d.zip
x11-libs/xview-bin: Update to latest debian patches
Package-Manager: portage-2.2.0_alpha142
Diffstat (limited to 'x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild')
-rw-r--r--x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild b/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild
new file mode 100644
index 000000000..4218a49cc
--- /dev/null
+++ b/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild
@@ -0,0 +1,36 @@
+## Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DEBVER="3.2p1.4-28"
+
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations - binary package"
+HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
+SRC_URI="mirror://debian/pool/main/x/xview/xviewg_${DEBVER}_i386.deb"
+
+LICENSE="XVIEW"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="static-libs"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_install() {
+ local lib_dir
+ if use prefix; then
+ lib_dir=lib
+ else
+ lib_dir=lib32
+ fi
+ dodir /usr/${lib_dir}/
+ mv usr/lib/* "${ED}"/usr/${lib_dir}/ || die
+}