aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/wxmacmolplt/Manifest1
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch12
-rw-r--r--sci-chemistry/wxmacmolplt/metadata.xml11
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.1.ebuild47
4 files changed, 71 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/Manifest b/sci-chemistry/wxmacmolplt/Manifest
new file mode 100644
index 000000000..13cf4a771
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/Manifest
@@ -0,0 +1 @@
+DIST wxmacmolplt-7.6.1.tar.gz 2353688 SHA256 930e7afd00fe1af68a2b4fdfef15aad1527ab36dd385c85d71bff98edcbbede1 SHA512 d8e3b531150d895f3c746eb9beb27525103e4e90fb1782f2c862cd914d276e65e41cec5d48fda5d579e7bc865092c16b17fa988314b8d7062ebd9ef0aa3bf476 WHIRLPOOL 6ea77b282eea96bf9cd1c4fb92a4d6ea77f0c52c2f99508afa176f5ffc3dc3f5085c0dc17ccfb8e0db3f3ebcd432fd9e56abb20101b204f88f951b5746c04b6d
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
new file mode 100644
index 000000000..08986db5b
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
@@ -0,0 +1,12 @@
+diff -urN wxmacmolplt-7.4.2.orig/configure.ac wxmacmolplt-7.4.2/configure.ac
+--- wxmacmolplt-7.4.2.orig/configure.ac 2010-12-05 02:48:29.000000000 +0300
++++ wxmacmolplt-7.4.2/configure.ac 2010-12-06 19:30:24.000000000 +0300
+@@ -20,7 +20,7 @@
+ ;;
+ *)
+ HOST=LINUX
+- LIBGL="-lGL -lGLU"
++ LIBGL=`pkg-config --libs glu glew`
+ ;;
+ esac
+ AM_CONDITIONAL(HOST_IS_MSW, [test "x$HOST" == xMSW])
diff --git a/sci-chemistry/wxmacmolplt/metadata.xml b/sci-chemistry/wxmacmolplt/metadata.xml
new file mode 100644
index 000000000..cd9831eb3
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+wxMacMolPlt is a program for plotting 3D molecular structures and normal modes (vibrations), various orbitals and electron density maps. It reads a variety of file formats including any GAMESS input, log or IRC file directly to create animations. It has a simple GAMESS input (.inp) builder and a primitive molecule builder.
+</longdescription>
+ <use>
+ <flag name="flash">Add support for flash movie generation using <pkg>media-libs/ming</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.1.ebuild
new file mode 100644
index 000000000..62a1a4cd7
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://brettbode.github.io/wxmacmolplt/"
+SRC_URI="https://github.com/brettbode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="flash"
+
+RDEPEND="
+ media-libs/glew
+ media-libs/mesa
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ flash? ( media-libs/ming )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ need-wxwidgets unicode
+ epatch "${FILESDIR}"/${PN}-7.5-glew.patch
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-glew \
+ $(use_with flash ming)
+}
+
+src_install() {
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}