aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/kat/kat-2.4.2.ebuild15
-rw-r--r--sci-biology/kat/kat-9999.ebuild15
2 files changed, 20 insertions, 10 deletions
diff --git a/sci-biology/kat/kat-2.4.2.ebuild b/sci-biology/kat/kat-2.4.2.ebuild
index e8f10ad5d..39c4fc6c1 100644
--- a/sci-biology/kat/kat-2.4.2.ebuild
+++ b/sci-biology/kat/kat-2.4.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
# https://github.com/Ensembl/Bio-DB-HTS/issues/30
inherit flag-o-matic autotools distutils-r1
@@ -23,9 +24,9 @@ CDEPEND="
dev-python/tabulate[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
DEPEND="${CDEPEND}
- dev-python/sphinx
test? ( sys-process/time )"
RDEPEND="${CDEPEND}"
# contains bundled and *modified* version of jellyfish-2.2.0
@@ -40,6 +41,9 @@ PATCHES=(
S="${WORKDIR}"/KAT-Release-"${PV}"
+distutils_enable_sphinx "${S}/doc/source" --no-autodoc
+distutils_enable_tests pytest
+
src_prepare(){
default
rm -rf deps/boost || die "Failed to zap bundled boost"
@@ -75,4 +79,5 @@ src_install(){
src_test(){
default
+ python_foreach_impl python_test
}
diff --git a/sci-biology/kat/kat-9999.ebuild b/sci-biology/kat/kat-9999.ebuild
index 961dc9ce8..752dab83c 100644
--- a/sci-biology/kat/kat-9999.ebuild
+++ b/sci-biology/kat/kat-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
# https://github.com/Ensembl/Bio-DB-HTS/issues/30
inherit flag-o-matic autotools distutils-r1 git-r3
@@ -24,9 +25,9 @@ CDEPEND="
dev-python/tabulate[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
DEPEND="${CDEPEND}
- dev-python/sphinx
test? ( sys-process/time )"
RDEPEND="${CDEPEND}"
# contains bundled and *modified* version of jellyfish-2.2.0
@@ -41,6 +42,9 @@ PATCHES=(
S="${WORKDIR}"/KAT-Release-"${PV}"
+distutils_enable_sphinx "${S}/doc/source" --no-autodoc
+distutils_enable_tests pytest
+
src_prepare(){
default
rm -rf deps/boost || die "Failed to zap bundled boost"
@@ -76,4 +80,5 @@ src_install(){
src_test(){
default
+ python_foreach_impl python_test
}