aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/pymol/ChangeLog4
-rw-r--r--sci-chemistry/pymol/files/pymol-9999-options.patch15
-rw-r--r--sci-chemistry/pymol/pymol-9999.ebuild4
3 files changed, 23 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index bb3c5db22..2cce80569 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 20 Oct 2014; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild,
+ +files/pymol-9999-options.patch:
+ Fix upstream buildsystem
+
17 Oct 2014; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild:
Import tree changes
diff --git a/sci-chemistry/pymol/files/pymol-9999-options.patch b/sci-chemistry/pymol/files/pymol-9999-options.patch
new file mode 100644
index 000000000..ce05e172e
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-9999-options.patch
@@ -0,0 +1,15 @@
+ pymol/setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pymol/setup.py b/pymol/setup.py
+index c446d6c..b7b353b 100644
+--- a/pymol/setup.py
++++ b/pymol/setup.py
+@@ -51,6 +51,7 @@ def CCompiler_compile(self, sources, output_dir=None, macros=None,
+ class options:
+ osx_frameworks = False
+ jobs = int(os.getenv('JOBS', 0))
++ no_libxml = False
+
+ try:
+ import argparse
diff --git a/sci-chemistry/pymol/pymol-9999.ebuild b/sci-chemistry/pymol/pymol-9999.ebuild
index b45111e77..a811e69ed 100644
--- a/sci-chemistry/pymol/pymol-9999.ebuild
+++ b/sci-chemistry/pymol/pymol-9999.ebuild
@@ -37,6 +37,10 @@ DEPEND="
web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-options.patch
+)
+
src_unpack() {
unpack ${A}
subversion_src_unpack