aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/xds-bin/ChangeLog13
-rw-r--r--sci-chemistry/xds-bin/Manifest5
-rw-r--r--sci-chemistry/xds-bin/metadata.xml11
-rw-r--r--sci-chemistry/xds-bin/xds-bin-20081214.ebuild55
4 files changed, 84 insertions, 0 deletions
diff --git a/sci-chemistry/xds-bin/ChangeLog b/sci-chemistry/xds-bin/ChangeLog
new file mode 100644
index 000000000..e2e761d57
--- /dev/null
+++ b/sci-chemistry/xds-bin/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/xds-bin
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Dec 2008; Justin Lecher (jlec) <jlec@j-schmitz.net> ++, metadata.xml,
+ -xds-bin-20080910.ebuild:
+ Version bump to 20081214
+
+ 20 Nov 2008; justin Lecher <justin@j-schmitz.net> ++,
+ -xds-bin-20071206.ebuild, -xds-bin-20080602.ebuild,
+ -xds-bin-20080714.ebuild:
+ version fixed xds-bin-20080910.ebuild
+
diff --git a/sci-chemistry/xds-bin/Manifest b/sci-chemistry/xds-bin/Manifest
new file mode 100644
index 000000000..efa3085e5
--- /dev/null
+++ b/sci-chemistry/xds-bin/Manifest
@@ -0,0 +1,5 @@
+DIST XDS-linux_ifc_Intel+AMD-20081214.tar.gz 6018729 RMD160 3c11a7b464cecd8068b3bc7346a414842985ebcf SHA1 eb3857a7107616809d419f28548c99a5075f56db SHA256 5656ddb31760b5b1bbd2bda9cb54fb24c13701d8e3d9dea19c30898830128134
+DIST XDS_html_doc-20081214.tar.gz 91816 RMD160 d4579bafe74e14cf82bbd66890eaaf06f92ccba1 SHA1 207b4014b54b9b0e87c1b9b579737867a396eae9 SHA256 89a807ef45be2fb6914b464df171ba0dda9f3f66c70176b740c745bf673790e2
+EBUILD xds-bin-20081214.ebuild 1354 RMD160 9a5567649c7dba510c9da8838f65d2e4cefe2485 SHA1 f25ce06b5954f13f3bc9f6b3fc750e01d365aab5 SHA256 1c630d7c90fa34434bc23a8c3f1a2e15124b59c78256538c765472b92bebc7c4
+MISC ChangeLog 432 RMD160 529068684f441f611535e8133bd037cc6e4e94d9 SHA1 7893055c7493baef67c8cbcf45980f92bb17b889 SHA256 bd3c1e26b58d45d2c81e9ee6cdc91a9dd6f8e6cd16c7ef110bf1fa9e2bbc0276
+MISC metadata.xml 285 RMD160 c1b661548cfa1d71ec057f354be28bfeb3d4f71a SHA1 baea4d39bedf1ebf1052e0e4ab10e67e7e06e463 SHA256 e5739146b5422b3ed31744f741491b1bd868833d7c1e3666dcadc5a340d0224b
diff --git a/sci-chemistry/xds-bin/metadata.xml b/sci-chemistry/xds-bin/metadata.xml
new file mode 100644
index 000000000..d08018ee7
--- /dev/null
+++ b/sci-chemistry/xds-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jlec@j-schmitz.net</email>
+</maintainer>
+<use>
+ <flag name='smp'>Makes use of more CPUs</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/xds-bin/xds-bin-20081214.ebuild b/sci-chemistry/xds-bin/xds-bin-20081214.ebuild
new file mode 100644
index 000000000..34c254df1
--- /dev/null
+++ b/sci-chemistry/xds-bin/xds-bin-20081214.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="X-ray Detector Software for processing single-crystal monochromatic diffraction data."
+SRC_URI="XDS-linux_ifc_Intel+AMD-${PV}.tar.gz
+ XDS_html_doc-${PV}.tar.gz"
+HOMEPAGE="http://www.mpimf-heidelberg.mpg.de/~kabsch/xds/"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="smp X"
+RDEPEND="X? ( x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libX11 )"
+DEPEND=""
+
+pkg_nofetch(){
+ ewarn "Fetch XDS-linux_ifc_Intel+AMD.tar.gz and XDS_html_doc.tar.gz"
+ ewarn "from ${HOMEPAGE}html_doc/downloading.html"
+ ewarn "rename it to $A and"
+ ewarn "place it in $DISTDIR"
+}
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe XDS-linux_ifc_Intel+AMD/*
+ if use smp; then
+ rm "${D}"/opt/${PN}/{xds,mintegrate,mcolspot,xscale}
+ dosym xds_par /opt/${PN}/xds
+ dosym xscale_par /opt/${PN}/xscale
+ dosym mintegrate_par /opt/${PN}/mintegrate
+ dosym mcolspot_par /opt/${PN}/mcolspot
+ else
+ rm "${D}"/opt/${PN}/*par
+ fi
+ if ! use X; then
+ rm "${D}"/opt/${PN}/VIEW
+ fi
+ dohtml -r XDS_html_doc/*
+ dodoc XDS_html_doc/html_doc/INPUT_templates/*
+
+ cat >> "${T}"/20xds <<- EOF
+ PATH="/opt/${PN}/"
+ EOF
+ doenvd "${T}"/20xds
+}
+
+pkg_postinst() {
+ elog "This package will expire on December 31, 2008"
+}
+