aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/ugene/Manifest1
-rw-r--r--sci-biology/ugene/metadata.xml12
-rw-r--r--sci-biology/ugene/ugene-1.20.0.ebuild42
3 files changed, 0 insertions, 55 deletions
diff --git a/sci-biology/ugene/Manifest b/sci-biology/ugene/Manifest
deleted file mode 100644
index 1288bb2e7..000000000
--- a/sci-biology/ugene/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ugene-1.20.0.tar.gz 21194907 SHA256 618987aa599d8880b53fd6bf1938b2b57d7a6112c909b8cce9b21b05e7a36c5f SHA512 063d15de5ddd39876ac5364d7ec4313080bf2816fb5d0b78b9b8de9b5ae9b473019c6ee3f5494acba8391a6a052344d4737dbc968c6f307ce449d46717a1293a WHIRLPOOL 5c084b8a2bcbc583443d9406ad5c6fc612bf31959e84361af9f7112470fc8af22bdc02828e4bdbf160399fc661b2aaf4bbb8478ec882d7c25d6a41c757b90ec6
diff --git a/sci-biology/ugene/metadata.xml b/sci-biology/ugene/metadata.xml
deleted file mode 100644
index a3daeebd2..000000000
--- a/sci-biology/ugene/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>alexxy@gentoo.org</email>
- <name>Alexey Shvetsov</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/sci-biology/ugene/ugene-1.20.0.ebuild b/sci-biology/ugene/ugene-1.20.0.ebuild
deleted file mode 100644
index 3aa9dfebe..000000000
--- a/sci-biology/ugene/ugene-1.20.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit qmake-utils
-
-DESCRIPTION="A free open-source cross-platform bioinformatics software"
-HOMEPAGE="http://ugene.unipro.ru"
-SRC_URI="http://${PN}.unipro.ru/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cpu_flags_x86_sse2"
-
-# http://ugene.net/download.html states Qt5.4 and QtWebkit but:
-# Project MESSAGE: Cannot build Unipro UGENE with Qt version 4.8.7
-# Project ERROR: Use at least Qt 5.2.1.
-DEPEND="
- >=dev-qt/qtgui-5.2.1
- >=dev-qt/qtscript-5.2.1[scripttools]"
-RDEPEND="${DEPEND}"
-
-LANGS="cs en ru zh"
-
-src_configure() {
- local CONFIG_OPTS
- if use amd64; then
- CONFIG_OPTS+=( CONFIG+="x64" )
- elif use ppc; then
- CONFIG_OPTS+=( CONFIG+="ppc" )
- fi
-
- use cpu_flags_x86_sse2 && CONFIG_OPTS+=( use_sse2 )
-
- eqmake5 $CONFIG_OPTS || die
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
-}