aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/ABI-connectivity-data/ABI-connectivity-data-0.2.ebuild32
-rw-r--r--sci-biology/ABI-connectivity-data/Manifest1
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/ABI-connectivity-data/ABI-connectivity-data-0.2.ebuild b/sci-biology/ABI-connectivity-data/ABI-connectivity-data-0.2.ebuild
new file mode 100644
index 000000000..260ce274d
--- /dev/null
+++ b/sci-biology/ABI-connectivity-data/ABI-connectivity-data-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit check-reqs
+
+DESCRIPTION="Connectivity data from the Allen Mouse Brain data portal"
+HOMEPAGE="https://github.com/IBT-FMI/ABI-connectivity-data"
+SRC_URI="http://chymera.eu/distfiles/${P}.tar.xz"
+
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND=""
+
+pkg_pretend() {
+ CHECKREQS_DISK_BUILD="3G"
+ CHECKREQS_DISK_USR="3G"
+ CHECKREQS_DISK_VAR="3G"
+ check-reqs_pkg_pretend
+}
+
+# We disable this phase to not check requirements twice.
+pkg_setup() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r *
+}
diff --git a/sci-biology/ABI-connectivity-data/Manifest b/sci-biology/ABI-connectivity-data/Manifest
index 58064c9e2..59b871e12 100644
--- a/sci-biology/ABI-connectivity-data/Manifest
+++ b/sci-biology/ABI-connectivity-data/Manifest
@@ -1 +1,2 @@
DIST ABI-connectivity-data-0.1.tar.xz 2748905328 BLAKE2B c404798d2ecbe740d7cfae295aeab52d99086e3effa6dc23eca42409990a7ed2cdf7d448010fc0f08178a7dfd638a083fb87afcc66797dc4bf7b5095cec02253 SHA512 91643114456362327e617db682636bc564c131ebd797dc4edda493c2d96c2beb9567ef87b3baf8bce77815a755de8ea010fa6399460a839070f1a179d07b755d
+DIST ABI-connectivity-data-0.2.tar.xz 2746778304 BLAKE2B 70ca32dd0a40fe6d6f3c402af9e4c8e1884d9ef8ecf98fd9751f0cd0c4f10b1923e6be4f0137e4d424705009bbbe1ca3c74ef5145189fa18c9970c40fc8f9fa5 SHA512 60538a45defaec32b126f7dd639f61fb030d9ef4830ff9ebb63736087493935312209dbd6591eb245a72be1217c35a3f877a7549918cc1bc39dfd34b2c23d478