aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/scikits_timeseries/ChangeLog10
-rw-r--r--sci-libs/scikits_timeseries/Manifest3
-rw-r--r--sci-libs/scikits_timeseries/metadata.xml16
-rw-r--r--sci-libs/scikits_timeseries/scikits_timeseries-0.91.1.ebuild28
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/scikits_timeseries/ChangeLog b/sci-libs/scikits_timeseries/ChangeLog
new file mode 100644
index 000000000..aa67e19d0
--- /dev/null
+++ b/sci-libs/scikits_timeseries/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/scikits_timeseries
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*scikits_timeseries-0.91.1 (17 Jun 2009)
+
+ 17 Jun 2009; Tim Cera <timcera@earthlink.net>
+ +scikits_timeseries-0.91.1.ebuild, +metadata.xml:
+ sci-libs/scikits_timeseries-0.91.1.ebuild: Initial ebuild.
+
diff --git a/sci-libs/scikits_timeseries/Manifest b/sci-libs/scikits_timeseries/Manifest
new file mode 100644
index 000000000..444b9d83b
--- /dev/null
+++ b/sci-libs/scikits_timeseries/Manifest
@@ -0,0 +1,3 @@
+DIST scikits.timeseries-0.91.1-html_docs.zip 917240 RMD160 7e1a5fda973de933e75604fa782527dd3163a65a SHA1 4f5cd6bf78b2fdb42262cc165c9892cdfa3c34ff SHA256 9b97d5052ec2e7161f9d0e30a75fe52180b063f465617dcef198626a5fd04153
+DIST scikits.timeseries-0.91.1.tar.gz 304553 RMD160 7a188145f2422ea58dd2fafd42e0dbb34bdeb3f8 SHA1 dbe4beb0be770019e44eacc7f33186dc643c389a SHA256 577624af45ac4205830e56dbe5747abbbb8fcb2ebbe321caafd9fa71086e2200
+EBUILD scikits_timeseries-0.91.1.ebuild 726 RMD160 22fce8bda819dd98a769a36a9d707e3d0a68554d SHA1 e6e7c17a616806595e8e4bc2ad866a150b693d30 SHA256 8d2c4ae17f081c66e593ca329c476bff772ea186b81f334d31614f1da9749d2b
diff --git a/sci-libs/scikits_timeseries/metadata.xml b/sci-libs/scikits_timeseries/metadata.xml
new file mode 100644
index 000000000..a74615cd1
--- /dev/null
+++ b/sci-libs/scikits_timeseries/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>timcera@earthlink.net</email>
+<name>Tim Cera</name>
+</maintainer>
+<longdescription lang="en">
+TAPPY is a tidal analysis package. It breaks down a record of water levels into
+the component sine waves. It is written in Python and uses the least squares
+optimization and other functions in SciPy. The focus is to make the most
+accurate analysis possible. TAPPY only determines the constituents that are
+calculatable according to the length of the time series.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/scikits_timeseries/scikits_timeseries-0.91.1.ebuild b/sci-libs/scikits_timeseries/scikits_timeseries-0.91.1.ebuild
new file mode 100644
index 000000000..a271a79ea
--- /dev/null
+++ b/sci-libs/scikits_timeseries/scikits_timeseries-0.91.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_P="${P/scikits_/scikits.}"
+
+DESCRIPTION="Provides classes and functions for manipulating, reporting, and
+plotting time series of various frequencies."
+HOMEPAGE="http://pytseries.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/pytseries/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/pytseries/${MY_P}-html_docs.zip )"
+
+LICENSE="BSD eGenixPublic"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/setuptools-0.6_rc9
+ >=dev-python/numpy-1.3.0
+ >=sci-libs/scipy-0.7.0
+ >=dev-python/matplotlib-0.98.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+