aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/almost/ChangeLog8
-rw-r--r--sci-chemistry/almost/Manifest5
-rw-r--r--sci-chemistry/almost/almost-1.0.3.ebuild55
-rw-r--r--sci-chemistry/almost/files/gcc-4.3.patch60
-rw-r--r--sci-chemistry/almost/metadata.xml10
5 files changed, 138 insertions, 0 deletions
diff --git a/sci-chemistry/almost/ChangeLog b/sci-chemistry/almost/ChangeLog
new file mode 100644
index 000000000..bc499938e
--- /dev/null
+++ b/sci-chemistry/almost/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-chemistry/almost
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 07 Nov 2008; justin Lecher <jlec@j-schmitz.net> +metadata.xml,
+ +almost-1.0.3.ebuild:
+ Setup sci-chemistry/almost
+
diff --git a/sci-chemistry/almost/Manifest b/sci-chemistry/almost/Manifest
new file mode 100644
index 000000000..08775c1b6
--- /dev/null
+++ b/sci-chemistry/almost/Manifest
@@ -0,0 +1,5 @@
+AUX gcc-4.3.patch 1766 RMD160 56732dd9e2bb4fab2808c9f919e0393b10449216 SHA1 49347a5cc03f97feec2b1f3575ba0247e1c061c0 SHA256 f9aa5c578cb0ba24724ad11c12f81c96303ca3bb6700d6cdcf22656d6d1b3032
+DIST almost-1.0.3.tar.gz 14056910 RMD160 409a53f661876eb1fba702ee6cc62a2928a5c014 SHA1 bd9c21d1f0e802f66e30c9ad9794a2f9ce98c5da SHA256 94893ce43f50e426c9ecfba67c5a555307ba9eb19b2a2034a69e5828778e9632
+EBUILD almost-1.0.3.ebuild 1289 RMD160 f9e4918b1405bc273c765268d6aabc4dacf865d2 SHA1 6b518414d47fcd370b9dc0042789ef028cc26258 SHA256 93aae4f321e2b15dd5e49729ce51e24ab85eec9eefcee950f22775358c2d5e83
+MISC ChangeLog 240 RMD160 b6d2dff2819bd8f01b9774323cd37490ad21c87d SHA1 21ec06f925f415df16d6ab53eeae155d723495c8 SHA256 d9c4c538b6fa627d6f50efb4c6f3a89d55f372125d75b48cb08965bdeb8c5788
+MISC metadata.xml 268 RMD160 adbf63d25b16c6d9199c20ab0092b9a75a851605 SHA1 ffc9c0fba9a923d9ba5326283b60c31573888cf3 SHA256 6a8f1e47a14b8730b4a7ba9e0f0055ab4d6071ebcaf12bb601e8b949223c0c7f
diff --git a/sci-chemistry/almost/almost-1.0.3.ebuild b/sci-chemistry/almost/almost-1.0.3.ebuild
new file mode 100644
index 000000000..ff764d7f5
--- /dev/null
+++ b/sci-chemistry/almost/almost-1.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="all atom molecular simulation toolkit"
+HOMEPAGE="http://www-almost.ch.cam.ac.uk/site"
+#SRC_URI="http://www-almost.ch.cam.ac.uk/site/downloads/${P}.tar.gz"
+## Upstream changes tarballs w/o revision bump so I host a copy
+SRC_URI="http://gentoo.j-schmitz.net/portage/distfiles/ALL/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND=""
+
+## dev-libs/boost-1.3.6, once it is in the tree soft masked
+## until then we use the shipped one
+# Upstream has to fix its code so that it compiles with mpicxx
+## Upstream only uses sys-cluster/mpich2, so we should first get this to work.
+#DEPEND="mpi? ( sys-cluster/mpich2 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror"
+
+src_unpack(){
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}"/gcc-4.3.patch
+ eautoreconf || die "Reconfiguration failed"
+}
+
+src_compile(){
+
+ econf || die "configure failed"
+
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || \
+ die "make failed"
+
+}
+
+src_test() {
+ emake check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodoc README NEWS TODO ChangeLog AUTHORS
+}
diff --git a/sci-chemistry/almost/files/gcc-4.3.patch b/sci-chemistry/almost/files/gcc-4.3.patch
new file mode 100644
index 000000000..44d06c73f
--- /dev/null
+++ b/sci-chemistry/almost/files/gcc-4.3.patch
@@ -0,0 +1,60 @@
+#--- src/lib/modules/shx/shxmalloc.cpp.orig 2008-11-07 11:41:35.000000000 +0100
+#+++ src/lib/modules/shx/shxmalloc.cpp 2008-11-07 11:41:43.000000000 +0100
+#@@ -15,6 +15,7 @@
+# ***************************************************************************/
+
+# #include <vector>
+#+#include <cstdlib>
+#
+# using namespace std;
+#
+#--- ./include/almost/forcefield/spec.h.orig 2008-11-07 11:57:47.000000000 +0100
+#+++ ./include/almost/forcefield/spec.h 2008-11-07 11:58:35.000000000 +0100
+#@@ -20,6 +20,7 @@
+# #define __SPEC__
+#
+# #include <almost.h>
+#+#include <typeinfo>
+# namespace Almost {
+#
+# struct None{};
+--- include/almost/cheshire/pssi.h.orig 2008-11-07 12:47:11.000000000 +0100
++++ include/almost/cheshire/pssi.h 2008-11-07 12:47:24.000000000 +0100
+@@ -22,6 +22,7 @@
+ #include <almost.h>
+ #include <sstream>
+ #include <iterator>
++#include <cstring>
+ namespace Almost {
+
+ class PSSI {
+--- src/lib/algorithm/topos.cpp.orig 2008-11-07 13:18:10.000000000 +0100
++++ src/lib/algorithm/topos.cpp 2008-11-07 13:18:27.000000000 +0100
+@@ -27,6 +27,7 @@
+ #include <cmath>
+ #include <cheshire/topos.h>
+ #include <cheshire/topos_rc.h>
++#include <cstring>
+ namespace Almost {
+
+ namespace Topos {
+--- include/almost/rose/rosedb.h.orig 2008-11-07 12:26:56.000000000 +0100
++++ include/almost/rose/rosedb.h 2008-11-07 12:27:04.000000000 +0100
+@@ -21,6 +21,7 @@
+
+ #include <almost.h>
+ #include <iterator>
++#include <cstring>
+
+ namespace Utils {
+ inline int toinda(char c){
+--- src/lib/zeta/zobj.cpp 2008-07-22 01:31:34.000000000 +0200
++++ src/lib/zeta/zobj.cpp.new 2008-11-23 19:19:26.000000000 +0100
+@@ -2,6 +2,7 @@
+ #include <zeta/zobj.h>
+ #include <zeta/zobj.hpp>
+ #include <zeta/zextinstance.h>
++#include <cstring>
+
+
+ ZObj * FactoryTrampolin::bind(ZObj * o){
diff --git a/sci-chemistry/almost/metadata.xml b/sci-chemistry/almost/metadata.xml
new file mode 100644
index 000000000..62373450c
--- /dev/null
+++ b/sci-chemistry/almost/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <maintainer>
+ <email>justin@j-schmitz.net</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
+