aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--dev-java/netcdf/ChangeLog5
-rw-r--r--dev-java/netcdf/netcdf-4.2.ebuild2
-rw-r--r--licenses/netCDF31
-rw-r--r--sci-mathematics/mdp/Manifest2
-rw-r--r--sci-mathematics/mdp/mdp-9999.ebuild31
-rw-r--r--sci-physics/LoopTools/Manifest2
7 files changed, 72 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000..9bea4330f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+
+.DS_Store
diff --git a/dev-java/netcdf/ChangeLog b/dev-java/netcdf/ChangeLog
index ce027a2a7..37e3a44a8 100644
--- a/dev-java/netcdf/ChangeLog
+++ b/dev-java/netcdf/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*netcdf-4.2 (18 Nov 2012)
+
+ 18 Nov 2012; W. Trevor King <wking@drexel.edu> netcdf-4.2.ebuild:
+ Fix license (the NetCDF license is neither LGPL or MIT)
+
*netcdf-4.2 (14 May 2012)
14 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +netcdf-4.2.ebuild,
diff --git a/dev-java/netcdf/netcdf-4.2.ebuild b/dev-java/netcdf/netcdf-4.2.ebuild
index a08a9fd12..046da42aa 100644
--- a/dev-java/netcdf/netcdf-4.2.ebuild
+++ b/dev-java/netcdf/netcdf-4.2.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Java Common Data Model (CDM) interface to to netCDF files"
HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf-java/"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/${PN}-java/v${PV}/ncSrc-${PV}.zip"
-LICENSE="LGPL-2 MIT"
+LICENSE="netCDF"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
diff --git a/licenses/netCDF b/licenses/netCDF
new file mode 100644
index 000000000..780ba9ee5
--- /dev/null
+++ b/licenses/netCDF
@@ -0,0 +1,31 @@
+Copyright 1993-2012 University Corporation for Atmospheric Research/Unidata
+
+Portions of this software were developed by the Unidata Program at the
+University Corporation for Atmospheric Research.
+
+Access and use of this software shall impose the following obligations
+and understandings on the user. The user is granted the right, without
+any fee or cost, to use, copy, modify, alter, enhance and distribute
+this software, and any derivative works thereof, and its supporting
+documentation for any purpose whatsoever, provided that this entire
+notice appears in all copies of the software, derivative works and
+supporting documentation. Further, UCAR requests that the user credit
+UCAR/Unidata in any publications that result from the use of this
+software or in any product that includes this software, although this
+is not an obligation. The names UCAR and/or Unidata, however, may not
+be used in any advertising or publicity to endorse or promote any
+products or commercial entity unless specific written permission is
+obtained from UCAR/Unidata. The user also understands that
+UCAR/Unidata is not obligated to provide the user with any support,
+consulting, training or assistance of any kind with regard to the use,
+operation and performance of this software nor to provide the user
+with any updates, revisions, new versions or "bug fixes."
+
+THIS SOFTWARE IS PROVIDED BY UCAR/UNIDATA "AS IS" AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL UCAR/UNIDATA BE LIABLE FOR ANY SPECIAL,
+INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING
+FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION
+WITH THE ACCESS, USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/sci-mathematics/mdp/Manifest b/sci-mathematics/mdp/Manifest
index b779313de..66da7654f 100644
--- a/sci-mathematics/mdp/Manifest
+++ b/sci-mathematics/mdp/Manifest
@@ -1 +1 @@
-DIST MDP-3.2.tar.gz 469010 RMD160 2ca32e16c787806533d84412e4ffc41a1d73b1f3 SHA1 d58123999e655137ee3b85151b32cdb8d2bf9678 SHA256 5310d54766cb91a02988f42bea4b493197155ac1960fbfa41a8c9661b08c1665
+DIST MDP-3.2.tar.gz 469010 SHA256 5310d54766cb91a02988f42bea4b493197155ac1960fbfa41a8c9661b08c1665 SHA512 223629b543ac8baedb891212e1beded231a7b21de167b3f23f4a355ceb7443afd40b1737e5fb96cc2df969c0011b5cbe2ebc7004cbb2ad89cfb75a1ec8b86a80 WHIRLPOOL 2e4fef0ea51af94e627f13ba791f6f22e13c13a1a7e2f2cd18ae311910dd10f30f0071d0a8601404d2604339d5af3873dbfc4585452d17bced91251ffd39aba8
diff --git a/sci-mathematics/mdp/mdp-9999.ebuild b/sci-mathematics/mdp/mdp-9999.ebuild
new file mode 100644
index 000000000..777e9ef5a
--- /dev/null
+++ b/sci-mathematics/mdp/mdp-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit distutils git-2
+
+MY_P="${P/mdp/MDP}"
+MY_P="${MY_P/_rc/RC}"
+
+DESCRIPTION="Modular data processing framework for python"
+HOMEPAGE="http://mdp-toolkit.sourceforge.net/index.html"
+EGIT_REPO_URI="git://github.com/mdp-toolkit/mdp-toolkit.git"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-python/numpy-1.1 >=sci-libs/scipy-0.5.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/src" "$(PYTHON)" -c "import mdp;mdp.test()"
+ }
+ python_execute_function testing
+}
+
+
diff --git a/sci-physics/LoopTools/Manifest b/sci-physics/LoopTools/Manifest
index 381cd33f4..9d2064e18 100644
--- a/sci-physics/LoopTools/Manifest
+++ b/sci-physics/LoopTools/Manifest
@@ -1 +1 @@
-DIST LoopTools-2.8.tar.gz 538787 SHA256 f5c67aea0a17b0cc527c0f666fa33b6242b749d1fc05a89a0af5b88c7ddeeb30 SHA512 e41920244e67e8168c9bd66574c64777ce465f2c68198af99f4908288f519dbfdce3e1804cfc6ede1cd3f02b9772b8a4b19c1b3722a59d1bd988ccec3a7fc81c WHIRLPOOL 2d2f11a83c6679a4315463a4c549b02c0d39488098430ceff8519841175bb5056a1d496a0af6dbbfb52e9a03c4d100d47d329ba70d78dcd210dccd8add0dc020
+DIST LoopTools-2.8.tar.gz 545508 SHA256 63ca71cccb4bce96a62306a718399ec9aa3c4541c5b31155a20a71af5224a224 SHA512 883f0e793069ae313bd1bda0e207a775ee8a9df0c612fb4ff1173783d0089fb8a4ae0bf498675ae41aab624be42972dd357fa4fef3699ef0aeacfc3b1127ffa0 WHIRLPOOL 1d5d59df9c72e6d35263da4ab286ecaa1d4d0eea51cf5f948dc5ff4e80019df90001cb105d2dcb26460bae73340f069c2628140a277dead370f665154d7d6c97