aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/utf8proc/ChangeLog9
-rw-r--r--dev-libs/utf8proc/Manifest1
-rw-r--r--dev-libs/utf8proc/files/utf8proc-1.1.6-buildflags.patch11
-rw-r--r--dev-libs/utf8proc/files/utf8proc-1.1.6-soname.patch11
-rw-r--r--dev-libs/utf8proc/metadata.xml5
-rw-r--r--dev-libs/utf8proc/utf8proc-1.1.6.ebuild36
6 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/utf8proc/ChangeLog b/dev-libs/utf8proc/ChangeLog
new file mode 100644
index 000000000..f85969704
--- /dev/null
+++ b/dev-libs/utf8proc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/utf8proc
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*utf8proc-1.1.6 (26 Jan 2014)
+
+ 26 Jan 2014; <xhochy@gentoo.org> +files/utf8proc-1.1.6-buildflags.patch,
+ +files/utf8proc-1.1.6-soname.patch, +metadata.xml, +utf8proc-1.1.6.ebuild:
+ Add ebuild for utf8proc
diff --git a/dev-libs/utf8proc/Manifest b/dev-libs/utf8proc/Manifest
new file mode 100644
index 000000000..4459cdb6a
--- /dev/null
+++ b/dev-libs/utf8proc/Manifest
@@ -0,0 +1 @@
+DIST utf8proc-v1.1.6.tar.gz 105825 SHA256 fedc8fa78022eb8f0584fbc85c9f9571bcd7fd510de0ce16955289c42f4199e7 SHA512 3bec2388298c201d9d6992cdd36330f1109d26a37b3411ba633f006f40da9e494ba0565051b763a7d3014e6113cd1e7754e6b95d5cbb2d7b50cee55193f0fdc1 WHIRLPOOL c211419407e80893b66fa7586a8148e9b2e45c89d2d31878658a4ae7f0b1ca72e269cef234ca8b30e27e4bac5a48715520dd546f6605af773d6e165ef76f81b0
diff --git a/dev-libs/utf8proc/files/utf8proc-1.1.6-buildflags.patch b/dev-libs/utf8proc/files/utf8proc-1.1.6-buildflags.patch
new file mode 100644
index 000000000..d9ff3be91
--- /dev/null
+++ b/dev-libs/utf8proc/files/utf8proc-1.1.6-buildflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2014-01-26 18:55:57.400996757 +0000
++++ b/Makefile 2014-01-26 19:00:10.264164095 +0000
+@@ -3,7 +3,7 @@
+
+ # settings
+
+-cflags = -O2 -std=c99 -pedantic -Wall -fpic $(CFLAGS)
++cflags = -std=c99 -pedantic -fpic $(CFLAGS)
+ cc = $(CC) $(cflags)
+
+
diff --git a/dev-libs/utf8proc/files/utf8proc-1.1.6-soname.patch b/dev-libs/utf8proc/files/utf8proc-1.1.6-soname.patch
new file mode 100644
index 000000000..c0463700d
--- /dev/null
+++ b/dev-libs/utf8proc/files/utf8proc-1.1.6-soname.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2014-01-26 19:01:17.723542649 +0000
++++ b/Makefile 2014-01-26 19:02:24.532907919 +0000
+@@ -34,7 +34,7 @@
+ ar rs libutf8proc.a utf8proc.o
+
+ libutf8proc.so: utf8proc.o
+- $(cc) -shared -o libutf8proc.so utf8proc.o
++ $(cc) -Wl,-soname,libutf8proc.so -shared -o libutf8proc.so utf8proc.o
+ chmod a-x libutf8proc.so
+
+ libutf8proc.dylib: utf8proc.o
diff --git a/dev-libs/utf8proc/metadata.xml b/dev-libs/utf8proc/metadata.xml
new file mode 100644
index 000000000..d369d068f
--- /dev/null
+++ b/dev-libs/utf8proc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/dev-libs/utf8proc/utf8proc-1.1.6.ebuild b/dev-libs/utf8proc/utf8proc-1.1.6.ebuild
new file mode 100644
index 000000000..81df46089
--- /dev/null
+++ b/dev-libs/utf8proc/utf8proc-1.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="library for processing UTF-8 encoded Unicode strings"
+HOMEPAGE="http://www.public-software-group.org/utf8proc"
+SRC_URI="http://www.public-software-group.org/pub/projects/${PN}/v${PV}/utf8proc-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-soname.patch \
+ "${FILESDIR}"/${P}-buildflags.patch
+}
+
+src_compile() {
+ emake libutf8proc.so
+ use static-libs & emake libutf8proc.a
+}
+
+src_install() {
+ doheader utf8proc.h
+ dolib.so libutf8proc.so
+ use static-libs && dolib.a libutf8proc.a
+}