aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/scipy/ChangeLog17
-rw-r--r--sci-libs/scipy/Manifest4
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.4.41
-rw-r--r--sci-libs/scipy/metadata.xml18
-rw-r--r--sci-libs/scipy/scipy-0.4.4.ebuild39
5 files changed, 79 insertions, 0 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
new file mode 100644
index 000000000..7c3b0fd11
--- /dev/null
+++ b/sci-libs/scipy/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for sci-libs/scipy
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*scipy-0.4.4 (07 Feb 2006)
+
+ 07 Feb 2006; Sebastien Fabbro <seb@ist.utl.pt>
+ +metadata.xml, +scipy-0.4.4.ebuild:
+ Version bump and slight modifs. Closes bug #119469.
+ Thanks to Alok Singhal <alok_singhal@yahoo.com> and others.
+
+*scipy-0.3.2 (22 Aug 2005)
+
+ 22 Aug 2005; Peter Bienstman <pbienst@gentoo.org> +files/system_info.diff,
+ +metadata.xml, +scipy-0.3.2.ebuild:
+ Initial import. Closes 24593. Thanks to D. Grant, D. Dale and others.
+
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
new file mode 100644
index 000000000..c9f3401b5
--- /dev/null
+++ b/sci-libs/scipy/Manifest
@@ -0,0 +1,4 @@
+MD5 905b6ba15324c6c0733a99ced6995e40 ChangeLog 563
+MD5 a949de96fef5b6758302142a51404cce files/digest-scipy-0.4.4 64
+MD5 51dd57e78f009510e5b3a8384723e22d metadata.xml 686
+MD5 6ffafad4b3f6efc0f2a3976b1cbebe9a scipy-0.4.4.ebuild 843
diff --git a/sci-libs/scipy/files/digest-scipy-0.4.4 b/sci-libs/scipy/files/digest-scipy-0.4.4
new file mode 100644
index 000000000..72a88a608
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.4.4
@@ -0,0 +1 @@
+MD5 b4e40265fc9d37fbaee809fff6c84469 scipy-0.4.4.tar.gz 2192200
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
new file mode 100644
index 000000000..af51deb43
--- /dev/null
+++ b/sci-libs/scipy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+ <maintainer>
+ <email>seb@ist.utl.pt</email>
+ <name>Sebastien Fabbro</name>
+ </maintainer>
+ <longdescription lang="en">
+ SciPy is an Open Source library of scientific tools for Python. It
+ gathers a variety of high level science and engineering modules
+ together as a single package. SciPy provides modules for
+ statistics, optimization, integration, linear algebra, Fourier
+ transforms, signal and image processing, genetic algorithms, ODE
+ solvers, special functions, and more.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/sci-libs/scipy/scipy-0.4.4.ebuild b/sci-libs/scipy/scipy-0.4.4.ebuild
new file mode 100644
index 000000000..ca499a542
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw"
+KEYWORDS="~x86"
+#keyworded to x86 only because of numpy
+
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numpy-0.9.2
+ virtual/blas
+ virtual/lapack
+ fftw? ( =sci-libs/fftw-2.1* )"
+
+# install doc claims fftw-2 is faster for complex ffts.
+# wxwindows seems to have disapeared.
+# f2py seems to be in numpy.
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3"
+
+src_test() {
+ einfo "Testing installation ..."
+ python -c "import scipy; scipy.test(level=1)" || \
+ die "Unit tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc `ls *.txt`
+}