aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/intel-common/Manifest2
-rw-r--r--dev-libs/intel-common/intel-common-16.0.1.150.ebuild137
-rw-r--r--dev-libs/intel-common/intel-common-16.0.2.181.ebuild150
-rw-r--r--dev-libs/intel-common/metadata.xml3
4 files changed, 154 insertions, 138 deletions
diff --git a/dev-libs/intel-common/Manifest b/dev-libs/intel-common/Manifest
index bc7e67674..07dbffc17 100644
--- a/dev-libs/intel-common/Manifest
+++ b/dev-libs/intel-common/Manifest
@@ -1 +1 @@
-DIST parallel_studio_xe_2016_update1.tgz 4126310292 SHA256 f5a3ab9fb581e19bf1bd966f7d40a11905e002a2bfae1c4a2140544288ca3e48 SHA512 5d6b2a853c6fd142d90d155e6e5997d13d1521c393a78dd1649404e90f2d1f3764a1c5efa0eeb0eedeae7e32bd059852b5b887aa3fafc71880ef3ad1d6774be9 WHIRLPOOL 8a2b84744057785968a1160d60ba9a79beeff323bafb0297bcd8fb36d05f22e9de0214dcc26058e638eb9fd136bf4e0cb04345b49e87a558e7167e651af68c16
+DIST parallel_studio_xe_2016_update2.tgz 4187748625 SHA256 280bf39c75d7f52f206759ca4d8b6334ab92d5970957b90f5aa286bb0aa8d65e SHA512 e1d208116ad37752a4fb03cc6aa60d380f70668092280c6de5005895f94d2498501e24d1c06ab3a471ad14fb58acb5b5eb10d2fc6db10e3341f52a6621dd13e4 WHIRLPOOL 81c74eb2f7c2fd841bbee50906cce617f57e05dbf1677861cdfbf43e2cfcc509fa8c04632f31e9b51cb1b5fb5b286b5a079d95bb212f04fc3e1b57e089870a5a
diff --git a/dev-libs/intel-common/intel-common-16.0.1.150.ebuild b/dev-libs/intel-common/intel-common-16.0.1.150.ebuild
deleted file mode 100644
index 89a2e0991..000000000
--- a/dev-libs/intel-common/intel-common-16.0.1.150.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-INTEL_DPN=parallel_studio_xe
-INTEL_DID=8365
-INTEL_DPV=2016_update1
-INTEL_SUBDIR=compilers_and_libraries
-INTEL_SINGLE_ARCH=false
-
-inherit intel-sdp-r1
-
-DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
-HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
-
-IUSE="+compiler doc examples mpi openmp linguas_ja"
-KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-CHECKREQS_DISK_BUILD=375M
-
-INTEL_BIN_RPMS=()
-INTEL_DAT_RPMS=(
- "ccompxe-2016.1-056.noarch.rpm"
- "comp-l-all-common"
- "comp-l-all-vars"
- "comp-l-ps-common"
- "comp-ps-ss-doc-16.0.1-150.noarch.rpm")
-INTEL_X86_RPMS=(
- "comp-l-all-32"
- "comp-l-ps-ss-wrapper")
-INTEL_AMD64_RPMS=()
-
-pkg_setup() {
- if use doc; then
- INTEL_DAT_RPMS+=(
- "ccompxe-doc-2016.1-056.noarch.rpm")
-
- if use linguas_ja; then
- INTEL_DAT_RPMS+=(
- "comp-ps-doc-jp-16.0.1-150.noarch.rpm")
- fi
- fi
-
- if use examples; then
- INTEL_DAT_RPMS+=(
- "ccomp-doc-2016.1-056.noarch.rpm")
- fi
-
- if use mpi; then
- INTEL_X86_RPMS+=(
- "mpirt-l-ps-150-16.0.1-150.i486.rpm")
- INTEL_AMD64_RPMS+=(
- "mpi-psxe-056-5.1.2-056.x86_64.rpm"
- "mpi-rt-core-150-5.1.2-150.x86_64.rpm"
- "mpi-rt-core-150-5.1.2-150.x86_64.rpm"
- "mpi-rt-mic-150-5.1.2-150.x86_64.rpm"
- "mpi-sdk-core-150-5.1.2-150.x86_64.rpm"
- "mpi-sdk-mic-150-5.1.2-150.x86_64.rpm")
-
- if use doc; then
- INTEL_AMD64_RPMS+=(
- "mpi-doc-5.1.2-150.x86_64.rpm")
- fi
- fi
-
- if use openmp; then
- INTEL_BIN_RPMS+=(
- "openmp-l-all"
- "openmp-l-ps")
- INTEL_AMD64_RPMS+=(
- "openmp-l-ps-ss"
- "openmp-l-ps-mic")
-
- if use compiler; then
- INTEL_BIN_RPMS+=(
- "openmp-l-all-devel")
- INTEL_AMD64_RPMS+=(
- "openmp-l-ps-devel"
- "openmp-l-ps-ss-devel"
- "openmp-l-ps-mic-devel")
-
- if use linguas_ja; then
- INTEL_AMD64_RPMS+=(
- "openmp-l-ps-devel-jp"
- "openmp-l-ps-mic-devel-jp")
- fi
- fi
-
- if use linguas_ja; then
- INTEL_X86_RPMS+=(
- "openmp-l-ps-jp")
- fi
- fi
-
- if use compiler; then
- INTEL_BIN_RPMS+=(
- "comp-l-all-devel"
- "comp-l-ps-ss-devel")
- INTEL_AMD64_RPMS+=(
- "comp-l-ps-devel")
- fi
- intel-sdp-r1_pkg_setup
-}
-
-src_install() {
- intel-sdp-r1_src_install
- local path rootpath ldpath arch fenv=35intelsdp
- cat > ${fenv} <<-EOF
- NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
- INTEL_LICENSE_FILE="${EPREFIX}/opt/intel/license:${INTEL_SDP_EDIR}/licenses:"
- EOF
- for arch in ${INTEL_ARCH}; do
- path=${path}:${INTEL_SDP_EDIR}/linux/bin/${arch}
- rootpath=${rootpath}:${INTEL_SDP_EDIR}/linux/bin/${arch}
- ldpath=${ldpath}:${INTEL_SDP_EDIR}/linux/compiler/lib/${arch}
- done
- if use mpi && use amd64; then
- path=${path}:${INTEL_SDP_EDIR}/linux/mpi/intel64/bin/
- rootpath=${rootpath}:${INTEL_SDP_EDIR}/linux/mpi/intel64/bin/
- ldpath=${ldpath}:${INTEL_SDP_EDIR}/linux/mpi/intel64/lib/
- fi
- cat >> ${fenv} <<-EOF
- PATH=${path#:}
- ROOTPATH=${rootpath#:}
- LDPATH=${ldpath#:}
- EOF
-
- doenvd ${fenv}
-
- cat >> "${T}"/40-${PN} <<- EOF
- SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
- EOF
- insinto /etc/revdep-rebuild/
- doins "${T}"/40-${PN}
-}
diff --git a/dev-libs/intel-common/intel-common-16.0.2.181.ebuild b/dev-libs/intel-common/intel-common-16.0.2.181.ebuild
new file mode 100644
index 000000000..82a142488
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-16.0.2.181.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+INTEL_DIST_SKU=8676
+INTEL_DIST_PV=2016_update2
+
+inherit intel-sdp-r1
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler doc examples mic mpi openmp linguas_ja"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="mic? ( openmp )"
+
+CHECKREQS_DISK_BUILD=750M
+
+INTEL_DIST_BIN_RPMS=()
+INTEL_DIST_DAT_RPMS=(
+ "ccompxe-2016.2-062.noarch.rpm"
+ "comp-l-all-common"
+ "comp-l-all-vars"
+ "comp-l-ps-common"
+ "comp-ps-ss-doc-16.0.2-181.noarch.rpm")
+INTEL_DIST_X86_RPMS=(
+ "comp-l-all-32"
+ "comp-l-ps-ss-wrapper")
+INTEL_DIST_AMD64_RPMS=()
+
+pkg_setup() {
+ if use doc; then
+ INTEL_DIST_DAT_RPMS+=(
+ "ccompxe-doc-2016.2-062.noarch.rpm")
+
+ if use linguas_ja; then
+ INTEL_DIST_DAT_RPMS+=(
+ "comp-ps-doc-jp-16.0.2-181.noarch.rpm")
+ fi
+ fi
+
+ if use examples; then
+ INTEL_DIST_DAT_RPMS+=(
+ "ccomp-doc-2016.2-062.noarch.rpm")
+ fi
+
+ if use mpi; then
+ INTEL_DIST_X86_RPMS+=(
+ "mpirt-l-ps-181-16.0.2-181.i486.rpm")
+ INTEL_DIST_AMD64_RPMS+=(
+ "mpi-psxe-062-5.1.3-062.x86_64.rpm"
+ "mpi-rt-core-181-5.1.3-181.x86_64.rpm"
+ "mpi-sdk-core-181-5.1.3-181.x86_64.rpm"
+ )
+
+ if use mic; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "mpi-rt-mic-181-5.1.3-181.x86_64.rpm"
+ "mpi-sdk-mic-181-5.1.3-181.x86_64.rpm")
+ fi
+
+ if use doc; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "mpi-doc-5.1.3-181.x86_64.rpm")
+ fi
+ fi
+
+ if use openmp; then
+ INTEL_DIST_BIN_RPMS+=(
+ "openmp-l-all"
+ "openmp-l-ps")
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-ss")
+
+ if use mic; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-mic")
+ fi
+
+ if use compiler; then
+ INTEL_DIST_BIN_RPMS+=(
+ "openmp-l-all-devel")
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-devel"
+ "openmp-l-ps-ss-devel")
+
+ if use linguas_ja; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-devel-jp")
+
+ if use mic; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-mic-devel-jp")
+ fi
+ fi
+
+ if use mic; then
+ INTEL_DIST_AMD64_RPMS+=(
+ "openmp-l-ps-mic-devel")
+ fi
+ fi
+
+ if use linguas_ja; then
+ INTEL_DIST_X86_RPMS+=(
+ "openmp-l-ps-jp")
+ fi
+ fi
+
+ if use compiler; then
+ INTEL_DIST_BIN_RPMS+=(
+ "comp-l-all-devel"
+ "comp-l-ps-ss-devel")
+ INTEL_DIST_AMD64_RPMS+=(
+ "comp-l-ps-devel")
+ fi
+}
+
+src_install() {
+ intel-sdp-r1_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=$(isdp_get-sdp-edir)/linux/compiler/lib/$(isdp_get-native-abi-arch)/locale/en_US/%N
+ INTEL_LICENSE_FILE=${EPREFIX%/}/opt/intel/licenses:$(isdp_get-sdp-edir)/licenses
+ EOF
+ for arch in $(isdp_get-sdp-installed-arches); do
+ path="${path}:$(isdp_get-sdp-edir)/linux/bin/${arch}"
+ rootpath="${rootpath}:$(isdp_get-sdp-edir)/linux/bin/${arch}"
+ ldpath="${ldpath}:$(isdp_get-sdp-edir)/linux/compiler/lib/${arch}"
+ done
+ if use mpi && use amd64; then
+ path="${path}:$(isdp_get-sdp-edir)/linux/mpi/intel64/bin/"
+ rootpath="${rootpath}:$(isdp_get-sdp-edir)/linux/mpi/intel64/bin/"
+ ldpath="${ldpath}:$(isdp_get-sdp-edir)/linux/mpi/intel64/lib/"
+ fi
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK=$(isdp_get-sdp-edir)
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}
diff --git a/dev-libs/intel-common/metadata.xml b/dev-libs/intel-common/metadata.xml
index 7e7298dac..b4d319f36 100644
--- a/dev-libs/intel-common/metadata.xml
+++ b/dev-libs/intel-common/metadata.xml
@@ -12,4 +12,7 @@
<use>
<flag name="compiler">Install the libraries needed for the icc and ifort compilers</flag>
</use>
+ <use>
+ <flag name="mic">Install the libraries needed for supporting Intel Many Integrated Core (Xeon Phi)</flag>
+ </use>
</pkgmetadata>