aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/glbinding/Manifest2
-rw-r--r--media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch19
-rw-r--r--media-libs/glbinding/files/glbinding-3.1.0_p1-CMakeLists.patch41
-rw-r--r--media-libs/glbinding/files/glbinding-3.1.0_p1-source_CMakeLists.patch12
-rw-r--r--media-libs/glbinding/glbinding-2.1.1.ebuild36
-rw-r--r--media-libs/glbinding/glbinding-3.1.0_p1.ebuild45
-rw-r--r--media-libs/glbinding/metadata.xml26
7 files changed, 114 insertions, 67 deletions
diff --git a/media-libs/glbinding/Manifest b/media-libs/glbinding/Manifest
index 03c0fb0c8..122510b11 100644
--- a/media-libs/glbinding/Manifest
+++ b/media-libs/glbinding/Manifest
@@ -1 +1 @@
-DIST glbinding-2.1.1.tar.gz 3147406 SHA256 253671f2b730a6efa55de92a704938bb0f1761d151f3f8e87c043c51d46ea1e4 SHA512 3d4035294b1383aa71d693f34691bc5e865267e73aa21010f418126b28e4b7850a28a03d8bf3af23bb566f2ca1b53d74ce4a4ee0be962c7df6a3256eb54bb60e WHIRLPOOL 7a5f6bd10611a7c0e7a768a53a0876a3445cd0c14d833824b7b91bb9a1900ef56f5311cc009ba0821fdda5ed0166b6a7fd47bfeba0a40206ad6eaea02af92878
+DIST glbinding-3.1.0_p1.tar.gz 2803219 BLAKE2B 5886fcde037ae5aede3d3a1661321c175b3b54fc2ba0cd4062f04f83c45f8a74a8fae051d2fab5a099b006270ef888907df85b8a455f538c8390803891f92dc7 SHA512 d062412e3455c03ecf7f927f6425786bc04add3ab934b0fdab7d9603ec61d4b5021c68418849885cd11f64f6567a29f933ece5f80efa6790f660a4e58d0d33a1
diff --git a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
deleted file mode 100644
index 8c4b50577..000000000
--- a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -159,16 +159,8 @@ add_subdirectory(deploy)
- # Deployment (global project files)
- #
-
--# Install version file
--install(FILES "${PROJECT_BINARY_DIR}/VERSION" DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
--
- # Install cmake find script for the project
- install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_ROOT} COMPONENT dev)
-
--# Install the project meta files
--install(FILES AUTHORS DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
--install(FILES LICENSE DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
--install(FILES README.md DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
--
- # Install runtime data
- install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${INSTALL_DATA} COMPONENT examples_data)
diff --git a/media-libs/glbinding/files/glbinding-3.1.0_p1-CMakeLists.patch b/media-libs/glbinding/files/glbinding-3.1.0_p1-CMakeLists.patch
new file mode 100644
index 000000000..7486939e7
--- /dev/null
+++ b/media-libs/glbinding/files/glbinding-3.1.0_p1-CMakeLists.patch
@@ -0,0 +1,41 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 45f9981..2c71349 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -143,8 +143,8 @@ if(UNIX AND SYSTEM_DIR_INSTALL)
+ set(INSTALL_EXAMPLES "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_DATA "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_BIN "bin") # /usr/[local]/bin
+- set(INSTALL_SHARED "lib") # /usr/[local]/lib
+- set(INSTALL_LIB "lib") # /usr/[local]/lib
++ set(INSTALL_SHARED "${CMAKE_INSTALL_LIBDIR}") # /usr/[local]/lib
++ set(INSTALL_LIB "${CMAKE_INSTALL_LIBDIR}") # /usr/[local]/lib
+ set(INSTALL_INCLUDE "include") # /usr/[local]/include
+ set(INSTALL_DOC "share/doc/${project}") # /usr/[local]/share/doc/<project>
+ set(INSTALL_SHORTCUTS "share/applications") # /usr/[local]/share/applications
+@@ -157,8 +157,8 @@ else()
+ set(INSTALL_EXAMPLES ".") # ./
+ set(INSTALL_DATA ".") # ./
+ set(INSTALL_BIN ".") # ./
+- set(INSTALL_SHARED "lib") # ./lib
+- set(INSTALL_LIB "lib") # ./lib
++ set(INSTALL_SHARED "${CMAKE_INSTALL_LIBDIR}") # ./lib
++ set(INSTALL_LIB "${CMAKE_INSTALL_LIBDIR}") # ./lib
+ set(INSTALL_INCLUDE "include") # ./include
+ set(INSTALL_DOC "doc") # ./doc
+ set(INSTALL_SHORTCUTS "misc") # ./misc
+@@ -210,3 +210,14 @@ install(FILES README.md DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+ if (TARGET cubescape OR TARGET cubescape-log OR TARGET cubescape-qt)
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${INSTALL_DATA} COMPONENT examples_data)
+ endif()
++
++MESSAGE(STATUS "<<< Gentoo configuration >>>
++Build type ${CMAKE_BUILD_TYPE}
++Install path ${CMAKE_INSTALL_PREFIX}
++Compiler flags:
++C ${CMAKE_C_FLAGS}
++C++ ${CMAKE_CXX_FLAGS}
++Linker flags:
++Executable ${CMAKE_EXE_LINKER_FLAGS}
++Module ${CMAKE_MODULE_LINKER_FLAGS}
++Shared ${CMAKE_SHARED_LINKER_FLAGS}\n")
diff --git a/media-libs/glbinding/files/glbinding-3.1.0_p1-source_CMakeLists.patch b/media-libs/glbinding/files/glbinding-3.1.0_p1-source_CMakeLists.patch
new file mode 100644
index 000000000..88d11dc3a
--- /dev/null
+++ b/media-libs/glbinding/files/glbinding-3.1.0_p1-source_CMakeLists.patch
@@ -0,0 +1,12 @@
+diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
+index 757217b..19da804 100644
+--- a/source/CMakeLists.txt
++++ b/source/CMakeLists.txt
+@@ -13,7 +13,6 @@ configure_file(version.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/${META_PROJECT_N
+
+ # 3rdParties
+ set(IDE_FOLDER "3rdparty")
+-add_subdirectory("3rdparty/KHR")
+
+ # Libraries
+ set(IDE_FOLDER "")
diff --git a/media-libs/glbinding/glbinding-2.1.1.ebuild b/media-libs/glbinding/glbinding-2.1.1.ebuild
deleted file mode 100644
index 408093fb5..000000000
--- a/media-libs/glbinding/glbinding-2.1.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Cross-platform C++ binding for the OpenGL API"
-HOMEPAGE="https://github.com/cginternals/glbinding"
-SRC_URI="https://github.com/cginternals/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- >=media-libs/glfw-3.1.1
- "
-DEPEND="${RDEPEND}
- >=dev-util/cmake-3.2.2
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-CMakeLists.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DOPTION_BUILD_TESTS=OFF
- -DOPTION_BUILD_GPU_TESTS=OFF
- -DOPTION_BUILD_DOCS=OFF
- -DOPTION_BUILD_EXAMPLES=OFF
- )
- cmake-utils_src_configure
-}
diff --git a/media-libs/glbinding/glbinding-3.1.0_p1.ebuild b/media-libs/glbinding/glbinding-3.1.0_p1.ebuild
new file mode 100644
index 000000000..9999b537f
--- /dev/null
+++ b/media-libs/glbinding/glbinding-3.1.0_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Cross-platform C++ binding for the OpenGL API"
+HOMEPAGE="https://github.com/cginternals/glbinding"
+COMMIT="55634e35bd8d8bf58cb36f6ed81af0a0f0939973"
+SRC_URI="https://github.com/cginternals/glbinding/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/glfw
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-vcs/git
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-CMakeLists.patch
+ "${FILESDIR}/${P}"-source_CMakeLists.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DOPTION_SELF_CONTAINED=OFF
+ -DOPTION_BUILD_TESTS=OFF
+ -DOPTION_BUILD_DOCS=OFF
+ -DOPTION_BUILD_EXAMPLES=OFF
+ -DOPTION_BUILD_WITH_BOOST_THREAD=OFF
+ -DOPTION_BUILD_CHECK=OFF
+ -DOPTION_BUILD_OWN_KHR_HEADERS=OFF
+ -DOPTION_BUILD_WITH_LTO=OFF
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/glbinding/metadata.xml b/media-libs/glbinding/metadata.xml
index 7e15e92be..706402ab4 100644
--- a/media-libs/glbinding/metadata.xml
+++ b/media-libs/glbinding/metadata.xml
@@ -5,22 +5,26 @@
<email>marbre@linux.sungazer.de</email>
<name>Marius Brehler</name>
</maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
-glbinding leverages modern C++11 features like enum classes,
-lambdas, and variadic templates, instead of relying on macros; all
-OpenGL symbols are real functions and variables. It provides
-type-safe parameters, per feature API header, lazy function
-resolution, multi-context and multi-thread support, global and local
-function callbacks, meta information about the generated OpenGL
-binding and the OpenGL runtime, as well as tools and examples for
-quick-starting your projects. Based on the OpenGL API specification
-(gl.xml) glbinding is generated using python scripts and templates
-that can be easily adapted to fit custom needs.
-</longdescription>
+ glbinding leverages modern C++11 features like enum classes,
+ lambdas, and variadic templates, instead of relying on macros; all
+ OpenGL symbols are real functions and variables. It provides
+ type-safe parameters, per feature API header, lazy function
+ resolution, multi-context and multi-thread support, global and local
+ function callbacks, meta information about the generated OpenGL
+ binding and the OpenGL runtime, as well as tools and examples for
+ quick-starting your projects. Based on the OpenGL API specification
+ (gl.xml) glbinding is generated using python scripts and templates
+ that can be easily adapted to fit custom needs.
+ </longdescription>
<upstream>
<remote-id type="github">cginternals/glbinding</remote-id>
</upstream>