aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/nwchem/ChangeLog7
-rw-r--r--sci-chemistry/nwchem/nwchem-6.5_p26243-r1.ebuild (renamed from sci-chemistry/nwchem/nwchem-6.5_p26243.ebuild)37
2 files changed, 30 insertions, 14 deletions
diff --git a/sci-chemistry/nwchem/ChangeLog b/sci-chemistry/nwchem/ChangeLog
index a9461ce25..df19a2136 100644
--- a/sci-chemistry/nwchem/ChangeLog
+++ b/sci-chemistry/nwchem/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*nwchem-6.5_p26243-r1 (12 Nov 2014)
+
+ 12 Nov 2014; Honza Macháček <Hloupy.Honza@centrum.cz>
+ -nwchem-6.5_p26243.ebuild, +nwchem-6.5_p26243-r1.ebuild:
+ Handling of 32-bit versus 64-bit integers in
+ sci-chemistry/nwchem-6.5_p26243-r1 corrected.
+
*nwchem-6.5_p26243 (11 Nov 2014)
11 Nov 2014; Honza Macháček <Hloupy.Honza@centrum.cz>
diff --git a/sci-chemistry/nwchem/nwchem-6.5_p26243.ebuild b/sci-chemistry/nwchem/nwchem-6.5_p26243-r1.ebuild
index 80132339b..3926d499b 100644
--- a/sci-chemistry/nwchem/nwchem-6.5_p26243.ebuild
+++ b/sci-chemistry/nwchem/nwchem-6.5_p26243-r1.ebuild
@@ -30,7 +30,9 @@ IUSE="blas cuda infiniband lapack mpi doc examples int64 nwchem-tests openmp mrc
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
infiniband? ( mpi )
- scalapack? ( !int64 )"
+ scalapack? ( !int64 )
+ lapack? ( blas )
+ scalapack? ( blas )"
RDEPEND="
sys-fs/sysfsutils
@@ -182,19 +184,9 @@ src_compile() {
export CCSDTQ="TRUE"
export CCSDTLR="TRUE"
unset BLASOPT
- use blas && BLASOPT="$(pkg-config --libs blas)"
- use lapack && BLASOPT+="$(pkg-config --libs lapack)"
- use scalapack && BLASOPT+="$(pkg-config --libs scalapack)"
- export BLASOPT
- if use int64; then
- BLAS_SIZE=8
- LAPACK_SIZE=8
- SCALAPACK_SIZE=8
- else
- BLAS_SIZE=4
- LAPACK_SIZE=4
- SCALAPACK_SIZE=4
- fi
+ use blas && export BLASOPT="$(pkg-config --libs blas)"
+ use lapack && export BLASOPT+="$(pkg-config --libs lapack)"
+ use scalapack && export BLASOPT+="$(pkg-config --libs scalapack)"
if use cuda; then
export TCE_CUDA=Y
export CUDA_PATH=/opt/cuda
@@ -206,6 +198,23 @@ src_compile() {
export LARGE_FILES="TRUE"
cd src
+ if use int64; then
+ export BLAS_SIZE=8
+ export LAPACK_SIZE=8
+ export SCALAPACK_SIZE=8
+ else
+ export BLAS_SIZE=4
+ export LAPACK_SIZE=4
+ export SCALAPACK_SIZE=4
+ export USE_64TO32=y
+ emake \
+ DIAG=PAR \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ NWCHEM_TOP="${S}" \
+ 64_to_32
+ fi
emake \
DIAG=PAR \
FC=$(tc-getFC) \