aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/uproot/Manifest1
-rw-r--r--sci-physics/uproot/uproot-3.12.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sci-physics/uproot/Manifest b/sci-physics/uproot/Manifest
index 989c030dd..59b039397 100644
--- a/sci-physics/uproot/Manifest
+++ b/sci-physics/uproot/Manifest
@@ -1 +1,2 @@
DIST uproot-3.11.0.tar.gz 32460790 BLAKE2B 5ac68713ba8cbc36df859992c6a3941d221fc5aa083adc604a2b665e848c3286b6cb651ea5a24361d4b8e64cd7f6a8e64f5e1cd8488f8839ec4ef59aa82b3358 SHA512 4be9194ea88404756afdfcbc90019cce045951653cfabfb449cf8fde65678cac979e651b8651a9b2c4900607c8d5c28a5b30cf0ca7e71737441422ccd4be4ae3
+DIST uproot-3.12.0.tar.gz 34502809 BLAKE2B 4f124223220e59188b5f34e6d032a1e2cbe14e52e8b29aab9b117646e770658ee54031cab2d0516f66040cf3cdd6d06f23967c0db7721b1c716add1349c2a34f SHA512 9711cde750a6a604d6ea0a06b4984f936ea1bfa7ba119feb52621ba348e08650a260dee24c3d8b6d51727891b5f5d84ba530dfe6a7ca74f0c65ce9f5092db272
diff --git a/sci-physics/uproot/uproot-3.12.0.ebuild b/sci-physics/uproot/uproot-3.12.0.ebuild
new file mode 100644
index 000000000..d6cf2148f
--- /dev/null
+++ b/sci-physics/uproot/uproot-3.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulate arrays of complex data structures as easily as Numpy."
+HOMEPAGE="https://github.com/scikit-hep/${PN}"
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/awkward-array[${PYTHON_USEDEP}]
+ sci-physics/uproot-methods[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]"