aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/dnaio/Manifest1
-rw-r--r--dev-python/dnaio/dnaio-1.2.1.ebuild27
-rw-r--r--dev-python/dnaio/metadata.xml12
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/dnaio/Manifest b/dev-python/dnaio/Manifest
new file mode 100644
index 000000000..6f28e78d7
--- /dev/null
+++ b/dev-python/dnaio/Manifest
@@ -0,0 +1 @@
+DIST dnaio-1.2.1.tar.gz 59274 BLAKE2B 8d41e3fa0319a17ef5239311b7b4a384801fe82a5f079c6e1102cd19fb903c07c3933b270242042f74f1c98b0d3577726f13e9f02eacfb66d558ab20de295c3b SHA512 99e175e146082b7b2e09a9d41a421453b3f3e7cbe8ea8e023bd2fc7dc189585e8f91c96b15afc4cee43c0a23e18fbb54624790510cc5b3d375726c0ea80200cc
diff --git a/dev-python/dnaio/dnaio-1.2.1.ebuild b/dev-python/dnaio/dnaio-1.2.1.ebuild
new file mode 100644
index 000000000..63e3d4201
--- /dev/null
+++ b/dev-python/dnaio/dnaio-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="dnaio processes FASTQ, FASTA and uBAM files"
+HOMEPAGE="https://github.com/marcelm/dnaio/"
+SRC_URI="$(pypi_sdist_url "${PN^}" "${PV}")"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+DEPEND="
+ dev-python/xopen[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ test? ( dev-python/pytest )
+"
+distutils_enable_tests pytest
diff --git a/dev-python/dnaio/metadata.xml b/dev-python/dnaio/metadata.xml
new file mode 100644
index 000000000..7151605a5
--- /dev/null
+++ b/dev-python/dnaio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">DNAio</remote-id>
+ <remote-id type="github">marcelm/dnaio</remote-id>
+ </upstream>
+</pkgmetadata>