aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/Lmod/Lmod-8.4.10.ebuild104
-rw-r--r--sys-cluster/Lmod/Manifest1
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-cluster/Lmod/Lmod-8.4.10.ebuild b/sys-cluster/Lmod/Lmod-8.4.10.ebuild
new file mode 100644
index 000000000..925e1d5e9
--- /dev/null
+++ b/sys-cluster/Lmod/Lmod-8.4.10.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Environment Module System based on Lua"
+HOMEPAGE="https://lmod.readthedocs.io/en/latest"
+SRC_URI="https://github.com/TACC/Lmod/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="auto-swap cache dotfiles duplicate +extend italic module-cmd nocase redirect test"
+RESTRICT="!test? ( test )"
+
+RDEPEND+="
+ app-shells/tcsh
+ || (
+ app-shells/loksh
+ app-shells/mksh
+ app-shells/ksh
+ )
+ app-shells/zsh
+ dev-lang/tcl
+ dev-lua/luafilesystem
+ dev-lua/luajson
+ dev-lua/luaposix
+ dev-lua/lua-term
+"
+DEPEND+="${RDEPEND}"
+BDEPEND+="
+ test? (
+ dev-util/Hermes
+ )
+"
+
+pkg_setup() {
+ elog "There is a lot of options for this package,"
+ elog "especially for run time behaviour."
+ elog "You can set them using EXTRA_ECONF variable."
+ elog "To see full list of options visit:"
+ elog "https://lmod.readthedocs.io/en/latest/090_configuring_lmod.html"
+}
+
+src_prepare() {
+ default
+
+ rm -r "${S}"/rt/{colorize,end2end,help,ifur,settarg} || die
+}
+
+src_configure() {
+ # set environment variables to pass to Lmod configuration
+ local -x CACHE_LIFETIME="${CACHE_LIFETIME:-86400}"
+ local -x SHORT_TIME="${SHORT_TIME:-2}"
+ local -x SYSTEM_TOUCH="${SYSTEM_TOUCH:-/var/lmod/latest_system_update.time}"
+ local -x SITE_NAME="${SITE_NAME:-Gentoo}"
+ local -x SYSHOST="${SYSHOST:-Gentoo}"
+
+ local myconf=(
+ --with-tcl
+ --with-fastTCLInterp
+ --with-colorize
+ --prefix=/opt
+ --with-ancient="${CACHE_LIFETIME}"
+ --with-supportKsh
+ --with-updateSystemFn="${SYSTEM_TOUCH}"
+ --with-siteName="${SITE_NAME}"
+ --with-syshost="${SYSHOST}"
+ --with-shortTime="${SHORT_TIME}"
+ --without-useBuiltinPkgs
+ $(use_with duplicate duplicatePaths)
+ $(use_with nocase caseIndependentSorting)
+ $(use_with italic hiddenItalic)
+ $(use_with auto-swap autoSwap)
+ $(use_with module-cmd exportedModuleCmd)
+ $(use_with redirect)
+ $(use_with dotfiles useDotFiles)
+ $(use_with cache cachedLoads)
+ $(use_with extend extendedDefault)
+ )
+
+ econf ${myconf[@]} ${EXTRA_ECONF[@]}
+}
+
+src_test() {
+ local -x PATH="/opt/hermes/bin:${PATH}"
+ tm -vvv || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/lmod
+}
+
+pkg_postinst() {
+ elog "Lmod has been installed at /opt/lmod/{lmod -> ${PV}}"
+ elog "To activate Lmod, you need to source the profile"
+ elog "script provided"
+ elog " $ . /opt/lmod/lmod/init/profile"
+ elog "This will provide you with the 'module' command"
+ elog " $ man module"
+}
diff --git a/sys-cluster/Lmod/Manifest b/sys-cluster/Lmod/Manifest
index 77dc2fa96..4a539659b 100644
--- a/sys-cluster/Lmod/Manifest
+++ b/sys-cluster/Lmod/Manifest
@@ -1,2 +1,3 @@
+DIST Lmod-8.4.10.tar.gz 19932188 BLAKE2B 56378c531b5b3f839032047363b4f016c90baf8157966e35d2b1faebc925fd95ec65f90cd24811f411d71d4be68223e15fc51ea68d02dd5c8bd8f9a0eb5fd5af SHA512 5ae34fc21cfe188220d678bd1cb81e1c829a0b06f51f4afed7cfef26faf5b0f4f2a49e2d7418733f3eac8e3809a04c672d95d19b132cc08ba643be5851f24bd6
DIST Lmod-8.4.5.tar.gz 19925053 BLAKE2B 9b0f3d9a0e44455b548710adabe53fc43fb7251d7e8852ed63d2e370c65aa89023b605c50ad582317b06d7c88d92330471d5491e6157a9861a823cec9bab348c SHA512 0a4bb191e61d450932d9d282d8d18116c5e66d51a2c93151f39b32a06feb5e0fe33100b568467af9082feed18a04460197e2942b1b0ba0383db05a5874b99b99
DIST Lmod-8.4.9.tar.gz 19931774 BLAKE2B 972f76ec5d22dac664c2a25b212ca368914131b307f1b0d6c6048299ef271f0d05ed40d9cfee9de6f93796703e3c100b0e94e8f7c4e2d80a2fe1d3a88585327a SHA512 b0d24075d3c2d2cbba0fa44a8c6e82179f124af4b8591647d7e807237382b846a3b3dbb8b25a6249d0ae7e6d090b428b478b2846370fda2b029e48158adafe80