aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cadquery/Manifest1
-rw-r--r--dev-python/cadquery/cadquery-2.2_rc20220506.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/cadquery/Manifest b/dev-python/cadquery/Manifest
index ae1e31fa3..380c3e6ae 100644
--- a/dev-python/cadquery/Manifest
+++ b/dev-python/cadquery/Manifest
@@ -1 +1,2 @@
DIST cadquery-2.2_rc20210804.tar.gz 2832275 BLAKE2B b1b25130a9eb73e4913c6e9fc8d1fafd689bc9d216adee6d7fcc6fd80805b9351e87839fae3d6bf7e0a1ccf147e5b4a9afe8f6afc0e01c1b3a287e2671870c8d SHA512 0c5b16da24deba2267b204e5f51f707fffab9a238b27af84a500b8a98aa190be24be75d7bc2d1e282c04aea7116eb404ed4520515d53ae5a64aebafc647aa4a3
+DIST cadquery-2.2_rc20220506.tar.gz 2872821 BLAKE2B a48b4279a6e24166842c3f7c43e0ff3552f22f8821fa203fce30b76110423c375019228b1a458b0020ebfd23a052545ae0d90e3246619a2e53dbe8f411449f3d SHA512 65bd62268f920d1fa170921033c4e4f451e1bdf7e4d1cef457bf34c4466a076de57f40d38ed7fb1d8f207b45447d6763a52880d9d49426372b06fefd536e7c17
diff --git a/dev-python/cadquery/cadquery-2.2_rc20220506.ebuild b/dev-python/cadquery/cadquery-2.2_rc20220506.ebuild
new file mode 100644
index 000000000..26aa07b6d
--- /dev/null
+++ b/dev-python/cadquery/cadquery-2.2_rc20220506.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parametric CAD scripting framework based on OCCT"
+HOMEPAGE="https://cadquery.readthedocs.io"
+
+# The official CadQuery 2.1 tarball requires the obsolete OCCT 7.4.0, but
+# CadQuery 2.2 has yet to be officially released. We instead package a commit
+# known to work as expected with OCCT 7.5.2.
+MY_COMMIT="803a05e78c233fdb537a8604c3f2b56a52179bbe"
+
+#FIXME: Uncomment on bumping to the next stable release.
+# SRC_URI="https://github.com/CadQuery/cadquery/archive/refs/tags/${PV}.tar.gz"
+SRC_URI="https://github.com/CadQuery/cadquery/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Dependencies are intentionally listed in "conda/meta.yml" order. Due to its
+# Anaconda focus, "setup.py" currently fails to list dependencies.
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ >=dev-python/cadquery-ocp-7.5.0[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pyparsing-2.0.0[${PYTHON_USEDEP}]
+ dev-python/ezdxf[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/nptyping[${PYTHON_USEDEP}]
+ sci-libs/nlopt[python,${PYTHON_USEDEP}]
+ dev-python/multimethod[${PYTHON_USEDEP}]
+ dev-python/typish[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+distutils_enable_tests pytest
+
+#FIXME: Uncomment after packaging "dev-python/sphinx-autodoc-typehints".
+# distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-autodoc-typehints