aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/root/ChangeLog5
-rw-r--r--sci-physics/root/files/root-6.00.01-tutorials-path.patch12
-rw-r--r--sci-physics/root/root-6.00.01-r1.ebuild4
-rw-r--r--sci-physics/root/root-9999.ebuild8
4 files changed, 26 insertions, 3 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 9b12ba532..477075328 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -3,6 +3,11 @@
# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.96 2012/03/29 18:21:49 bicatali Exp $
02 Jul 2014; Andrew Savchenko <bircoph@gmail.com> root-6.00.01-r1.ebuild,
+ root-9999.ebuild, files/root-6.00.01-tutorials-path.patch:
+ Do not compress files required for .credits, .demo, .license
+ commands. Fix tutorials patch.
+
+ 02 Jul 2014; Andrew Savchenko <bircoph@gmail.com> root-6.00.01-r1.ebuild,
+files/root-6.00.01-tutorials-path.patch:
Honor --tutdir from .demos CLI command.
Install files for .license and .credits commands to work.
diff --git a/sci-physics/root/files/root-6.00.01-tutorials-path.patch b/sci-physics/root/files/root-6.00.01-tutorials-path.patch
index 2e496a494..cb6861554 100644
--- a/sci-physics/root/files/root-6.00.01-tutorials-path.patch
+++ b/sci-physics/root/files/root-6.00.01-tutorials-path.patch
@@ -10,6 +10,18 @@ index 5950401..e4fbfbf 100644
#define ROOTSRCDIR "@srcdir@"
#define ROOTICONPATH "@iconpath@"
#define EXTRAICONPATH "@extraiconpath@"
+diff --git a/configure b/configure
+index 131df92..2c8ea95 100755
+--- a/configure
++++ b/configure
+@@ -7537,6 +7537,7 @@ sed \
+ -e "s|@prefix@|$prefix|" \
+ -e "s|@srcdir@|$srcdir|" \
+ -e "s|@ttffontdir@|$fontdir|" \
++ -e "s|@tutdir@|$tutdir|" \
+ -e "s|@setresuid@|$setresuid|" \
+ -e "s|@hasmathmore@|$hasmathmore|" \
+ -e "s|@haspthread@|$haspthread|" \
diff --git a/core/base/src/TApplication.cxx b/core/base/src/TApplication.cxx
index 1c1809a..7d7ed37 100644
--- a/core/base/src/TApplication.cxx
diff --git a/sci-physics/root/root-6.00.01-r1.ebuild b/sci-physics/root/root-6.00.01-r1.ebuild
index 74c7af805..d5993c073 100644
--- a/sci-physics/root/root-6.00.01-r1.ebuild
+++ b/sci-physics/root/root-6.00.01-r1.ebuild
@@ -426,9 +426,9 @@ src_install() {
cleanup_install
# do not copress files used by ROOT's CLI (.credit, .demo, .license)
- docompress -x "${DOC_DIR}/{CREDITS,LICENSE,examples/tutorials}"
+ docompress -x "${DOC_DIR}"/{CREDITS,LICENSE,examples/tutorials}
# needed for .license command to work
- dosym "${ED}"/usr/portage/licenses/LGPL-2.1 "${DOC_DIR}/LICENSE"
+ dosym "${ED}"usr/portage/licenses/LGPL-2.1 "${DOC_DIR}/LICENSE"
}
pkg_postinst() {
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 26f1dd15c..9c76fed4f 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -200,7 +200,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-6.00.01-nobyte-compile.patch \
"${FILESDIR}"/${PN}-6.00.01-prop-flags.patch \
"${FILESDIR}"/${PN}-6.00.01-llvm.patch \
- "${FILESDIR}"/${PN}-6.00.01-geocad.patch
+ "${FILESDIR}"/${PN}-6.00.01-geocad.patch \
+ "${FILESDIR}"/${PN}-6.00.01-tutorials-path.patch
# make sure we use system libs and headers
rm montecarlo/eg/inc/cfortran.h README/cfortran.doc || die
@@ -422,6 +423,11 @@ src_install() {
daemon_install
desktop_install
cleanup_install
+
+ # do not copress files used by ROOT's CLI (.credit, .demo, .license)
+ docompress -x "${DOC_DIR}"/{CREDITS,LICENSE,examples/tutorials}
+ # needed for .license command to work
+ dosym "${ED}"usr/portage/licenses/LGPL-2.1 "${DOC_DIR}/LICENSE"
}
pkg_postinst() {