aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/nmrpipe/ChangeLog10
-rw-r--r--sci-chemistry/nmrpipe/files/extract.M37
-rw-r--r--sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09-r1.ebuild (renamed from sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09.ebuild)3
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/nmrpipe/ChangeLog b/sci-chemistry/nmrpipe/ChangeLog
index 5ad1beec3..0e6666223 100644
--- a/sci-chemistry/nmrpipe/ChangeLog
+++ b/sci-chemistry/nmrpipe/ChangeLog
@@ -2,6 +2,16 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 28 Oct 2013; Justin Lecher <jlec@gentoo.org>
+ -nmrpipe-8.1.2013.218.23.09.ebuild, +nmrpipe-8.1.2013.218.23.09-r1.ebuild,
+ +files/extract.M:
+ Add IBS extract.M macro
+
+ 25 Oct 2013; Justin Lecher <jlec@gentoo.org>
+ -nmrpipe-8.1.2013.218.23.09.ebuild, +nmrpipe-8.1.2013.218.23.09-r1.ebuild,
+ +files/extract.M:
+ Add IBS extract.M macro
+
12 Aug 2013; Justin Lecher <jlec@gentoo.org>
-nmrpipe-7.9.2013.021.23.09-r3.ebuild, +nmrpipe-8.1.2013.218.23.09.ebuild,
-files/nmrpipe-7.9.2013.021.23.09-lib.patch,
diff --git a/sci-chemistry/nmrpipe/files/extract.M b/sci-chemistry/nmrpipe/files/extract.M
new file mode 100644
index 000000000..544d2fee3
--- /dev/null
+++ b/sci-chemistry/nmrpipe/files/extract.M
@@ -0,0 +1,37 @@
+if (sliceCode == CODE_ARGS)
+ {
+ ArrayNum = argVal( "an" ); /* Array size of arrayed parameter */
+ SpecNum = argVal( "sn" ); /* Spectrum number to be extracted */
+ printf(" Spectrum %3.0f out of %4.0f\n",SpecNum,ArrayNum);
+ };
+
+if (sliceCode == CODE_INIT)
+ {
+ (void) setParm( fdata, NDSIZE, integer( specnum/ArrayNum ), CUR_YDIM );
+ };
+
+if (sliceCode >1)
+ {
+ exit( 0 );
+ };
+
+if (sliceCode < 0)
+ {
+ exit( 0 );
+ };
+
+
+float fid[2*size*specnum];
+float Single[4*size];
+
+(void) dReadB(inUnit,fid, 2*wordLen*size*specnum ); /* load the whole FID data in the array "fid" */
+
+offset = 4*size*(SpecNum-1);
+
+for( i = 0; i < specnum*size*2; i = i+4*ArrayNum*size)
+{
+ (void) vvCopyOff( Single, fid, 4*size, 0, offset ); /* load in the buffer array "Single" two complex spectra
+ (phase=1,phase=2) from the "fid" array starting from offset*/
+ (void) dWrite( outUnit,Single,wordLen*4*size); /* write "Single in the output */
+ offset += 4*ArrayNum*size;
+}
diff --git a/sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09.ebuild b/sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09-r1.ebuild
index 1a81a38f0..cd253d5d3 100644
--- a/sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09.ebuild
+++ b/sci-chemistry/nmrpipe/nmrpipe-8.1.2013.218.23.09-r1.ebuild
@@ -208,4 +208,7 @@ src_install() {
exeinto ${NMRBASE}/nmrbin.linux9
doexe "${T}"/nmrWish
+
+ insinto ${NMRBASE}/nmrtxt
+ doins "${FILESDIR}"/extract.M
}