aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/librecad/ChangeLog7
-rw-r--r--media-gfx/librecad/librecad-1.0.3.ebuild13
-rw-r--r--media-gfx/librecad/librecad-1.0.4.ebuild15
3 files changed, 19 insertions, 16 deletions
diff --git a/media-gfx/librecad/ChangeLog b/media-gfx/librecad/ChangeLog
index a287d08d4..7b80bf43f 100644
--- a/media-gfx/librecad/ChangeLog
+++ b/media-gfx/librecad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/librecad
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header$
+
+ 15 Jan 2015; Marius Brehler <marbre@linux.sungazer.de>
+ librecad-1.0.3.ebuild, librecad-1.0.4.ebuild:
+ Move to EAPI=5
+
19 Sep 2014; Dongxu Li <dongxuli2011@gmail.com> : librecad-9999.ebuild:
install appdata.xml
diff --git a/media-gfx/librecad/librecad-1.0.3.ebuild b/media-gfx/librecad/librecad-1.0.3.ebuild
index 8a04ca196..fc579a387 100644
--- a/media-gfx/librecad/librecad-1.0.3.ebuild
+++ b/media-gfx/librecad/librecad-1.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
inherit qt4-r2 eutils
@@ -19,8 +19,7 @@ RDEPEND="
dev-qt/qtgui[qt3support]
dev-qt/qthelp:4
dev-qt/qt3support:4
- dev-cpp/muParser
- "
+ dev-cpp/muParser"
DEPEND="${RDEPEND}"
@@ -30,13 +29,13 @@ src_unpack() {
}
src_prepare() {
-sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro"
+ sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro" || die
}
src_install() {
- dobin unix/librecad || die
+ dobin unix/librecad
insinto /usr/share/"${PN}"
- doins -r unix/resources/* || die
+ doins -r unix/resources/*
if use doc ; then
dohtml -r support/doc/*
fi
diff --git a/media-gfx/librecad/librecad-1.0.4.ebuild b/media-gfx/librecad/librecad-1.0.4.ebuild
index 8a04ca196..80889f1ef 100644
--- a/media-gfx/librecad/librecad-1.0.4.ebuild
+++ b/media-gfx/librecad/librecad-1.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit qt4-r2 eutils
+inherit eutils qt4-r2
DESCRIPTION="An generic 2D CAD program"
HOMEPAGE="http://www.librecad.org/"
@@ -19,8 +19,7 @@ RDEPEND="
dev-qt/qtgui[qt3support]
dev-qt/qthelp:4
dev-qt/qt3support:4
- dev-cpp/muParser
- "
+ dev-cpp/muParser"
DEPEND="${RDEPEND}"
@@ -30,13 +29,13 @@ src_unpack() {
}
src_prepare() {
-sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro"
+ sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro" || die
}
src_install() {
- dobin unix/librecad || die
+ dobin unix/librecad
insinto /usr/share/"${PN}"
- doins -r unix/resources/* || die
+ doins -r unix/resources/*
if use doc ; then
dohtml -r support/doc/*
fi