aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/brlcad/brlcad-7.22.0.ebuild2
-rw-r--r--media-gfx/brlcad/brlcad-7.24.0.ebuild2
-rw-r--r--media-gfx/brlcad/brlcad-7.24.2.ebuild2
-rw-r--r--media-gfx/brlcad/brlcad-9999.ebuild2
-rw-r--r--sci-biology/OBO-Edit/OBO-Edit-2.1.0.ebuild35
-rw-r--r--sci-biology/OBO-Edit/OBO-Edit-2.1.1.6.ebuild42
-rw-r--r--sci-biology/OBO-Edit/metadata.xml2
-rw-r--r--sci-biology/apollo/apollo-9999.ebuild2
-rw-r--r--sci-biology/consed/consed-29.ebuild2
-rw-r--r--sci-biology/pileup/pileup-0.6.ebuild4
-rw-r--r--sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild9
-rw-r--r--sci-biology/tablet-bin/tablet-bin-1.14.10.21.ebuild2
-rw-r--r--sci-biology/trf/trf-4.07b.ebuild2
-rw-r--r--sci-libs/med/med-2.3.6.ebuild8
14 files changed, 70 insertions, 46 deletions
diff --git a/media-gfx/brlcad/brlcad-7.22.0.ebuild b/media-gfx/brlcad/brlcad-7.22.0.ebuild
index 98fb81098..da291020e 100644
--- a/media-gfx/brlcad/brlcad-7.22.0.ebuild
+++ b/media-gfx/brlcad/brlcad-7.22.0.ebuild
@@ -105,7 +105,7 @@ src_install() {
dodoc AUTHORS NEWS README HACKING TODO BUGS ChangeLog
echo "PATH=\"${BRLCAD_DIR}/bin\"" > 99brlcad
echo "MANPATH=\"${BRLCAD_DIR}/man\"" >> 99brlcad
- doenvd 99brlcad || die
+ doenvd 99brlcad
newicon misc/macosx/Resources/ReadMe.rtfd/brlcad_logo_tiny.png brlcad.png
make_desktop_entry mged "BRL-CAD" brlcad "Graphics;Engineering"
}
diff --git a/media-gfx/brlcad/brlcad-7.24.0.ebuild b/media-gfx/brlcad/brlcad-7.24.0.ebuild
index 1933ed4c9..d8781b479 100644
--- a/media-gfx/brlcad/brlcad-7.24.0.ebuild
+++ b/media-gfx/brlcad/brlcad-7.24.0.ebuild
@@ -105,7 +105,7 @@ src_install() {
dodoc AUTHORS NEWS README HACKING TODO BUGS ChangeLog
echo "PATH=\"${BRLCAD_DIR}/bin\"" > 99brlcad
echo "MANPATH=\"${BRLCAD_DIR}/man\"" >> 99brlcad
- doenvd 99brlcad || die
+ doenvd 99brlcad
newicon misc/macosx/Resources/ReadMe.rtfd/brlcad_logo_tiny.png brlcad.png
make_desktop_entry mged "BRL-CAD" brlcad "Graphics;Engineering"
}
diff --git a/media-gfx/brlcad/brlcad-7.24.2.ebuild b/media-gfx/brlcad/brlcad-7.24.2.ebuild
index 09399be15..f828e7c8a 100644
--- a/media-gfx/brlcad/brlcad-7.24.2.ebuild
+++ b/media-gfx/brlcad/brlcad-7.24.2.ebuild
@@ -104,7 +104,7 @@ src_install() {
dodoc AUTHORS NEWS README HACKING TODO BUGS ChangeLog
echo "PATH=\"${BRLCAD_DIR}/bin\"" > 99brlcad
echo "MANPATH=\"${BRLCAD_DIR}/man\"" >> 99brlcad
- doenvd 99brlcad || die
+ doenvd 99brlcad
newicon misc/macosx/Resources/ReadMe.rtfd/brlcad_logo_tiny.png brlcad.png
make_desktop_entry mged "BRL-CAD" brlcad "Graphics;Engineering"
}
diff --git a/media-gfx/brlcad/brlcad-9999.ebuild b/media-gfx/brlcad/brlcad-9999.ebuild
index 06de13dea..0ca181ca8 100644
--- a/media-gfx/brlcad/brlcad-9999.ebuild
+++ b/media-gfx/brlcad/brlcad-9999.ebuild
@@ -100,7 +100,7 @@ src_install() {
dodoc AUTHORS NEWS README HACKING TODO BUGS ChangeLog
echo "PATH=\"${BRLCAD_DIR}/bin\"" > 99brlcad
echo "MANPATH=\"${BRLCAD_DIR}/man\"" >> 99brlcad
- doenvd 99brlcad || die
+ doenvd 99brlcad
newicon misc/macosx/Resources/ReadMe.rtfd/brlcad_logo_tiny.png brlcad.png
make_desktop_entry mged "BRL-CAD" brlcad "Graphics;Engineering"
}
diff --git a/sci-biology/OBO-Edit/OBO-Edit-2.1.0.ebuild b/sci-biology/OBO-Edit/OBO-Edit-2.1.0.ebuild
index f5d99485e..c1b900a5f 100644
--- a/sci-biology/OBO-Edit/OBO-Edit-2.1.0.ebuild
+++ b/sci-biology/OBO-Edit/OBO-Edit-2.1.0.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit toolchain-funcs versionator java-pkg-2
+inherit eutils toolchain-funcs versionator java-pkg-2
MY_PV=$(replace_all_version_separators '-')
DESCRIPTION="Java-based editor optimized for the OBO biological ontology file format"
HOMEPAGE="http://www.oboedit.org/"
SRC_URI="
- http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/OBO-Edit%20"${PV}"/"${MY_PV}"_unix_install4j.sh/download -> OBO-Edit_unix_install4j-"${PV}".sh
- http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/OBO-Edit%20"${PV}"/ReleaseNotes-"${PV}".txt"
+ http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/OBO-Edit%20${PV}/${MY_PV}_unix_install4j.sh/download -> OBO-Edit_unix_install4j-${PV}.sh
+ http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/OBO-Edit%20${PV}/ReleaseNotes-${PV}.txt"
LICENSE="OBO-Edit" # Artistic-like
SLOT="0"
@@ -25,17 +25,30 @@ RDEPEND="virtual/jre"
S="${WORKDIR}"
src_install(){
- mkdir -p "${D}"/opt/OBO-Edit2/.install4j || die "Cannot pre-create "${D}"/opt/OBO-Edit2/.install4j/"
- sed "s#\"\${D}\"#"${D}"#g" "${FILESDIR}"/response.varfile > "${D}"/opt/OBO-Edit2/.install4j/response.varfile || die "sed failed"
- sed "s#/bin/java\" -Dinstall4j.jvmDir#/bin/java\" -Duser.home="${D}"/../temp -Dinstall4j.jvmDir#" -i "${DISTDIR}"/OBO-Edit_unix_install4j-"${PV}".sh || die "failed to set userHome value"
-
- sh "${DISTDIR}"/OBO-Edit_unix_install4j-"${PV}".sh -q -overwrite --varfile="${D}"/opt/OBO-Edit2/.install4j/response.varfile --destination="${D}"/opt/OBO-Edit2 -dir "${D}"/opt/OBO-Edit2 || die "Failed to run the self-extracting "${DISTDIR}"/OBO-Edit_unix_install4j-"${PV}".sh file"
+ dodir /opt/OBO-Edit2/.install4j
+
+ sed \
+ -e "s#\"\${D}\"#"${D}"#g" \
+ "${FILESDIR}"/response.varfile \
+ > "${D}"/opt/OBO-Edit2/.install4j/response.varfile || die "sed failed"
+
+ sed \
+ -e "s#/bin/java\" -Dinstall4j.jvmDir#/bin/java\" -Duser.home="${D}"/../temp -Dinstall4j.jvmDir#" \
+ -i "${DISTDIR}"/OBO-Edit_unix_install4j-"${PV}".sh || die "failed to set userHome value"
+
+ sh "${DISTDIR}"/OBO-Edit_unix_install4j-"${PV}".sh \
+ -q -overwrite \
+ --varfile="${D}"/opt/OBO-Edit2/.install4j/response.varfile \
+ --destination="${D}"/opt/OBO-Edit2 \
+ -dir "${D}"/opt/OBO-Edit2 \
+ || die "Failed to run the self-extracting ${DISTDIR}/OBO-Edit_unix_install4j-"${PV}".sh file"
find . -name firstrun -delete || die
- find . -name .svn -exec rm -rf '{}' \; || die
+
+ esvn_clean
insinto /opt/
doins -r OBO-Edit2
- chmod 755 "${ED}"/opt/OBO-Edit2/*
+ chmod 755 "${ED}"/opt/OBO-Edit2/* || die
dodoc "${DISTDIR}"/ReleaseNotes-2.1.0.txt
}
diff --git a/sci-biology/OBO-Edit/OBO-Edit-2.1.1.6.ebuild b/sci-biology/OBO-Edit/OBO-Edit-2.1.1.6.ebuild
index 0a3ca5d30..4aa649629 100644
--- a/sci-biology/OBO-Edit/OBO-Edit-2.1.1.6.ebuild
+++ b/sci-biology/OBO-Edit/OBO-Edit-2.1.1.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit toolchain-funcs versionator java-pkg-2
+inherit eutils toolchain-funcs versionator java-pkg-2
# MY_PV=$(replace_all_version_separators '-')
MY_PV="oboedit_2_1_1-b6"
@@ -14,8 +14,8 @@ MY_PV=$(replace_all_version_separators '-')
DESCRIPTION="Java-based editor optimized for the OBO biological ontology file format"
HOMEPAGE="http://www.oboedit.org/"
SRC_URI="
- http://downloads.sourceforge.net/project/geneontology/OBO-Edit%202%20%5BLatest%20versions%5D/"${MY_VER}"/"${MY_PV}"_unix_install4j.sh -> "${PN}"_unix_install4j-"${PV}".sh
- http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/"${MY_PV}"/ReleaseNotes-"${MY_VER}".txt -> "${PN}"_ReleaseNotes-"${PV}".txt"
+ http://downloads.sourceforge.net/project/geneontology/OBO-Edit%202%20%5BLatest%20versions%5D/${MY_VER}/${MY_PV}_unix_install4j.sh -> ${PN}_unix_install4j-${PV}.sh
+ http://sourceforge.net/projects/geneontology/files/OBO-Edit%202%20%5BLatest%20versions%5D/${MY_PV}/ReleaseNotes-${MY_VER}.txt -> ${PN}_ReleaseNotes-${PV}.txt"
LICENSE="OBO-Edit" # Artistic-like
SLOT="0"
@@ -36,24 +36,26 @@ pkg_setup() {
}
src_prepare(){
- mkdir -p "${D}"/opt/OBO-Edit2/.install4j || die "Cannot pre-create "${D}"/opt/OBO-Edit2/.install4j/"
- mkdir -p "${D}"/usr/bin
+ dodir /opt/OBO-Edit2/.install4j /usr/bin
# /var/tmp/portage/sci-biology/OBO-Edit-2.1.1.6/image//opt/OBO-Edit2/.install4j/response.varfile
sed -e "s#\"\${D}\"#"${D}"#g" "${FILESDIR}"/response.varfile | \
sed -e "s#\"\${TMPDIR}\"#"${TMPDIR}"#g" | \
- sed -e "s@sys.symlinkDir=/usr/local/bin@#sys.symlinkDir=/usr/local/bin@" > \
- "${D}"/opt/OBO-Edit2/.install4j/response.varfile || die "sed failed"
- cp -r "${D}"/opt/OBO-Edit2/.install4j "${TMPDIR}"
+ sed -e "s@sys.symlinkDir=/usr/local/bin@#sys.symlinkDir=/usr/local/bin@" \
+ > "${D}"/opt/OBO-Edit2/.install4j/response.varfile || die "sed failed"
+ cp -r "${D}"/opt/OBO-Edit2/.install4j "${TMPDIR}" || die
# for user root install4j writes into /opt/icedtea-bin-7.2.0/jre/.systemPrefs or whatever it
# found via JAVA_HOME or similar variables
# for other users it writes into $HOME/.java/.userPrefs/
# trick setting -Djava.util.prefs.systemRoot="${TMPDIR}" does not work
- sed -e "s@/bin/java\" -Dinstall4j.jvmDir=\"\$app_java_home\"@/bin/java\" -Duser.home="${TMPDIR}" -Dinstall4j.jvmDir="${TMPDIR}" -Dsys.symlinkDir="${D}"usr/bin -Djava.util.prefs.systemRoot="${TMPDIR}"@" -i "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh || die "failed to set userHome and jvmDir where JAVA .systemPrefs can be found"
+ sed \
+ -e "s@/bin/java\" -Dinstall4j.jvmDir=\"\$app_java_home\"@/bin/java\" -Duser.home="${TMPDIR}" -Dinstall4j.jvmDir="${TMPDIR}" -Dsys.symlinkDir="${D}"usr/bin -Djava.util.prefs.systemRoot="${TMPDIR}"@" \
+ -i "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh \
+ || die "failed to set userHome and jvmDir where JAVA .systemPrefs can be found"
- chmod u+rx "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh
+ chmod u+rx "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh || die
}
src_install(){
@@ -62,12 +64,20 @@ src_install(){
# cat "${TMPDIR}"/.install4j/response.varfile
# chmod a-w "${TMPDIR}"/.install4j/response.varfile
- INSTALL4J_KEEP_TEMP="yes" HOME="${TMPDIR}" "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh -q --varfile="${TMPDIR}"/.install4j/response.varfile --destination="${D}"/opt/OBO-Edit2 -dir "${D}"/opt/OBO-Edit2 || die "Failed to run the self-extracting "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh file"
- find . -name firstrun -delete
- find . -name .svn -exec rm -rf '{}' \;
+ INSTALL4J_KEEP_TEMP="yes" \
+ HOME="${TMPDIR}" \
+ sh "${DISTDIR}"/"${PN}"_unix_install4j-"${PV}".sh -q \
+ --varfile="${TMPDIR}"/.install4j/response.varfile \
+ --destination="${D}"/opt/OBO-Edit2 \
+ -dir "${D}"/opt/OBO-Edit2 \
+ || die "Failed to run the self-extracting ${DISTDIR}/${PN}_unix_install4j-${PV}.sh file"
+
+ find . -name firstrun -delete || die
+
+ esvn_clean
dodoc "${DISTDIR}"/"${PN}"_ReleaseNotes-"${PV}".txt
- echo "PATH=/opt/OBO-Edit2" > 99OBO-Edit
- doenvd 99OBO-Edit || die
+ echo "PATH=/opt/OBO-Edit2" > 99OBO-Edit || die
+ doenvd 99OBO-Edit
}
diff --git a/sci-biology/OBO-Edit/metadata.xml b/sci-biology/OBO-Edit/metadata.xml
index c0878bce6..51e938491 100644
--- a/sci-biology/OBO-Edit/metadata.xml
+++ b/sci-biology/OBO-Edit/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-biology</herd>
diff --git a/sci-biology/apollo/apollo-9999.ebuild b/sci-biology/apollo/apollo-9999.ebuild
index c00cdcc83..b92396a8c 100644
--- a/sci-biology/apollo/apollo-9999.ebuild
+++ b/sci-biology/apollo/apollo-9999.ebuild
@@ -46,5 +46,5 @@ src_install() {
java-pkg_dojar jars/apollo.jar
echo "PATH=/opt/Apollo" > 99Apollo
- doenvd 99Apollo || die
+ doenvd 99Apollo
}
diff --git a/sci-biology/consed/consed-29.ebuild b/sci-biology/consed/consed-29.ebuild
index b814b4689..46144771b 100644
--- a/sci-biology/consed/consed-29.ebuild
+++ b/sci-biology/consed/consed-29.ebuild
@@ -74,7 +74,7 @@ src_install() {
echo 'CONSED_PARAMETERS="${EPREFIX}/etc/consedrc"' >> "${S}"/99consed || die
mkdir -p "${ED}"/etc/consedrc || die
touch "${ED}"/etc/consedrc || die
- doenvd "${S}/99consed" || die
+ doenvd "${S}/99consed"
sed \
-e "s#/usr/local/genome#${EPREFIX}/usr#" \
-i "${ED}"/usr/bin/{*.perl,phredPhrap,phredPhrapWithPhdBalls} || die
diff --git a/sci-biology/pileup/pileup-0.6.ebuild b/sci-biology/pileup/pileup-0.6.ebuild
index aaa8a56b5..77322f471 100644
--- a/sci-biology/pileup/pileup-0.6.ebuild
+++ b/sci-biology/pileup/pileup-0.6.ebuild
@@ -48,14 +48,14 @@ src_compile(){
src_install(){
cd ssaha_pileup/ssaha_pileup || die "Cannot cd to "${S}"ssaha_pileup/ssaha_pileup"
- dobin ssaha_pileup ssaha_solexa ssaha_pairs ssaha_clean ssaha_mates ssaha_cigar ssaha_indel view_pileup ssaha_reads ssaha_merge ssaha_check-cigar || die "dobin failed"
+ dobin ssaha_pileup ssaha_solexa ssaha_pairs ssaha_clean ssaha_mates ssaha_cigar ssaha_indel view_pileup ssaha_reads ssaha_merge ssaha_check-cigar "dobin failed"
cd "${S}" || die
for f in ssaha_pileup/other_codes/get_seqreads/get_seqreads \
ssaha_pileup/other_codes/ssaha_split/ssaha_split \
ssaha_pileup/other_codes/ssaha_parseSNP/ssaha_parseSNP \
ssaha_pileup/other_codes/search_read/search_read; do
- dobin $f || die "dobin failed"
+ dobin $f "dobin failed"
done
# TODO:
diff --git a/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild b/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
index 86be5affe..18e3e697e 100644
--- a/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
+++ b/sci-biology/repeatmasker/repeatmasker-4.0.6-r2.ebuild
@@ -68,19 +68,20 @@ Y
src_install() {
exeinto /usr/share/${PN}
for i in DateRepeats ProcessRepeats RepeatMasker DupMasker RepeatProteinMask; do
- doexe $i || die
- dosym /usr/share/${PN}/$i /usr/bin/$i || die
+ doexe $i
+ dosym /usr/share/${PN}/$i /usr/bin/$i
done
dodir /usr/share/${PN}/lib
insinto /usr/share/${PN}/lib
doins "${S}"/*.pm "${S}"/Libraries/*.pm
- rm -rf "${S}"/Libraries/*.pm # zap the supposedly misplaced RepeatAnnotationData.pm file
+ # zap the supposedly misplaced RepeatAnnotationData.pm file
+ rm -rf "${S}"/Libraries/*.pm || die
# if sci-biology/repeatmasker-libraries is installed prevent file collision
# and do NOT install Libraries/RepeatMaskerLib.embl file which contains
# a limited version of the file: 20110419-min
- rm -rf Libraries/RepeatMaskerLib.embl
+ rm -rf Libraries/RepeatMaskerLib.embl || die
insinto /usr/share/${PN}
doins -r util Matrices Libraries *.help
keepdir /usr/share/${PN}/Libraries
diff --git a/sci-biology/tablet-bin/tablet-bin-1.14.10.21.ebuild b/sci-biology/tablet-bin/tablet-bin-1.14.10.21.ebuild
index ae4e970b5..6c0e63a2b 100644
--- a/sci-biology/tablet-bin/tablet-bin-1.14.10.21.ebuild
+++ b/sci-biology/tablet-bin/tablet-bin-1.14.10.21.ebuild
@@ -93,5 +93,5 @@ src_install() {
# python_foreach_impl python_doscript "${WORKDIR}"/coveragestats.py
echo "PATH=${EPREFIX}/opt/Tablet" > 99Tablet
- doenvd 99Tablet || die
+ doenvd 99Tablet
}
diff --git a/sci-biology/trf/trf-4.07b.ebuild b/sci-biology/trf/trf-4.07b.ebuild
index 4d0416a31..eed81dea9 100644
--- a/sci-biology/trf/trf-4.07b.ebuild
+++ b/sci-biology/trf/trf-4.07b.ebuild
@@ -35,7 +35,7 @@ src_install() {
dosym /opt/${PN}/${MY_P}.linux.exe /opt/bin/trf
# GTK version (http://tandem.bu.edu/trf/downloads/trf400.linuxgtk.exe) has broken linking
#if use gtk; then
- # doexe trf400.linuxgtk.exe || die
+ # doexe trf400.linuxgtk.exe
# make_desktop_entry /opt/${PN}/trf400.linuxgtk.exe "Tandem Repeats Finder" || die
#fi
dodoc \
diff --git a/sci-libs/med/med-2.3.6.ebuild b/sci-libs/med/med-2.3.6.ebuild
index edfa5be63..d32da0be2 100644
--- a/sci-libs/med/med-2.3.6.ebuild
+++ b/sci-libs/med/med-2.3.6.ebuild
@@ -47,18 +47,18 @@ src_install() {
exeinto /usr/share/doc/${PF}/examples/c
for i in `ls tests/c/*.o` ;
do
- doexe tests/c/`basename ${i} .o` || die "doexe failed"
+ doexe tests/c/`basename ${i} .o` "doexe failed"
done
exeinto /usr/share/doc/${PF}/examples/c/.libs
- doexe tests/c/.libs/* || die "doexe failed"
+ doexe tests/c/.libs/* "doexe failed"
dodir /usr/share/doc/${PF}/examples/f/.libs
exeinto /usr/share/doc/${PF}/examples/f
for i in `ls tests/f/*.o` ;
do
- doexe tests/f/`basename ${i} .o` || die "doexe failed"
+ doexe tests/f/`basename ${i} .o` "doexe failed"
done
exeinto /usr/share/doc/${PF}/examples/f/.libs
- doexe tests/f/.libs/* || die "doexe failed"
+ doexe tests/f/.libs/* "doexe failed"
fi
}