aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/gsl/ChangeLog7
-rw-r--r--sci-libs/gsl/gsl-1.16-r1.ebuild60
-rw-r--r--sci-libs/gsl/gsl-1.16-r2.ebuild8
-rw-r--r--sci-libs/gsl/metadata.xml10
4 files changed, 17 insertions, 68 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index 0ffe3bda8..936c4dff6 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-libs/gsl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.77 2010/08/09 09:32:55 xarthisius Exp $
+ 16 Jun 2015; Justin Lecher <jlec@gentoo.org> -gsl-1.16-r1.ebuild,
+ gsl-1.16-r2.ebuild, metadata.xml:
+ sci-libs/gsl: Fix problems during installation with multilib and alternatives,
+ https://github.com/gentoo-science/sci/issues/438
+
*gsl-1.16-r2 (10 Nov 2014)
10 Nov 2014; Christoph Junghans <ottxor@gentoo.org> +gsl-1.16-r2.ebuild:
diff --git a/sci-libs/gsl/gsl-1.16-r1.ebuild b/sci-libs/gsl/gsl-1.16-r1.ebuild
deleted file mode 100644
index f19bba153..000000000
--- a/sci-libs/gsl/gsl-1.16-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-
-inherit alternatives-2 autotools-utils eutils toolchain-funcs
-
-DESCRIPTION="GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="cblas-external static-libs"
-
-RDEPEND="cblas-external? ( virtual/cblas )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-cblas-external.patch )
-
-src_configure() {
- if use cblas-external; then
- export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
- export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
- fi
- local myeconfargs=(
- $(use_with cblas-external)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- local libname=gslcblas
-
- cat <<-EOF > ${libname}.pc
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include
- Name: ${libname}
- Description: ${DESCRIPTION} CBLAS implementation
- Version: ${PV}
- URL: ${HOMEPAGE}
- Libs: -L\${libdir} -l${libname}
- Libs.private: -lm
- Cflags: -I\${includedir}
- EOF
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${libname}.pc
-
- # Don't add gsl as a cblas alternative if using cblas-external
- use cblas-external || alternatives_for cblas gsl 0 \
- /usr/$(get_libdir)/pkgconfig/cblas.pc ${libname}.pc \
- /usr/include/cblas.h gsl/gsl_cblas.h
-}
diff --git a/sci-libs/gsl/gsl-1.16-r2.ebuild b/sci-libs/gsl/gsl-1.16-r2.ebuild
index 7cf440230..fada1472a 100644
--- a/sci-libs/gsl/gsl-1.16-r2.ebuild
+++ b/sci-libs/gsl/gsl-1.16-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -53,8 +53,12 @@ multilib_src_install() {
insinto /usr/$(get_libdir)/pkgconfig
doins ${libname}.pc
+ GSL_ALTERNATIVES+=( /usr/$(get_libdir)/pkgconfig/cblas.pc ${libname}.pc )
+}
+
+multilib_src_install_all() {
# Don't add gsl as a cblas alternative if using cblas-external
use cblas-external || alternatives_for cblas gsl 0 \
- /usr/$(get_libdir)/pkgconfig/cblas.pc ${libname}.pc \
+ ${GSL_ALTERNATIVES[@]} \
/usr/include/cblas.h gsl/gsl_cblas.h
}
diff --git a/sci-libs/gsl/metadata.xml b/sci-libs/gsl/metadata.xml
index 9be87cabc..2d7f4e76e 100644
--- a/sci-libs/gsl/metadata.xml
+++ b/sci-libs/gsl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The GNU Scientific Library (GSL) is a collection of routines for
numerical analysis. The routines are written from scratch by the GSL
team in C, and present a modern API for C programmers, while allowing
@@ -15,8 +15,8 @@
differential equations, quadrature, Monte Carlo integration, special
functions, physical constants, and much more.
</longdescription>
-<use>
- <flag name="cblas-external">Link gsl with external cblas provided by
+ <use>
+ <flag name="cblas-external">Link gsl with external cblas provided by
(<pkg>virtual/cblas</pkg>) instead of shipped internal version</flag>
-</use>
+ </use>
</pkgmetadata>