aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/numba/Manifest2
-rw-r--r--dev-python/numba/numba-0.54.0.ebuild84
-rw-r--r--dev-python/numba/numba-0.55.0.ebuild85
3 files changed, 0 insertions, 171 deletions
diff --git a/dev-python/numba/Manifest b/dev-python/numba/Manifest
index 073390aea..6282580a9 100644
--- a/dev-python/numba/Manifest
+++ b/dev-python/numba/Manifest
@@ -1,3 +1 @@
-DIST numba-0.54.0.tar.gz 2263302 BLAKE2B 24747fcf23f686460fdd8df4784a3bccd6c41f07ff7e657f797a2959066254c079b05ec4460a7cbafef9482f463aa000ee28f8f09339cd7568a0c85b52bc4437 SHA512 ad1142e8c772660b7cbbd17566b9dc96784057467b5cc546f88e2215c9428905e1f6da05ffe104f4ad526f5131fedfa9057745d5458c3293a8cd8e01a49d0fad
-DIST numba-0.55.0.tar.gz 2335687 BLAKE2B 439206cb94149226f54eb988bcc9cefb815f734b0bfa01888f7ba16525ae2cbab39ee929a655086a47a3c3bc540e8589bdbf119cc084e876d9b61da1017bdfe9 SHA512 3651d1d06c5f325459ab73c07f501c12b3081d97d0f92d0120c8cfb312092658bbebc91f8340786f7b10cd43a95e278085cbba6d199cb3d0b5f71987ee7e5776
DIST numba-0.56.0.tar.gz 2488023 BLAKE2B ebfc00e2f131de54cf97db0f7bb6034a650c76db1b001fc68adec7800f4890b598d83cbcf8e5beb7f8023b770b310a2d837bfc0a43d5b901f2e09a40908ec307 SHA512 cedeb683120505a02ce2911efc46c0137cc03a25b1a6864b1ff68fe69655abfbe1d9880785ea718cd14577c985e1baa8b2cb3ecaf5c591c843b9021fa182c284
diff --git a/dev-python/numba/numba-0.54.0.ebuild b/dev-python/numba/numba-0.54.0.ebuild
deleted file mode 100644
index 125b20daf..000000000
--- a/dev-python/numba/numba-0.54.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit optfeature multiprocessing distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="https://numba.pydata.org/
- https://github.com/numba"
-SRC_URI="https://github.com/numba/numba/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="openmp threads"
-
-RDEPEND="
- >=dev-python/llvmlite-0.37.0[${PYTHON_USEDEP}]
- <dev-python/llvmlite-0.38.0
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- threads? ( >=dev-cpp/tbb-2019.5 )
-"
-BDEPEND="
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-distutils_enable_tests unittest
-distutils_enable_sphinx docs/source dev-python/numpydoc dev-python/sphinx_rtd_theme
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.52.0-skip_tests.patch"
-)
-
-pkg_setup() {
- if ! use openmp; then
- export NUMBA_DISABLE_OPENMP=1 || die
- else
- unset NUMBA_DISABLE_OPENMP || die
- fi
- if ! use threads; then
- export NUMBA_DISABLE_TBB=1 || die
- else
- unset NUMBA_DISABLE_TBB || die
- export TBBROOT="${EPREFIX}/usr" || die
- fi
-}
-
-python_prepare_all() {
- # This conf.py only works in a git repo
- if use doc; then
- git init -q || die
- git config user.email "larry@gentoo.org" || die
- git config user.name "Larry the Cow" || die
- git add . || die
- git commit -m "init" || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- # FIXME: parallel python building fails. See Portage bug #614464 and
- # gentoo/sci issue #1080.
- export MAKEOPTS=-j1 || die
- distutils-r1_python_compile
-}
-
-# https://numba.pydata.org/numba-doc/latest/developer/contributing.html?highlight=test#running-tests
-python_test() {
- distutils_install_for_testing
- ${EPYTHON} setup.py build_ext --inplace || die \
- "${EPYTHON} failed to build_ext"
- ${EPYTHON} runtests.py -m $(makeopts_jobs) || die \
- "${EPYTHON} failed unittests"
-}
-
-pkg_postinst() {
- optfeature "compile cuda code" dev-util/nvidia-cuda-sdk
-}
diff --git a/dev-python/numba/numba-0.55.0.ebuild b/dev-python/numba/numba-0.55.0.ebuild
deleted file mode 100644
index 342c3894f..000000000
--- a/dev-python/numba/numba-0.55.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit optfeature multiprocessing distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="https://numba.pydata.org/
- https://github.com/numba"
-SRC_URI="https://github.com/numba/numba/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="openmp threads"
-
-RDEPEND="
- >=dev-python/llvmlite-0.38.0[${PYTHON_USEDEP}]
- <=dev-python/llvmlite-0.39.0
- >=dev-python/numpy-1.18.0[${PYTHON_USEDEP}]
- <dev-python/numpy-1.22[${PYTHON_USEDEP}]
- threads? ( >=dev-cpp/tbb-2021.1 )
-"
-BDEPEND="
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-distutils_enable_tests unittest
-distutils_enable_sphinx docs/source dev-python/numpydoc dev-python/sphinx_rtd_theme
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.52.0-skip_tests.patch"
-)
-
-pkg_setup() {
- if ! use openmp; then
- export NUMBA_DISABLE_OPENMP=1 || die
- else
- unset NUMBA_DISABLE_OPENMP || die
- fi
- if ! use threads; then
- export NUMBA_DISABLE_TBB=1 || die
- else
- unset NUMBA_DISABLE_TBB || die
- export TBBROOT="${EPREFIX}/usr" || die
- fi
-}
-
-python_prepare_all() {
- # This conf.py only works in a git repo
- if use doc; then
- git init -q || die
- git config user.email "larry@gentoo.org" || die
- git config user.name "Larry the Cow" || die
- git add . || die
- git commit -m "init" || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- # FIXME: parallel python building fails. See Portage bug #614464 and
- # gentoo/sci issue #1080.
- export MAKEOPTS=-j1 || die
- distutils-r1_python_compile
-}
-
-# https://numba.pydata.org/numba-doc/latest/developer/contributing.html?highlight=test#running-tests
-python_test() {
- distutils_install_for_testing
- ${EPYTHON} setup.py build_ext --inplace || die \
- "${EPYTHON} failed to build_ext"
- ${EPYTHON} runtests.py -m $(makeopts_jobs) || die \
- "${EPYTHON} failed unittests"
-}
-
-pkg_postinst() {
- optfeature "compile cuda code" dev-util/nvidia-cuda-sdk
-}