aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/mlgmpidl/Manifest2
-rw-r--r--dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild14
-rw-r--r--dev-ml/ocamlgraph/Manifest2
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild18
-rw-r--r--sci-mathematics/apron/Manifest2
-rw-r--r--sci-mathematics/apron/apron-0.9.10.ebuild12
-rw-r--r--sci-mathematics/frama-c/Manifest2
-rw-r--r--sci-mathematics/frama-c/frama-c-20090901.ebuild22
-rw-r--r--sci-mathematics/gappa/Manifest2
-rw-r--r--sci-mathematics/gappa/gappa-0.12.1.ebuild17
-rw-r--r--sci-mathematics/gappalib-coq/Manifest2
-rw-r--r--sci-mathematics/gappalib-coq/gappalib-coq-0.12.ebuild15
-rw-r--r--sci-mathematics/pff/Manifest2
-rw-r--r--sci-mathematics/pff/pff-8.2.1.2.ebuild15
-rw-r--r--sci-mathematics/why/Manifest2
-rw-r--r--sci-mathematics/why/why-2.19.ebuild31
16 files changed, 72 insertions, 88 deletions
diff --git a/dev-ml/mlgmpidl/Manifest b/dev-ml/mlgmpidl/Manifest
index 1f3a46d51..aa9c3903e 100644
--- a/dev-ml/mlgmpidl/Manifest
+++ b/dev-ml/mlgmpidl/Manifest
@@ -1,2 +1,2 @@
DIST mlgmpidl-1.1.tgz 194002 RMD160 752c865e5355b40f9b3c9babf0c9c378cb3b4009 SHA1 ef26eaa215ccedbfc20c00614f702a06d3a70420 SHA256 8990a56f4c1ff701bb922bacf7f23b40539d123216ac5f9fe0f35967735d6fc9
-EBUILD mlgmpidl-1.1.ebuild 1347 RMD160 5eff2fd937a758d0ac8df13473465551a6b35f73 SHA1 a3135dfdb622b46b1fc086ff8d88901219cbd0a3 SHA256 98f8d303dafc13b7ca0aaa41bd284da84e7d6117adf9d7856238e0d962a38c24
+EBUILD mlgmpidl-1.1.ebuild 1306 RMD160 6864dcd9898822cc61b5bb6eb00750fef89ffb2c SHA1 d03222f5ad460e269004fa4bf6491b37fd4afc9a SHA256 eb577a14243d7de1685e17782eadaa34674bcab41860d522c547a1f1a3d0cfe7
diff --git a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
index 4bc14d0d1..fefbd9c56 100644
--- a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
+++ b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
inherit eutils toolchain-funcs
-DESCRIPTION="MLGMPIDL is a package offering an interface to the GMP and MPFR libraries for OCaml version 3.07 or higher."
+DESCRIPTION="MLGMPIDL is an OCaml interface to the GMP and MPFR libraries"
HOMEPAGE="http://www.inrialpes.fr/pop-art/people/bjeannet/mlxxxidl-forge/mlgmpidl/"
SRC_URI="http://gforge.inria.fr/frs/download.php/20228/${PN}-${PV}.tgz"
@@ -13,13 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc +mpfr"
-RDEPEND="dev-libs/gmp
+RDEPEND=">=dev-lang/ocaml-3.09
+ dev-ml/camlidl
+ dev-libs/gmp
mpfr? ( dev-libs/mpfr )
- >=dev-lang/ocaml-3.09
- dev-ml/camlidl"
-DEPEND="${RDEPEND}
doc? ( app-text/texlive
app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index e64401809..97fe01cb1 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1,3 +1,3 @@
AUX ocamlgraph-1.2-makefile.patch 3980 RMD160 fda851982c979d4c4d667bdd803bb9a570f8e3f8 SHA1 74eec2569ad39f35fd784fc13fa16f7d37cbe3f8 SHA256 fa5ce23b1561555c07d51a75b7e2850fdb1b6abe41bc902b9d4f8f99a1473e0c
DIST ocamlgraph-1.2.tar.gz 213426 RMD160 c5ef73069a912ba179adbad3c4e0d629cc91cd54 SHA1 087cd2720c1a3df3f6543db4ad8d81983fcddba0 SHA256 0695a91a3f2abc0f47eafdae4af8a6022154727aec00784a12362d3719ff51f2
-EBUILD ocamlgraph-1.2.ebuild 1006 RMD160 65691ad55fe153b56ea2f8f4a0e1290e3d24f31c SHA1 f04c187df1bc7413f604bec076d233ce7cf74674 SHA256 9675075cb999ab2509e69ce44d45295f20c6dd616ee1c205efa2d243ece78da6
+EBUILD ocamlgraph-1.2.ebuild 978 RMD160 a7cee4a4bfc08a9697bec9cb73b747c07a8b5df3 SHA1 cb2cdf8cb2c81ea561e9a75d03656570626c1faf SHA256 1977d3ab257ca158405a7112aba13536ab7674f7c2799fd162db86a0b5115638
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
index 3c20a8c59..97ae38e1c 100644
--- a/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
-
-inherit eutils autotools
+# $Header: $
EAPI="2"
+inherit eutils autotools
+
DESCRIPTION="A graph library for Objective Caml"
HOMEPAGE="http://ocamlgraph.lri.fr/"
SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
@@ -13,17 +13,13 @@ SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples gtk +ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
-
-DEPEND="${RDEPEND}
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
gtk? ( >=dev-ml/lablgtk-2.6 )"
+RDEPEND="${DEPEND}"
-IUSE="doc examples gtk +ocamlopt"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
+src_prepare() {
epatch "${FILESDIR}/${P}-makefile.patch"
eautoreconf
}
diff --git a/sci-mathematics/apron/Manifest b/sci-mathematics/apron/Manifest
index 251d0b2aa..f62d6aa59 100644
--- a/sci-mathematics/apron/Manifest
+++ b/sci-mathematics/apron/Manifest
@@ -1,3 +1,3 @@
AUX apron-0.9.10-pkgrid_manager.patch 543 RMD160 36b7ef40e2748781a21275af0e50bfbfd0a4253e SHA1 c636f4837643b3bfe6cc2f9ee7194d9b2a756fc6 SHA256 d62e05fac7f08d2b6ac62a8e8819ce00e55605155869a7d5ad814c399020d6bf
DIST apron-0.9.10.tgz 845879 RMD160 ddd621617adfa158ecd1b8cc3371feca29a95538 SHA1 77ac01bad0d5a0dfc702c647e1290b4bd1ff6f11 SHA256 af1f113b455d16b41bba3c3e94274edacfa5a8d8ef12fde2adc26eaa01f900ef
-EBUILD apron-0.9.10.ebuild 2389 RMD160 98a8a1433d7b67ed3a00d61b71f7f4da82d7c7eb SHA1 d8f5287502b13c05508d2d99687dc0e4cb08abdc SHA256 6af7263051e118ab4635ba425810c331f25cf5bb970ba82a53e609693e46487a
+EBUILD apron-0.9.10.ebuild 2386 RMD160 8380979823586038f2f24193d931680f484de4cc SHA1 c512f3691e8eedf71869c2b428c12476565e59bb SHA256 48cd14b9caae325c240bd796897064ccf65f2ec7e49a36d91a8ed0137d4071a8
diff --git a/sci-mathematics/apron/apron-0.9.10.ebuild b/sci-mathematics/apron/apron-0.9.10.ebuild
index bb1879386..1adf692be 100644
--- a/sci-mathematics/apron/apron-0.9.10.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10.ebuild
@@ -4,7 +4,7 @@
inherit eutils toolchain-funcs
-DESCRIPTION="The APRON library is dedicated to the static analysis of the numerical variables of a program by Abstract Interpretation"
+DESCRIPTION="APRON is a library dedicated to the static analysis of the numerical variables of a program by Abstract Interpretation"
HOMEPAGE="http://apron.cri.ensmp.fr/library/"
SRC_URI="http://apron.cri.ensmp.fr/library/${P}.tgz"
@@ -13,16 +13,16 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="cxx doc ocaml ppl"
-RDEPEND="dev-libs/gmp
- dev-libs/mpfr
- ocaml? ( >=dev-lang/ocaml-3.09
+DEPEND="ocaml? ( >=dev-lang/ocaml-3.09
dev-ml/camlidl
dev-ml/mlgmpidl )
- ppl? ( dev-libs/ppl )"
-DEPEND="${RDEPEND}
+ dev-libs/gmp
+ dev-libs/mpfr
+ ppl? ( dev-libs/ppl )
doc? ( app-text/texlive
app-text/ghostscript-gpl
cxx? ( app-doc/doxygen ) )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/sci-mathematics/frama-c/Manifest b/sci-mathematics/frama-c/Manifest
index e0dcdaaca..4314b2f2a 100644
--- a/sci-mathematics/frama-c/Manifest
+++ b/sci-mathematics/frama-c/Manifest
@@ -2,4 +2,4 @@ AUX frama-c-20090901-ocamlgraph_link.patch 721 RMD160 0b78639b9f31c62575a0552c93
AUX frama-c-20090901-varinfo_export.patch 672 RMD160 987c2ca3b627eaf500e5db8ad91ca8a81e3a1bd4 SHA1 d2cdbd2107058476b460d9986f7bb95ca5d6138e SHA256 03d8aee3083f9b35d535882124305d99964b193931eca877d45202abcf6d9186
AUX frama-c-20090901-why_link.patch 2172 RMD160 bc971e4d99a8a8b7570fd1da8e5f751b70b4a73f SHA1 6e8d3c337715af9d94f996aa2ca5a63dbae20ae9 SHA256 0f4020d2562cf32f85e1ee605464c2e48cffa0448245999fd063b70095640357
DIST frama-c-Beryllium-20090901.tar.gz 18162700 RMD160 b29038e948b898196947cae636eef9adbea99ed6 SHA1 17b1516e9807a9a34ab20a3413efc372549e6fed SHA256 ac420d72b9d0062dd1213a6e595a01c32d0cd5a465c8736c65a42cc717742cc9
-EBUILD frama-c-20090901.ebuild 1592 RMD160 350e9b34960c7af27dd13e207e074a2f284f36c0 SHA1 abe99a2adb0bca1d473d3709963dbcf4bed7437a SHA256 b6c176a9af2c3d1101b1399240d0a59ed8dfc37542f9f150de63dd30af414816
+EBUILD frama-c-20090901.ebuild 1578 RMD160 ccc9615d90e4298233cb50e12833c7e9fc6f5d2d SHA1 438c45e919e9943d2715bf7574a88d36139d2d70 SHA256 aa2b4c7bd0e5de83884d504d10a99d9bbc399c7bedd722623845fc849e7c4925
diff --git a/sci-mathematics/frama-c/frama-c-20090901.ebuild b/sci-mathematics/frama-c/frama-c-20090901.ebuild
index a737eedcc..ceb871061 100644
--- a/sci-mathematics/frama-c/frama-c-20090901.ebuild
+++ b/sci-mathematics/frama-c/frama-c-20090901.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
inherit autotools eutils
@@ -12,29 +14,25 @@ SRC_URI="http://www.frama-c.cea.fr/download/${PN/-c/-c-$NAME}-${PV/_/-}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
IUSE="apron coq doc gappa gtk pff +why"
RESTRICT="strip"
-RDEPEND="sci-mathematics/ltl2ba
+DEPEND=">=dev-lang/ocaml-3.10.2
+ >=dev-ml/ocamlgraph-1.2
+ gtk? ( >=dev-ml/lablgtk-2.12 )
+ sci-mathematics/ltl2ba
apron? ( sci-mathematics/apron )
coq? ( sci-mathematics/coq )
gappa? ( sci-mathematics/gappalib-coq )
pff? ( sci-mathematics/pff )
why? ( sci-mathematics/why )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/ocaml-3.10.2
- >=dev-ml/ocamlgraph-1.1
- gtk? ( >=dev-ml/lablgtk-2.12 )"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN/-c/-c-$NAME}-${PV/_/-}"
-src_unpack(){
- unpack ${A}
- cd "${S}"
-
+src_prepare(){
touch config_file
+
epatch "${FILESDIR}/${P}-varinfo_export.patch"
epatch "${FILESDIR}/${P}-why_link.patch"
epatch "${FILESDIR}/${P}-ocamlgraph_link.patch"
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
index 848ec3985..36f905d4c 100644
--- a/sci-mathematics/gappa/Manifest
+++ b/sci-mathematics/gappa/Manifest
@@ -1,2 +1,2 @@
DIST gappa-0.12.1.tar.gz 250015 RMD160 0809d73801636ee649324f951db72c58bb74a65a SHA1 b01ba7bf5e915b5c0f25eb34ad6a52e4ede09b10 SHA256 287c9ba0186319a1e7e353fa7955ffaf1f1f13941d2605d4ca078b8f260e13cd
-EBUILD gappa-0.12.1.ebuild 1301 RMD160 2016153dc74006e9d7d410d590dd9f3f328f62fc SHA1 27f787bd511e0722f29406a5590b5a895be89cf0 SHA256 e9b704031f4516c5d28f6b7280d0d86f85b9b48386bcf45ac6bd2fa3457c3a73
+EBUILD gappa-0.12.1.ebuild 1281 RMD160 e1aa7ca24242e8a4e0fed0db52452707fb3d61d2 SHA1 4fe9ac5cca5c0c1f95572ec4d88f6a0fc7a760a2 SHA256 686481381955112d30934f6d76cd474a1b381f93f606e13b60c8875dae93b981
diff --git a/sci-mathematics/gappa/gappa-0.12.1.ebuild b/sci-mathematics/gappa/gappa-0.12.1.ebuild
index 48a39de92..feb64947a 100644
--- a/sci-mathematics/gappa/gappa-0.12.1.ebuild
+++ b/sci-mathematics/gappa/gappa-0.12.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
DESCRIPTION="A tool to help verifying and proving properties on floating-point or fixed-point arithmetic."
HOMEPAGE="http://gappa.gforge.inria.fr/"
@@ -9,22 +11,17 @@ SRC_URI="http://gforge.inria.fr/frs/download.php/23429/${P}.tar.gz"
LICENSE="CeCILL GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
IUSE="doc"
-RDEPEND="dev-libs/gmp
+DEPEND="dev-libs/gmp
dev-libs/mpfr
- dev-libs/boost"
-
-DEPEND="${RDEPEND}
+ dev-libs/boost
doc? ( app-text/texlive
app-text/ghostscript-gpl
app-doc/doxygen )"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd ${S}
-
+src_prepare() {
sed -i doc/doxygen/Doxyfile \
-e "s/GENERATE_LATEX = NO/GENERATE_LATEX = YES/g" \
-e "s/USE_PDFLATEX = NO/USE_PDFLATEX = YES/g" \
diff --git a/sci-mathematics/gappalib-coq/Manifest b/sci-mathematics/gappalib-coq/Manifest
index c641472c2..56575587c 100644
--- a/sci-mathematics/gappalib-coq/Manifest
+++ b/sci-mathematics/gappalib-coq/Manifest
@@ -1,2 +1,2 @@
DIST gappalib-coq-0.12.tar.gz 118809 RMD160 f2df65844fb142c6287f4e95524cc08cc8e0c645 SHA1 6d9224a7d3bfcaf6cd16ad36671f7fcee6ad2d70 SHA256 0d9de0d4dd29a1992651aa5b76beb0d142f525a3c2b23453104fdfc9b71915cf
-EBUILD gappalib-coq-0.12.ebuild 876 RMD160 f5b188d0b9e55893aa977291b93168b8ec4ceb8f SHA1 dc17a4bb20ef0492a0b53b5706f5a238aa067016 SHA256 3ba356dbf4ad94210da62a6fd3ed45b81531e8fff0a2c54b831316211937ddac
+EBUILD gappalib-coq-0.12.ebuild 857 RMD160 2a5b470c6ac044d97207ea49282c0329b3717124 SHA1 05e0409a37aa8f3b89cf760b0adeba0f8a988d7a SHA256 a7423c507e044f192930d7f5738afaccc6030103a4ffb9e8a49603c5fca7d657
diff --git a/sci-mathematics/gappalib-coq/gappalib-coq-0.12.ebuild b/sci-mathematics/gappalib-coq/gappalib-coq-0.12.ebuild
index c52c4a928..7b55ef276 100644
--- a/sci-mathematics/gappalib-coq/gappalib-coq-0.12.ebuild
+++ b/sci-mathematics/gappalib-coq/gappalib-coq-0.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
DESCRIPTION="This library allows the certificates Gappa generates to be imported by the Coq."
HOMEPAGE="http://gappa.gforge.inria.fr/"
@@ -9,18 +11,13 @@ SRC_URI="http://lipforge.ens-lyon.fr/frs/download.php/160/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
IUSE=""
-RDEPEND="sci-mathematics/gappa
+DEPEND="sci-mathematics/gappa
sci-mathematics/coq"
+RDEPEND="${DEPEND}"
-DEPEND="${RDEPEND}"
-
-src_unpack(){
- unpack ${A}
- cd ${S}
-
+src_prepare(){
sed -i configure -e "s/if test \"\$libdir\" = '\${exec_prefix}\/lib';/ \
if test \"\$libdir\" = '\${exec_prefix}\/lib' -o "\$libdir" = \"\${prefix}\/lib64\";/g"
}
diff --git a/sci-mathematics/pff/Manifest b/sci-mathematics/pff/Manifest
index e4dfca6fc..c8baca3e2 100644
--- a/sci-mathematics/pff/Manifest
+++ b/sci-mathematics/pff/Manifest
@@ -1,2 +1,2 @@
DIST Float8.2-1.2.tgz 322949 RMD160 5ef8a68e4c10d8cffe4cd8d3eb5d5d2c1394fb60 SHA1 ab9b01cf953e32c100ed21e9980adf68553aaed1 SHA256 df61debf5afb2cbf44be6a605622b1645ba07be1912bb154ef79009d7eb235b2
-EBUILD pff-8.2.1.2.ebuild 775 RMD160 d5cd94ff2ab62d4591f4c95fef5ddcedca1a4e66 SHA1 ac4ccb9fd21c7b87e0d3ed239e6cc5406102238f SHA256 511f36dec4e350662ebb7b41ac5d0abf0455477b12b6c47277a5594e00d83a72
+EBUILD pff-8.2.1.2.ebuild 754 RMD160 9b5756e657d7c9a2fb44b089e282285f7cedf496 SHA1 c109b256d784a95f40acfec7e4c393104a9e4279 SHA256 9160ba0f01b3e83f8c4af08980d371f6fa1e7d8ccde68b1162829b91c912ea99
diff --git a/sci-mathematics/pff/pff-8.2.1.2.ebuild b/sci-mathematics/pff/pff-8.2.1.2.ebuild
index a46596a7b..3e4189d12 100644
--- a/sci-mathematics/pff/pff-8.2.1.2.ebuild
+++ b/sci-mathematics/pff/pff-8.2.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
DESCRIPTION="Library for reasoning about floating point numbers in coq."
HOMEPAGE="http://lipforge.ens-lyon.fr/www/pff/"
@@ -9,19 +11,14 @@ SRC_URI="http://lipforge.ens-lyon.fr/frs/download.php/147/Float${PV/%????/}-${PV
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
IUSE=""
-RDEPEND="sci-mathematics/coq"
-
-DEPEND="${RDEPEND}"
+DEPEND="sci-mathematics/coq"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/Float"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i -e "s|\`\$(COQC) -where\`/user-contrib| \
\$(DESTDIR)/\`\$(COQC) -where\`/user-contrib|g" Makefile
}
diff --git a/sci-mathematics/why/Manifest b/sci-mathematics/why/Manifest
index c751cc226..16fd7e4ff 100644
--- a/sci-mathematics/why/Manifest
+++ b/sci-mathematics/why/Manifest
@@ -1,4 +1,4 @@
AUX why-2.19-jessie_lib.patch 1631 RMD160 b3975a252f539a04b079b6e973332136fde464cb SHA1 2ba2c2956354c896904d0c9a2e1d6079fbb56027 SHA256 aaff9f7648438d54eec0b1e9f0ff4828aaa26558ee7d847190d7a3d6e0c4abbc
AUX why-2.19-makefile_sandbox.patch 3025 RMD160 b8b1b178b09a7b6eda9c8aeac7f5013650fb6c84 SHA1 6bd5e80aa79a6a36d89a114696da716b92aa60df SHA256 121b67a2b46139b93be9af293615a6a04e06a00323096e8b2317a7116bbf5d84
DIST why-2.19.tar.gz 2622629 RMD160 d1e3a099226a42b039672161ada63270e6274b46 SHA1 6139699168c6aab76d42e02029ba4c51cf2a8130 SHA256 f5eef288c25744f1c7725c1c733b3129a74cde6cf08eaa57b9705115d75499a3
-EBUILD why-2.19.ebuild 1464 RMD160 c651f3e87eb0480a2317c826e14ce2b92ce1cfae SHA1 71a7c40261f577d17859c129b91808f6143087e6 SHA256 830c491810c985213eb4ad19be2502a27cef19162e7588fcfa7aa87e1d7d713e
+EBUILD why-2.19.ebuild 1452 RMD160 2421c53d93a304b7fd66c39b4a5a310266b68759 SHA1 ba14b16b737bf32df58fbd134a1a626e61caff0f SHA256 a20483829aca99e8506441d0336478be5ac858e911c37e78141383b080f6ddbd
diff --git a/sci-mathematics/why/why-2.19.ebuild b/sci-mathematics/why/why-2.19.ebuild
index 9731df967..aa882d08f 100644
--- a/sci-mathematics/why/why-2.19.ebuild
+++ b/sci-mathematics/why/why-2.19.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
inherit autotools eutils
@@ -11,24 +13,19 @@ SRC_URI="http://why.lri.fr/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
IUSE="apron coq doc examples gappa gtk pff pvs"
-RDEPEND="apron? ( sci-mathematics/apron )
- coq? ( sci-mathematics/coq )
- gappa? ( sci-mathematics/gappalib-coq )
- pff? ( sci-mathematics/pff )
- pvs? ( sci-mathematics/pvs )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/ocaml-3.09
- >=dev-ml/ocamlgraph-1.1
- gtk? ( >=dev-ml/lablgtk-2.12 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-ml/ocamlgraph-1.2
+ gtk? ( >=dev-ml/lablgtk-2.12 )
+ apron? ( sci-mathematics/apron )
+ coq? ( sci-mathematics/coq )
+ gappa? ( sci-mathematics/gappalib-coq )
+ pff? ( sci-mathematics/pff )
+ pvs? ( sci-mathematics/pvs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
epatch "${FILESDIR}/${P}-makefile_sandbox.patch"
mv jc/jc_ast.mli jc/jc_ast.ml