aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/calculix-ccx/Manifest3
-rw-r--r--sci-libs/calculix-ccx/calculix-ccx-2.10.ebuild74
-rw-r--r--sci-libs/calculix-ccx/files/01_ccx_2.10_Makefile_custom_cc_flags_spooles_arpack.patch35
-rw-r--r--sci-libs/calculix-ccx/metadata.xml11
-rw-r--r--sci-libs/calculix-cgx/Manifest2
-rw-r--r--sci-libs/calculix-cgx/calculix-cgx-2.10.ebuild58
-rw-r--r--sci-libs/calculix-cgx/files/01_cgx_2.10_Makefile_custom_cxx_flags.patch73
-rw-r--r--sci-libs/calculix-cgx/files/02_cgx_2.10_menu_fix-freeglut_2.8.1.patch72
-rw-r--r--sci-libs/calculix-cgx/metadata.xml8
9 files changed, 0 insertions, 336 deletions
diff --git a/sci-libs/calculix-ccx/Manifest b/sci-libs/calculix-ccx/Manifest
deleted file mode 100644
index b74e7e9f3..000000000
--- a/sci-libs/calculix-ccx/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ccx_2.10.ps.tar.bz2 2421249 SHA256 e7f5278b8a6efd92ca97b022afb1964792e9256b42ef9b26eb966d496a60db43 SHA512 9578d358255331045dfb3d5eccb6281f3cbaf7fdb4d0cef5cd0c19d622cba857216c7d5cba95146a1396b940a0131508509c830200c82e8c7e5ea558907aac43 WHIRLPOOL 4d1510f3ae5d327b5826753badef2671c959b2b43477f5c151ca528b0a88f66a21ab243ef6aebdcd973a723d6aa3dc7c2e75a637ab3a0cf30b58d183e15fed0c
-DIST ccx_2.10.src.tar.bz2 1005712 BLAKE2B 3450423fd6d57f188d9f9dff9c7c99ef4606ae66e7b39e694c11f3b3cf0c638d37c1e40e07a97e9b86bb199322ba9bee6ac06658bf28975cea456f0ef278e4d3 SHA512 bdd852a7fa5e327ed248058370bfaa5f029e4d98c9ee7d0e0a12f2bca480e5fc402a228e23c45f94149b2de427ebff32805f9c2a4ddbb223ff6333c26076743b
-DIST ccx_2.10.test.tar.bz2 9083192 SHA256 a5e00abc7f9b2a5a5f1a4f7b414617dc65cd0be9b2a66c93e20b5a25c1392a75 SHA512 9dac892b5d3d2070cc266ceeceec2aba205a81db6bb3b688a803f7768d0223c10c545cbd617628ed3ca39b13d154834eab3529a43f360991ad41d6a7771446f2 WHIRLPOOL 757fcadbb6356d9a904973ff0e6fb5644d2ec0c36ac15a0f058d310eb43c2cb91f0c34d7bfd62e0da2d8c44a4cf6ea963975e5a247a173cf80afdad78ba326b7
diff --git a/sci-libs/calculix-ccx/calculix-ccx-2.10.ebuild b/sci-libs/calculix-ccx/calculix-ccx-2.10.ebuild
deleted file mode 100644
index 9b7efa9f3..000000000
--- a/sci-libs/calculix-ccx/calculix-ccx-2.10.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs flag-o-matic fortran-2
-
-MY_P=ccx_${PV/_/}
-
-DESCRIPTION="A Free Software Three-Dimensional Structural Finite Element Program"
-HOMEPAGE="http://www.calculix.de/"
-SRC_URI="
- http://www.dhondt.de/${MY_P}.src.tar.bz2
- doc? ( http://www.dhondt.de/${MY_P}.ps.tar.bz2 )
- examples? ( http://www.dhondt.de/${MY_P}.test.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="arpack doc examples openmp threads"
-
-RDEPEND="
- arpack? ( >=sci-libs/arpack-3.1.3 )
- >=sci-libs/spooles-2.2[threads=]
- virtual/lapack
- virtual/blas"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-text/ghostscript-gpl )"
-
-S=${WORKDIR}/CalculiX/${MY_P}/src
-
-PATCHES=(
- "${FILESDIR}/01_${MY_P}_Makefile_custom_cc_flags_spooles_arpack.patch"
-)
-
-src_configure() {
- # Technically we currently only need this when arpack is not used.
- # Keeping things this way in case we change pkgconfig for arpack
- export LAPACK=$($(tc-getPKG_CONFIG) --libs lapack)
-
- append-cflags "-I/usr/include/spooles -DSPOOLES"
- if use threads; then
- append-cflags "-DUSE_MT"
- fi
-
- if use openmp; then
- append-fflags "-fopenmp"
- append-cflags "-fopenmp"
- fi
-
- if use arpack; then
- export ARPACKLIB=$($(tc-getPKG_CONFIG) --libs arpack)
- append-cflags "-DARPACK"
- fi
- export CC="$(tc-getCC)"
- export FC="$(tc-getFC)"
-}
-
-src_install () {
- dobin ${MY_P}
- dosym ${MY_P} /usr/bin/ccx
-
- if use doc; then
- cd "${S}/../doc" || die
- ps2pdf ${MY_P}.ps ${MY_P}.pdf || die "ps2pdf failed"
- dodoc ${MY_P}.pdf
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/../test/*
- fi
-}
diff --git a/sci-libs/calculix-ccx/files/01_ccx_2.10_Makefile_custom_cc_flags_spooles_arpack.patch b/sci-libs/calculix-ccx/files/01_ccx_2.10_Makefile_custom_cc_flags_spooles_arpack.patch
deleted file mode 100644
index 83caf80f9..000000000
--- a/sci-libs/calculix-ccx/files/01_ccx_2.10_Makefile_custom_cc_flags_spooles_arpack.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Fix Makefile to make it use custom CFLAGS and system libraries.
-
-diff -uwrN ccx_2.10.ORIG/src/Makefile ccx_2.10/src/Makefile
---- src/Makefile 2016-03-07 04:57:09.462878788 +0100
-+++ ccx_2.10/src/Makefile 2016-03-07 06:05:44.150786978 +0100
-@@ -1,9 +1,6 @@
-
--CFLAGS = -Wall -O3 -fopenmp -I ../../../SPOOLES.2.2 -DARCH="Linux" -DSPOOLES -DARPACK -DMATRIXSTORAGE
--FFLAGS = -Wall -O3 -fopenmp
--
--CC=cc
--FC=gfortran
-+CFLAGS := -Wall -DARCH="Linux" -DMATRIXSTORAGE $(CFLAGS)
-+FFLAGS := -Wall $(FFLAGS)
-
- .c.o :
- $(CC) $(CFLAGS) -c $<
-@@ -18,15 +15,10 @@
- OCCXC = $(SCCXC:.c=.o)
- OCCXMAIN = $(SCCXMAIN:.c=.o)
-
--DIR=../../../SPOOLES.2.2
--
--LIBS = \
-- $(DIR)/spooles.a \
-- ../../../ARPACK/libarpack_INTEL.a \
-- -lpthread -lm -lc
-+LIBS = $(ARPACKLIB) $(LAPACK) -lm -lc -lspooles -lpthread
-
- ccx_2.10: $(OCCXMAIN) ccx_2.10.a $(LIBS)
-- ./date.pl; $(CC) $(CFLAGS) -c ccx_2.10.c; $(FC) -fopenmp -Wall -O3 -o $@ $(OCCXMAIN) ccx_2.10.a $(LIBS)
-+ ./date.pl; $(CC) $(CFLAGS) -c ccx_2.10.c; $(FC) $(FFLAGS) -o $@ $(OCCXMAIN) ccx_2.10.a $(LIBS)
-
- ccx_2.10.a: $(OCCXF) $(OCCXC)
- ar vr $@ $?
diff --git a/sci-libs/calculix-ccx/metadata.xml b/sci-libs/calculix-ccx/metadata.xml
deleted file mode 100644
index a62eacf73..000000000
--- a/sci-libs/calculix-ccx/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <use>
- <flag name="arpack"> Add sparse eigen value support via sci-libs/arpack </flag>
- </use>
-</pkgmetadata>
diff --git a/sci-libs/calculix-cgx/Manifest b/sci-libs/calculix-cgx/Manifest
deleted file mode 100644
index b5d231084..000000000
--- a/sci-libs/calculix-cgx/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST cgx_2.10.all.tar.bz2 1701663 SHA256 b2ea974003374c28b8e24f76f8a6c142db470a8c2a53013e3735efe78e98e84d SHA512 ac4dce3ffee63aa7be7ee441b7ae31a3839e6322175b70449e3c72bff3ed0bf3ade66170dd47f00d6ef488729f987f622a7db9cde3e69ad7cf38b9b096c931fd WHIRLPOOL a5186a8667e6272c669ed1f5214028235ca2179eb59f08abaa09ded64875aaeae6ab2541da6fbd6494b16b489ca2f1e68185e726fc3bc5be6bf03ed1df9d1b40
-DIST cgx_2.10.pdf 1178710 SHA256 b9bc56222496283948e151e3b1e07e4295cefba20ff9a567221bfbdb2c68b654 SHA512 cedf7556e85f631aa475d25325587aea2ecad650c325762080524dd056ba1e247d677c9ae2bcb2736b9c0a402a9060dbdebff834d8c10e3d127ecc3af9106385 WHIRLPOOL a10b68ec7772a0f98aa620b70c17b6293bf6a44647ee0a293b0629f5db6488a232b2c32cb632d77550b756293e307c4dfcd52fc3f3ccb8f73ec8ef9c6c4a4aef
diff --git a/sci-libs/calculix-cgx/calculix-cgx-2.10.ebuild b/sci-libs/calculix-cgx/calculix-cgx-2.10.ebuild
deleted file mode 100644
index e7535f52f..000000000
--- a/sci-libs/calculix-cgx/calculix-cgx-2.10.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-MY_P=cgx_${PV}
-
-DESCRIPTION="A Free Software Three-Dimensional Structural Finite Element Program"
-HOMEPAGE="http://www.calculix.de/"
-SRC_URI="http://www.dhondt.de/${MY_P}.all.tar.bz2
- doc? ( http://www.dhondt.de/${MY_P}.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# nptl removed since I cannot work around it
-IUSE="doc examples"
-
-RDEPEND="media-libs/mesa[nptl]
- >=media-libs/freeglut-1.0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXmu
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libSM
- x11-libs/libICE"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl )"
-
-S=${WORKDIR}/CalculiX/${MY_P}/src/
-
-PATCHES=(
- "${FILESDIR}"/01_${MY_P}_Makefile_custom_cxx_flags.patch
- "${FILESDIR}"/02_${MY_P}_menu_fix-freeglut_2.8.1.patch
-)
-
-src_configure () {
- # Does not compile without -lpthread
- export PTHREAD="-lpthread"
- export LFLAGS="-L/usr/$(get_libdir) ${LFLAGS}"
-}
-
-src_install () {
- dobin cgx
-
- if use doc; then
- dodoc "${DISTDIR}/${MY_P}.pdf"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/../examples/*
- fi
-}
diff --git a/sci-libs/calculix-cgx/files/01_cgx_2.10_Makefile_custom_cxx_flags.patch b/sci-libs/calculix-cgx/files/01_cgx_2.10_Makefile_custom_cxx_flags.patch
deleted file mode 100644
index d6e22f9c9..000000000
--- a/sci-libs/calculix-cgx/files/01_cgx_2.10_Makefile_custom_cxx_flags.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -uwrN cgx_2.10.ORIG/src/Makefile cgx_2.10/src/Makefile
---- src/Makefile 2016-01-13 12:41:40.398930000 +0100
-+++ cgx_2.10/src/Makefile 2016-03-08 11:02:59.591853482 +0100
-@@ -1,15 +1,15 @@
--CFLAGS = -O3 -Wall \
-+CFLAGS += -Wall \
- -I./ \
- -I/usr/include \
- -I/usr/include/GL \
- -I../../libSNL/src \
- -I../../glut-3.5/src \
-- -I/usr/X11/include
-+ -I/usr/include/X11
-
--LFLAGS = \
-- -L/usr/lib64 -lGL -lGLU \
-- -L/usr/X11R6/lib64 -lX11 -lXi -lXmu -lXext -lXt -lSM -lICE \
-- -lm -lpthread -lrt
-+LFLAGS += \
-+ -lGL -lGLU -lglut\
-+ -lX11 -lXi -lXmu -lXext -lXt -lSM -lICE \
-+ -lm $(PTHREAD) -lrt
-
-
- # on 32bit systems change lib64 to lib
-@@ -22,41 +22,6 @@
- userFunction.c
-
- SUTIL = \
-- ../../glut-3.5/src/layerutil.c \
-- ../../glut-3.5/src/glut_dials.c \
-- ../../glut-3.5/src/glut_ext.c \
-- ../../glut-3.5/src/glut_mesa.c \
-- ../../glut-3.5/src/glut_menu.c \
-- ../../glut-3.5/src/glut_modifier.c \
-- ../../glut-3.5/src/glut_space.c \
-- ../../glut-3.5/src/glut_shapes.c \
-- ../../glut-3.5/src/glut_tablet.c \
-- ../../glut-3.5/src/glut_warp.c \
-- ../../glut-3.5/src/glut_8x13.c \
-- ../../glut-3.5/src/glut_9x15.c \
-- ../../glut-3.5/src/glut_hel10.c \
-- ../../glut-3.5/src/glut_hel18.c \
-- ../../glut-3.5/src/glut_hel12.c \
-- ../../glut-3.5/src/glut_tr10.c \
-- ../../glut-3.5/src/glut_tr24.c \
-- ../../glut-3.5/src/glut_bitmap.c \
-- ../../glut-3.5/src/glut_cursor.c \
-- ../../glut-3.5/src/glut_event.c \
-- ../../glut-3.5/src/glut_get.c \
-- ../../glut-3.5/src/glut_overlay.c \
-- ../../glut-3.5/src/glut_input.c \
-- ../../glut-3.5/src/glut_stroke.c \
-- ../../glut-3.5/src/glut_teapot.c \
-- ../../glut-3.5/src/glut_winmisc.c \
-- ../../glut-3.5/src/glut_fullscrn.c \
-- ../../glut-3.5/src/glut_cindex.c \
-- ../../glut-3.5/src/glut_roman.c \
-- ../../glut-3.5/src/glut_mroman.c \
-- ../../glut-3.5/src/glut_swidth.c \
-- ../../glut-3.5/src/glut_bwidth.c \
-- ../../glut-3.5/src/glut_win.c \
-- ../../glut-3.5/src/glut_init.c \
-- ../../glut-3.5/src/glut_util.c \
- uselibSNL.cpp \
- generateTet.cpp \
- ../../libSNL/src/*.cpp
-@@ -66,7 +31,7 @@
- OUTIL = $(SUTIL:.c=.o)
-
- cgx: $(OLIB) $(OUTIL) $(OULIB)
-- g++ $(OULIB) $(OLIB) $(OUTIL) $(CFLAGS) $(LFLAGS) -o $@
-+ $(CXX) $(OULIB) $(OLIB) $(OUTIL) $(CFLAGS) $(LFLAGS) -o $@
diff --git a/sci-libs/calculix-cgx/files/02_cgx_2.10_menu_fix-freeglut_2.8.1.patch b/sci-libs/calculix-cgx/files/02_cgx_2.10_menu_fix-freeglut_2.8.1.patch
deleted file mode 100644
index ff440b44e..000000000
--- a/sci-libs/calculix-cgx/files/02_cgx_2.10_menu_fix-freeglut_2.8.1.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -uwrN cgx_2.10.ORIG/src/cgx.c cgx_2.10/src/cgx.c
---- src/cgx.c 2016-03-04 20:40:43.429549000 +0100
-+++ cgx_2.10/src/cgx.c 2016-03-08 10:53:56.816865592 +0100
-@@ -242,6 +242,9 @@
- int subsubmenu_animTune=-1, subsubmenu_animSteps=-1;
- int subsubmenu_animPeriod=-1;
-
-+char recompileFlag=0; /* 0 if nothing to recompile */
-+int recompileMenu=0; /* If recompile needed, set to lc */
-+
- GLfloat lmodel_twoside[] = { GL_TRUE };
- GLfloat lmodel_oneside[] = { GL_FALSE };
- double dx ,dy; /* Mauskoordinaten im bereich +-1*/
-@@ -400,7 +403,11 @@
- #endif
- }
-
--
-+void queueRecompileEntitiesInMenu(int lc)
-+{
-+ recompileFlag = 1;
-+ recompileMenu = lc;
-+}
-
- /* the node pointer must not be changed inside the function. Since that is the case the *node is changed to *node_dummy
- and the global *node is used which is always correct so far */
-@@ -3201,7 +3208,7 @@
- seqLC[2]=anz->l-1;
- }/* no sequence until a new entity is selected and all data are prepared */
-
-- recompileEntitiesInMenu(pre_lc);
-+ queueRecompileEntitiesInMenu(pre_lc);
- }
-
-
-@@ -3229,7 +3236,15 @@
- glutSetWindow( activWindow);
- }
-
--
-+void processMenuStatus(int status, int x, int y)
-+{
-+ if (status == GLUT_MENU_NOT_IN_USE) {
-+ if (recompileFlag) {
-+ recompileEntitiesInMenu(recompileMenu);
-+ recompileFlag = 0;
-+ }
-+ }
-+}
-
- void recompileEntitiesInMenu(int lc)
- {
-@@ -5918,6 +5933,7 @@
- glutSpecialFunc ( specialKeyboard );
- glutEntryFunc ( entryfunktion );
- glutPassiveMotionFunc ( Mouse );
-+ glutMenuStatusFunc( processMenuStatus );
- glDisable(GL_DITHER);
- glLightModelfv(GL_LIGHT_MODEL_TWO_SIDE, lmodel_oneside);
- glCullFace ( GL_BACK );
-diff -uwrN cgx_2.10.ORIG/src/extUtil.h cgx_2.10/src/extUtil.h
---- src/extUtil.h 2016-02-13 02:21:44.342442000 +0100
-+++ cgx_2.10/src/extUtil.h 2016-03-08 10:55:36.194863375 +0100
-@@ -34,7 +34,7 @@
- }
- #endif
- #else
-- #include <GL/glut_cgx.h>
-+ #include <GL/glut.h>
- #endif
-
- #define PI 3.14159265358979323846264338327950288 \ No newline at end of file
diff --git a/sci-libs/calculix-cgx/metadata.xml b/sci-libs/calculix-cgx/metadata.xml
deleted file mode 100644
index ae9640ffb..000000000
--- a/sci-libs/calculix-cgx/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
-</pkgmetadata>