aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/petsc/ChangeLog5
-rw-r--r--sci-mathematics/petsc/Manifest4
-rw-r--r--sci-mathematics/petsc/petsc-3.1_p5.ebuild4
3 files changed, 9 insertions, 4 deletions
diff --git a/sci-mathematics/petsc/ChangeLog b/sci-mathematics/petsc/ChangeLog
index f167e76ef..e9535e963 100644
--- a/sci-mathematics/petsc/ChangeLog
+++ b/sci-mathematics/petsc/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Oct 2010; Jens-Malte Gottfried <jmgottfried@web.de>
+ petsc-3.1_p5.ebuild:
+ appending fortran compilers to command line only if fortran use-flag is
+ set
+
*petsc-3.1_p5 (06 Oct 2010)
06 Oct 2010; Jens-Malte Gottfried <jmgottfried@web.de>
diff --git a/sci-mathematics/petsc/Manifest b/sci-mathematics/petsc/Manifest
index ce552cdc2..770deee2a 100644
--- a/sci-mathematics/petsc/Manifest
+++ b/sci-mathematics/petsc/Manifest
@@ -3,6 +3,6 @@ AUX fix-mpiuni.patch 456 RMD160 2e69463821de6c3279a3b04b3b4b149ee354fffe SHA1 6c
DIST petsc-3.1-p4.tar.gz 15455558 RMD160 42d1c587ab1a2676f62de866afe8c43365a1b236 SHA1 4516e74e7ea349fed58b26963cfa3747ef07c62e SHA256 4e9abb2d6a07e49ba77459398871c3f91c50669979f7e9d5017009615d2a24af
DIST petsc-3.1-p5.tar.gz 15456384 RMD160 c97e6cf9e000c6eb635a5c76d006b7f8b84b3320 SHA1 e884e3f670093fff66fe1a3964b2f6bfc58543ce SHA256 193c7f8a5826a2bfd47a915f74e87d31a67339f89129aadb16e7b4b9e9dbf7e1
EBUILD petsc-3.1_p4.ebuild 4138 RMD160 32626757ecff1e6a512bb33fbededbb7bbf9326a SHA1 af5aeed15c6cfc12dbc3eb579fb244304a50e786 SHA256 413b705b42b9db6059176b21dd18089babab1f919b184d8195a841f3557034d1
-EBUILD petsc-3.1_p5.ebuild 3367 RMD160 ff1f32f8156a4e3202394b7adbda362b45b6f36c SHA1 19f4b1cabb55a758e85fb3720ee11da9371ecf60 SHA256 639469e91fb84f3dea4e478ecf35968de7126539c80ccbd6f4030bbb73e3a961
-MISC ChangeLog 700 RMD160 b5691a8e2b6dc0fd90acbc994e937714a2bac443 SHA1 c8cba3cb3ce74a4aa6557de2aeb03b771b59719a SHA256 b4f9521b1c7baec8af3fe1f7569386cd75b2552c3534f6d1f2d9d60673d13357
+EBUILD petsc-3.1_p5.ebuild 3397 RMD160 5a4cca5bdfb36691cd2e61c01e774e3230430226 SHA1 4b3b319728a1f7a8c7f08ba1accf689019980870 SHA256 69dcc674623a6f01d28593210e35e3a0b76a0cadc52d68340be4d2cc0996d5f2
+MISC ChangeLog 861 RMD160 e6f9692e6a514f3ff815f8389eefef9de0bd2c34 SHA1 480418df57d9efb96495db4791d498f99ac7bf3f SHA256 fe16642d08cca0ebf2ac366ec20a964a6bda1b7edd8342317b5b99cb54a48a9d
MISC metadata.xml 270 RMD160 095cc24d79cf505fb399f4efe83c1fbd669a4777 SHA1 d694ac481815815d35bc28c0653b02b3c4bbcd08 SHA256 34185c01f89f4dac0de8133ad0d6f6e36f0e2c83f958a6cb03d0ae0f30fda007
diff --git a/sci-mathematics/petsc/petsc-3.1_p5.ebuild b/sci-mathematics/petsc/petsc-3.1_p5.ebuild
index 7c5c64f92..aa99a6aa9 100644
--- a/sci-mathematics/petsc/petsc-3.1_p5.ebuild
+++ b/sci-mathematics/petsc/petsc-3.1_p5.ebuild
@@ -45,12 +45,12 @@ src_configure(){
if use mpi; then
myconf="${myconf} --with-cc=/usr/bin/mpicc"
myconf="${myconf} --with-cxx=/usr/bin/mpicxx"
- myconf="${myconf} --with-fc=/usr/bin/mpif77"
+ use fortran && myconf="${myconf} --with-fc=/usr/bin/mpif77"
myconf="${myconf} --with-mpi=1 --with-mpi-compilers=1"
else
myconf="${myconf} --with-cc=$(tc-getCC)"
myconf="${myconf} --with-cxx=$(tc-getCXX)"
- myconf="${myconf} --with-fc=$(tc-getF77)"
+ use fortran && myconf="${myconf} --with-fc=$(tc-getF77)"
myconf="${myconf} --with-mpi=0"
fi