aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/pythontex/ChangeLog6
-rw-r--r--dev-tex/pythontex/pythontex-0.14-r1.ebuild (renamed from dev-tex/pythontex/pythontex-0.14.ebuild)2
-rw-r--r--dev-tex/pythontex/pythontex-9999.ebuild8
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-tex/pythontex/ChangeLog b/dev-tex/pythontex/ChangeLog
index 23ecc71cd..a608dfc2f 100644
--- a/dev-tex/pythontex/ChangeLog
+++ b/dev-tex/pythontex/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*pythontex-0.14-r1 (12 May 2015)
+
+ 12 May 2015; Justin Lecher <jlec@gentoo.org> +pythontex-0.14-r1.ebuild,
+ -pythontex-0.14.ebuild, pythontex-9999.ebuild:
+ dev-tex/pythontex: Fix installation of latex files, bug #548534
+
*pythontex-0.14 (09 Mar 2015)
09 Mar 2015; Justin Lecher <jlec@gentoo.org> +pythontex-0.14.ebuild,
diff --git a/dev-tex/pythontex/pythontex-0.14.ebuild b/dev-tex/pythontex/pythontex-0.14-r1.ebuild
index 252dcdcbb..d49ef7f23 100644
--- a/dev-tex/pythontex/pythontex-0.14.ebuild
+++ b/dev-tex/pythontex/pythontex-0.14-r1.ebuild
@@ -53,5 +53,5 @@ src_install() {
}
python_foreach_impl installation
- latex-package_src_doinstall ${PN}.{dtx,ins,sty}
+ latex-package_src_doinstall dtx ins sty
}
diff --git a/dev-tex/pythontex/pythontex-9999.ebuild b/dev-tex/pythontex/pythontex-9999.ebuild
index 92b36ac07..c9c538824 100644
--- a/dev-tex/pythontex/pythontex-9999.ebuild
+++ b/dev-tex/pythontex/pythontex-9999.ebuild
@@ -43,16 +43,16 @@ src_install() {
cd ${PN} || die
installation() {
- if python_is_python3; then
+ if python_is_python3; then
python_domodule {de,}${PN}3.py
- else
+ else
python_domodule {de,}${PN}2.py
- fi
+ fi
python_domodule ${PN}_{engines,utils}.py
python_doscript {de,}${PN}.py syncpdb.py
python_optimize
}
python_foreach_impl installation
- latex-package_src_doinstall ${PN}.{dtx,ins,sty}
+ latex-package_src_doinstall dtx ins sty
}