aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/libspatialindex/Manifest2
-rw-r--r--sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch15
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild19
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.5.ebuild37
-rw-r--r--sci-libs/libspatialindex/metadata.xml6
5 files changed, 58 insertions, 21 deletions
diff --git a/sci-libs/libspatialindex/Manifest b/sci-libs/libspatialindex/Manifest
index 5150c659b..9b0e8058c 100644
--- a/sci-libs/libspatialindex/Manifest
+++ b/sci-libs/libspatialindex/Manifest
@@ -1 +1 @@
-DIST spatialindex-src-1.6.1.tar.bz2 346819 SHA256 42dc4149c04f7436632b3e15d5470fe80172e91f16a16665ffc5587b8c576fe4
+DIST spatialindex-src-1.8.5.tar.bz2 407871 SHA256 31ec0a9305c3bd6b4ad60a5261cba5402366dd7d1969a8846099717778e9a50a SHA512 d3e47982cc2809d04490fae27796b31cdb59675790010d8b45e1a98b5a23048a4a44e321a2470dd36c01aba6f6e7620cafc4988a02b55e4f59d1b7fa9b588b06 WHIRLPOOL 498fc14ff9aea93a362cf7719e20f77bd84b5f6be94e8b1bfb3bbb00bb04d2bf1e9cc1156090c8f7f37e0ca4b64ac5701e1c91476591f401bf9f738b0d6efa1f
diff --git a/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch
new file mode 100644
index 000000000..446452dc9
--- /dev/null
+++ b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch
@@ -0,0 +1,15 @@
+--- spatialindex-src-1.8.0/configure.ac
++++ spatialindex-src-1.8.0/configure.ac
+@@ -49,10 +49,10 @@
+ AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging [default=$debug_default]],, enable_debug=$debug_default)
+
+ if test "x$enable_debug" = "xyes"; then
+- CXXFLAGS="$CXXFLAGS -g -DDEBUG"
++ CXXFLAGS="$CXXFLAGS -DDEBUG"
+ AC_MSG_RESULT(checking wether debug information is enabled... yes)
+ else
+- CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+ AC_MSG_RESULT(checking wether debug information is enabled... no)
+ fi
+
diff --git a/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild b/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild
deleted file mode 100644
index cb5a9d9a2..000000000
--- a/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-MY_PN="spatialindex-src"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="General framework for developing spatial indices"
-HOMEPAGE="http://trac.gispython.org/spatialindex/wiki"
-SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.5.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.5.ebuild
new file mode 100644
index 000000000..e6725933f
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2014 Julian Ospald <hasufell@posteo.de>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0/4"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.1-QA.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/sci-libs/libspatialindex/metadata.xml b/sci-libs/libspatialindex/metadata.xml
index 5f27678c1..8d63d2790 100644
--- a/sci-libs/libspatialindex/metadata.xml
+++ b/sci-libs/libspatialindex/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-geosciences</herd>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>hasufell@posteo.de</email>
+ <name>Julian Ospald</name>
+ </maintainer>
</pkgmetadata>