aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/openbabel-java/ChangeLog10
-rw-r--r--sci-chemistry/openbabel-java/metadata.xml12
-rw-r--r--sci-chemistry/openbabel-java/openbabel-java-9999.ebuild63
-rw-r--r--sci-chemistry/openbabel-perl/ChangeLog10
-rw-r--r--sci-chemistry/openbabel-perl/metadata.xml12
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild64
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog10
-rw-r--r--sci-chemistry/openbabel-python/metadata.xml12
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild84
-rw-r--r--sci-chemistry/openbabel-ruby/ChangeLog10
-rw-r--r--sci-chemistry/openbabel-ruby/metadata.xml12
-rw-r--r--sci-chemistry/openbabel-ruby/openbabel-ruby-9999.ebuild78
-rw-r--r--sci-chemistry/openbabel/ChangeLog10
-rw-r--r--sci-chemistry/openbabel/metadata.xml20
-rw-r--r--sci-chemistry/openbabel/openbabel-9999.ebuild87
-rw-r--r--sci-physics/abinit/ChangeLog6
-rw-r--r--sci-physics/abinit/abinit-7.4.2.ebuild15
17 files changed, 504 insertions, 11 deletions
diff --git a/sci-chemistry/openbabel-java/ChangeLog b/sci-chemistry/openbabel-java/ChangeLog
new file mode 100644
index 000000000..36777b53b
--- /dev/null
+++ b/sci-chemistry/openbabel-java/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel-java
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-java-9999 (24 Sep 2013)
+
+ 24 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-java-9999.ebuild,
+ +metadata.xml:
+ Add live ebuild.
+
diff --git a/sci-chemistry/openbabel-java/metadata.xml b/sci-chemistry/openbabel-java/metadata.xml
new file mode 100644
index 000000000..13ecd9d5d
--- /dev/null
+++ b/sci-chemistry/openbabel-java/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ Open Babel is a chemical toolbox designed to speak the many languages of
+ chemical data. It's an open, collaborative project allowing anyone to
+ search, convert, analyze, or store data from molecular modeling, chemistry,
+ solid-state materials, biochemistry, or related areas. This package enables
+ to access Open Babel library from Java (Scala, etc.) programs.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild b/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild
new file mode 100644
index 000000000..fc7ca33e3
--- /dev/null
+++ b/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils eutils java-pkg-2 git-2
+
+DESCRIPTION="Java bindings for OpenBabel"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEP="~sci-chemistry/openbabel-${PV}"
+
+DEPEND="${COMMON_DEP}
+ >=dev-lang/swig-1.3.29
+ >=virtual/jdk-1.7"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.7"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_RPATH=
+ -DBINDINGS_ONLY=ON
+ -DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
+ -DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
+ -DLIB_INSTALL_DIR=${S}/$(get_libdir)
+ -DJAVA_BINDINGS=ON
+ -DJAVA_INCLUDE_PATH=${EPREFIX}$(java-config-2 -o)/include
+ -DJAVA_INCLUDE_PATH2=${EPREFIX}$(java-config-2 -o)/include/linux
+ -DJAVA_AWT_INCLUDE_PATH=${EPREFIX}$(java-config-2 -o)/include
+ -DJAVA_AWT_LIBRARY=${EPREFIX}$(java-config-2 -o)/jre/lib/${ABI}/libjawt.so
+ -DJAVA_JVM_LIBRARY=${EPREFIX}$(java-config-2 -o)/jre/lib/${ABI}/server/libjvm.so
+ -DRUN_SWIG=ON"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_make bindings_java
+}
+
+src_test() {
+ cd scripts/java || die
+ einfo "Running test: ${S}/scripts/java/OBTest.java"
+ CLASSPATH="openbabel.jar" LD_LIBRARY_PATH="${S}/$(get_libdir)" javac OBTest.java || die
+ CLASSPATH=".:openbabel.jar" LD_LIBRARY_PATH="${S}/$(get_libdir)" java OBTest || die
+}
+
+src_install() {
+ # Let cmake take care of RPATH setting and the like
+ cmake -DCOMPONENT=bindings_java -P cmake_install.cmake
+
+ java-pkg_dojar "${S}/$(get_libdir)/openbabel.jar"
+ java-pkg_doso "${S}/$(get_libdir)/libopenbabel_java.so"
+}
diff --git a/sci-chemistry/openbabel-perl/ChangeLog b/sci-chemistry/openbabel-perl/ChangeLog
new file mode 100644
index 000000000..14040e1a2
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel-perl
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-perl-9999 (26 Sep 2013)
+
+ 26 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-perl-9999.ebuild,
+ +metadata.xml:
+ Add live ebuild.
+
diff --git a/sci-chemistry/openbabel-perl/metadata.xml b/sci-chemistry/openbabel-perl/metadata.xml
new file mode 100644
index 000000000..075056290
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ Open Babel is a chemical toolbox designed to speak the many languages of
+ chemical data. It's an open, collaborative project allowing anyone to
+ search, convert, analyze, or store data from molecular modeling, chemistry,
+ solid-state materials, biochemistry, or related areas.
+ This package enables to access Open Babel library from Perl programs.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
new file mode 100644
index 000000000..2a352a8c2
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils eutils git-2 perl-module
+
+DESCRIPTION="Perl bindings for OpenBabel"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ ~sci-chemistry/openbabel-${PV}"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8
+ >=dev-lang/swig-2"
+
+S="${WORKDIR}/openbabel-${PV}"
+
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_configure() {
+ perl_set_version
+ local mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_RPATH=
+ -DBINDINGS_ONLY=ON
+ -DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
+ -DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
+ -DLIB_INSTALL_DIR=${ED}/${VENDOR_ARCH}
+ -DPERL_BINDINGS=ON
+ -DRUN_SWIG=ON"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile bindings_perl
+}
+
+src_test() {
+ mkdir "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry"
+ cp \
+ "${CMAKE_USE_DIR}/scripts/perl/OpenBabel.pm" \
+ "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry/"
+ for i in "${CMAKE_USE_DIR}"/scripts/perl/t/*
+ do
+ einfo "Running test: ${i}"
+ perl -I"${CMAKE_BUILD_DIR}/$(get_libdir)" "${i}" || die
+ done
+}
+
+src_install() {
+ cd "${CMAKE_BUILD_DIR}"
+ cmake -DCOMPONENT=bindings_perl -P cmake_install.cmake
+}
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
new file mode 100644
index 000000000..0f52b419e
--- /dev/null
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel-python
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-python-9999 (26 Sep 2013)
+
+ 26 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-python-9999.ebuild,
+ +metadata.xml:
+ Add live ebuild.
+
diff --git a/sci-chemistry/openbabel-python/metadata.xml b/sci-chemistry/openbabel-python/metadata.xml
new file mode 100644
index 000000000..f85780135
--- /dev/null
+++ b/sci-chemistry/openbabel-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ Open Babel is a chemical toolbox designed to speak the many languages of
+ chemical data. It's an open, collaborative project allowing anyone to
+ search, convert, analyze, or store data from molecular modeling, chemistry,
+ solid-state materials, biochemistry, or related areas. This package enables
+ to access Open Babel library from Python programs.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
new file mode 100644
index 000000000..f0b113268
--- /dev/null
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit cmake-utils eutils git-2 multilib python-r1
+
+DESCRIPTION="Python bindings for OpenBabel (including Pybel)"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !sci-chemistry/babel
+ ~sci-chemistry/openbabel-${PV}
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8
+ >=dev-lang/swig-2"
+
+S="${WORKDIR}"/openbabel-${PV}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed \
+ -e "s:\"\.\.\":\"${EPREFIX}/usr\":g" \
+ -i test/testbabel.py || die
+ swig -python -c++ -small -O -templatereduce -naturalvar \
+ -I"${EPREFIX}/usr/include/openbabel-2.0" \
+ -o scripts/python/openbabel-python.cpp \
+ -DHAVE_EIGEN \
+ -outdir scripts/python \
+ scripts/openbabel-python.i \
+ || die "Regeneration of openbabel-python.cpp failed"
+}
+
+src_configure() {
+ my_impl_src_configure() {
+ local mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_RPATH=
+ -DBINDINGS_ONLY=ON
+ -DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
+ -DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
+ -DLIB_INSTALL_DIR=${ED}/usr/$(get_libdir)/${EPYTHON}/site-packages
+ -DPYTHON_BINDINGS=ON
+ -DPYTHON_EXECUTABLE=${PYTHON}
+ -DPYTHON_INCLUDE_DIR=${EPREFIX}/usr/include/${EPYTHON}
+ -DPYTHON_LIBRARY=${EPREFIX}/usr/$(get_libdir)/lib${EPYTHON}.so
+ -DENABLE_TESTS=ON"
+
+ cmake-utils_src_configure
+ }
+
+ python_foreach_impl my_impl_src_configure
+}
+
+src_compile() {
+ python_parallel_foreach_impl cmake-utils_src_make bindings_python
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test -R py
+}
+
+src_install() {
+ my_impl_src_install() {
+ cd "${BUILD_DIR}" || die
+
+ cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+
+ python_optimize
+ }
+
+ python_foreach_impl my_impl_src_install
+}
diff --git a/sci-chemistry/openbabel-ruby/ChangeLog b/sci-chemistry/openbabel-ruby/ChangeLog
new file mode 100644
index 000000000..6ee5574ab
--- /dev/null
+++ b/sci-chemistry/openbabel-ruby/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel-ruby
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-ruby-9999 (26 Sep 2013)
+
+ 26 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-ruby-9999.ebuild,
+ +metadata.xml:
+ Add live ebuild.
+
diff --git a/sci-chemistry/openbabel-ruby/metadata.xml b/sci-chemistry/openbabel-ruby/metadata.xml
new file mode 100644
index 000000000..e787ba02a
--- /dev/null
+++ b/sci-chemistry/openbabel-ruby/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ Open Babel is a chemical toolbox designed to speak the many languages of
+ chemical data. It's an open, collaborative project allowing anyone to
+ search, convert, analyze, or store data from molecular modeling, chemistry,
+ solid-state materials, biochemistry, or related areas. This package enables
+ to access Open Babel library from Ruby programs.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel-ruby/openbabel-ruby-9999.ebuild b/sci-chemistry/openbabel-ruby/openbabel-ruby-9999.ebuild
new file mode 100644
index 000000000..28aa2a409
--- /dev/null
+++ b/sci-chemistry/openbabel-ruby/openbabel-ruby-9999.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+inherit cmake-utils eutils ruby-ng git-2
+
+DESCRIPTION="Ruby bindings for OpenBabel"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="${DEPEND}
+ ~sci-chemistry/openbabel-${PV}
+ >=dev-lang/swig-1.3.29"
+RDEPEND="${RDEPEND}
+ ~sci-chemistry/openbabel-${PV}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ all_ruby_unpack() {
+ git-2_src_unpack
+ }
+
+ ruby-ng_src_unpack
+}
+
+all_ruby_prepare() {
+ swig -ruby -c++ -small -O -templatereduce -naturalvar -autorename \
+ -I"${EPREFIX}/usr/include/openbabel-2.0" \
+ -o scripts/ruby/openbabel-ruby.cpp \
+ -outdir scripts/ruby \
+ scripts/openbabel-ruby.i \
+ || die "Generation of openbabel-ruby.cpp failed"
+ sed 's/void Init_OpenBabel/void Init_openbabel/' -i scripts/ruby/openbabel-ruby.cpp
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR="${WORKDIR}/${environment}/${P}"
+ local mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_RPATH=
+ -DBINDINGS_ONLY=ON
+ -DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
+ -DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
+ -DLIB_INSTALL_DIR=${ED}/$(ruby_rbconfig_value sitearchdir)
+ -DRUBY_BINDINGS=ON
+ -DRUBY_EXECUTABLE=${RUBY}
+ -DRUBY_INCLUDE_DIR=$(ruby_get_hdrdir) -I$(ruby_get_hdrdir)/$(ruby_rbconfig_value sitearch)
+ -DRUBY_LIBRARY=$(ruby_get_libruby)"
+
+ cmake-utils_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR="${WORKDIR}/${environment}/${P}"
+ cmake-utils_src_make bindings_ruby
+}
+
+each_ruby_test() {
+ for i in scripts/ruby/examples/*
+ do
+ einfo "Running test: ${WORKDIR}/${environment}/${P}/${i}"
+ ${RUBY} -I"${WORKDIR}/${environment}/${P}/$(get_libdir)" "${i}" || die
+ done
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR="${WORKDIR}/${environment}/${P}"
+ cmake -DCOMPONENT=bindings_ruby -P cmake_install.cmake
+}
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
new file mode 100644
index 000000000..be72d72b1
--- /dev/null
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-9999 (24 Sep 2013)
+
+ 24 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-9999.ebuild,
+ +metadata.xml:
+ Add live ebuild with Java, Perl, Python and Ruby bindings.
+
diff --git a/sci-chemistry/openbabel/metadata.xml b/sci-chemistry/openbabel/metadata.xml
new file mode 100644
index 000000000..f0fb5eeb9
--- /dev/null
+++ b/sci-chemistry/openbabel/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ Open Babel is a chemical toolbox designed to speak the many languages of
+ chemical data. It's an open, collaborative project allowing anyone to
+ search, convert, analyze, or store data from molecular modeling, chemistry,
+ solid-state materials, biochemistry, or related areas.
+ </longdescription>
+ <use>
+ <flag name="doc">Install API dicumentation.</flag>
+ <flag name="openmp">Enable parallelization using OpenMP.</flag>
+ <flag name="java">Install Java bindings.</flag>
+ <flag name="perl">Install Perl bindings.</flag>
+ <flag name="python">Install Python bindings and PyBel.</flag>
+ <flag name="ruby">Install Ruby bindings.</flag>
+ <flag name="wxwidgets">Build Open Babel GUI.</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel/openbabel-9999.ebuild b/sci-chemistry/openbabel/openbabel-9999.ebuild
new file mode 100644
index 000000000..d57d78d8e
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit cmake-utils eutils git-2 wxwidgets
+
+DESCRIPTION="Interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc java openmp perl python ruby test wxwidgets"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/libxml2:2
+ !sci-chemistry/babel
+ sci-libs/inchi
+ sys-libs/zlib
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8
+ doc? ( app-doc/doxygen )"
+PDEPEND="
+ java? ( sci-chemistry/openbabel-java )
+ perl? ( sci-chemistry/openbabel-perl )
+ python? ( sci-chemistry/openbabel-python )
+ ruby? ( sci-chemistry/openbabel-ruby )"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use_enable openmp OPENMP)
+ $(cmake-utils_use wxwidgets BUILD_GUI)"
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DPYTHON_EXECUTABLE=false
+ $(cmake-utils_use wxwidgets BUILD_GUI)
+ $(cmake-utils_use_enable openmp OPENMP)
+ $(cmake-utils_use_enable test TESTS)"
+
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test -E py
+}
+
+src_install() {
+ dohtml doc/{*.html,*.png}
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/API/html
+ doins doc/API/html/*
+ fi
+ cmake-utils_src_install
+
+ # Ensure that modules are allways in openbabel/${PV}
+ pushd "${ED}/usr/$(get_libdir)/openbabel"
+ ver=$(ls -d * | grep -E '([0-9]+[.]){2}[0-9]+')
+ if [ "${ver}" != "${PV}" ] ; then
+ ln -s ${ver} ${PV}
+ fi
+ popd
+}
diff --git a/sci-physics/abinit/ChangeLog b/sci-physics/abinit/ChangeLog
index 4cde21a8f..ac91ec67e 100644
--- a/sci-physics/abinit/ChangeLog
+++ b/sci-physics/abinit/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Sep 2013; Honza Macháček <Hloupy.Honza@centrum.cz> abinit-7.4.2.ebuild:
+ sci-physics/abinit-7.4.2 finally made to actually build and install (tests
+ have to be configured for their Makefile to be where it is looked for during
+ the installation). Testing scripts, written for Python 2, made to run in an
+ environment with Python 3 selected as the main interpreter.
+
19 Sep 2013; Honza Macháček <Hloupy.Honza@centrum.cz> metadata.xml:
The metadata of sci-physics/abinit augmented by the description of the etsf_io
USE flag.
diff --git a/sci-physics/abinit/abinit-7.4.2.ebuild b/sci-physics/abinit/abinit-7.4.2.ebuild
index 41441a68f..d46593ff2 100644
--- a/sci-physics/abinit/abinit-7.4.2.ebuild
+++ b/sci-physics/abinit/abinit-7.4.2.ebuild
@@ -182,6 +182,7 @@ src_prepare() {
"${FILESDIR}"/7.4.2-syntax.patch
eautoreconf
sed -e"s/\(grep '\^-\)\(\[LloW\]\)'/\1\\\(\2\\\|pthread\\\)'/g" -i configure
+ python_fix_shebang "${S}"/tests
}
src_configure() {
@@ -234,6 +235,7 @@ src_configure() {
local myeconfargs=(
--enable-clib
--enable-exports
+ --enable-pkg-check
$(use_enable debug debug enhanced)
$(use_enable mpi)
$(use_enable mpi mpi-io)
@@ -263,7 +265,7 @@ src_configure() {
"$(use bigdft && echo "--with-bigdft-incs=${modules}")"
"$(use bigdft && echo "--with-bigdft-libs=$($(tc-getPKG_CONFIG) --libs bigdft)")"
"$(use libxc && echo "--with-libxc-incs=${modules}")"
- "$(use libxc && echo "--with-libxc-libs=-lxc")"
+ "$(use libxc && echo "--with-libxc-libs=$($(tc-getPKG_CONFIG) --libs libxc)")"
"$(use wannier && echo "--with-wannier90-bins=/usr/bin")"
"$(use wannier && echo "--with-wannier90-incs=${modules}")"
"$(use wannier && echo "--with-wannier90-libs=-lwannier $($(tc-getPKG_CONFIG) --libs lapack)")"
@@ -293,17 +295,8 @@ src_compile() {
src_test() {
einfo "The tests take quite a while, easily several hours or even days"
- # autotools-utils_src_test() expanded
- _check_build_dir
- pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null
- # again something the autotools-utils function cannot be called to do
- # now quite a lot of work actually
- mkdir -p tests
-
- python2 "${S}"/tests/runtests.py -w tests/ -b "${AUTOTOOLS_BUILD_DIR}"
-
- popd > /dev/null
+ autotools-utils_src_test
}
src_install() {